0 Replies Latest reply on Nov 4, 2010 6:39 PM by BennyB23

    VideoPlayer scrubBar issue

    BennyB23

      I have an application that I'm working on that has two menus, an audio menu and a video menu, and both share a spark VideoPlayer component. I've run into a problem where the VideoPlayer skin's seekBar isn't working when it's playing back videos and the durationDisplay label isn't updating. The videos still play and all other aspects of the skin appear to be functional and there are no problems handling the audio menu. During the playback of videos the seekBar thumb doesn't move, however it is able to receive focus and a MouseClick will trigger the dataTip popup with the time associated with the currentTimeDisplay value. Attempting to drag the thumb to the left, even though it's already all the way to left will set the dataTip text to zero, but the mouse down, up, and drag have no effect on the playback and the mouse events don't throw any errors in debug mode (I'm not sure if it would, but I'm just noting it).

       

      I'm using a custom skin for the VideoPlayer, but the problem is persistent even with the default spark skin. The media format for the audio menu is m4a and the video format is flv (my copy of media encoder isn't behaving, but that's another issue altogether...). I've tested the project in Firefox and Safari and the behavior is the same in each browser.

       

      I created a separate diagnostic file, which just contains the information and UI for the video menu and it runs without any problems, so I'm pretty stumped on how to go about fixing this issue. Any suggestions would be greatly appreciated.

       

      Thanks~Benny