3 Replies Latest reply on Jul 17, 2007 7:38 AM by burbankbiker

    Flex Builder Web Server?

    burbankbiker
      If I build my project in Flex Builder and click the green run button, my project loads in a browser and runs great. But the web address is file:///C:/lcds/jrun4/servers/default/myProject/bin/myProject.html. If I try to view that same page by going to localhost:8700/myProject/bin/myProject.html I get a blank grey screen. It's the typical Flex grey default background but my interface isn't there.

      Any ideas?

      I'm stumped.

        • 1. Re: Flex Builder Web Server?
          ntsiii Level 3
          Did you copy everything from the bin folder? Including the .js files?

          Are you doing any data service calls?


          Tracy
          • 2. Re: Flex Builder Web Server?
            burbankbiker Level 1
            Not sure what you mean by "copy"...

            Should I be moving everything out of the bin folder in order for it to run? Can I not just include the bin folder in my path? As in http://localhost:8700/samples/MyProject/bin/MyProject.html

            I tried, for the sake of it, copying all the files in the bin folder and moving them out of the bin folder. Now everything is in the project's root directory. Still does the same thing.

            Still stumped.

            • 3. Re: Flex Builder Web Server?
              burbankbiker Level 1
              okay... a bit more digging back to the beginning of my setup...

              if I try to view the LCDS samples I get server 500 errors with the following:


              java.lang.NullPointerException
              at jrun.servlet.JRunRequestDispatcher.invoke(JRunRequestDispatcher.java:258)
              at jrun.servlet.ServletEngineService.dispatch(ServletEngineService.java:541)
              at jrun.servlet.http.WebService.invokeRunnable(WebService.java:172)
              at jrunx.scheduler.ThreadPool$ThreadThrottle.invokeRunnable(ThreadPool.java:428)
              at jrunx.scheduler.WorkerThread.run(WorkerThread.java:66)


              Sounds like something broke, obviously, but what do I need to do... reinstall LCDS? Java? The Flex compiler?