3 Replies Latest reply on Jun 7, 2011 12:23 AM by shakesvongreen

    Modeling Plug-in is incompatible with Eclipse 3.6 (Helios)

    eliasbalasis

      Has anyone tried to run "Application Modeling Plug-in for Adobe Flash Builder 4" with Eclipse 3.6 (Helios)?

       

      I did

      and found out that the "Data Model" editor is not opening because of some plug-in related errors

       

      More specifically, Eclipse "Error Log" reports the following when opening the data model editor on a Flex project

       

      Message:

      Plug-in: org.eclipse.wst.validation

      Stack Trace:

      java.lang.NullPointerException

      at org.eclipse.wst.validation.internal.ValManager$1.visit(ValManager.java:664)

      at org.eclipse.wst.validation.internal.ValManager.accept(ValManager.java:810)

      at org.eclipse.wst.validation.internal.ValManager.validate(ValManager.java:669)

      at org.eclipse.wst.validation.internal.ValidationRunner.execute(ValidationRunner.java:134)

      at org.eclipse.wst.validation.internal.ValidationRunner.validate(ValidationRunner.java:68)

      at com.adobe.model.derived.editor.xml.validator.FiberValidationRunner.runInWorkspace(FiberVa lidationRunner.java:116)

      at org.eclipse.core.internal.resources.InternalWorkspaceJob.run(InternalWorkspaceJob.java:38 )

      at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)

      Message: Error while creating editor buttons
      Plug-in: com.adobe.model.utils
      Stack Trace:
      java.lang.IllegalArgumentException:
      at org.eclipse.core.runtime.Assert.isLegal(Assert.java:63)
      at org.eclipse.core.runtime.Assert.isLegal(Assert.java:47)
      at org.eclipse.ui.part.EditorPart.setInput(EditorPart.java:224)
      at com.adobe.model.design.editor.FiberDesignEditor.setInput(FiberDesignEditor.java:431)
      at com.adobe.model.derived.design.GraphicalEditor.init(GraphicalEditor.java:366)
      at com.adobe.model.derived.editor.FiberMultiPageEditorPart.addPage(FiberMultiPageEditorPart. java:194)
      at com.adobe.model.derived.editor.FiberMultiPageEditorPart.addPage(FiberMultiPageEditorPart. java:174)
      at com.adobe.model.editor.FiberXMLEditor.createAndAddDesignEditor(FiberXMLEditor.java:391)
      at com.adobe.model.editor.FiberXMLEditor.createMultiViews(FiberXMLEditor.java:433)
      at com.adobe.model.editor.FiberXMLEditor.createPages(FiberXMLEditor.java:374)
      at com.adobe.model.derived.editor.FiberMultiPageEditorPart.createPartControl(FiberMultiPageE ditorPart.java:259)
      at org.eclipse.ui.internal.EditorReference.createPartHelper(EditorReference.java:670)
      at org.eclipse.ui.internal.EditorReference.createPart(EditorReference.java:465)
      at org.eclipse.ui.internal.WorkbenchPartReference.getPart(WorkbenchPartReference.java:595)
      at org.eclipse.ui.internal.PartPane.setVisible(PartPane.java:313)
      at org.eclipse.ui.internal.presentations.PresentablePart.setVisible(PresentablePart.java:180 )
      at org.eclipse.ui.internal.presentations.util.PresentablePartFolder.select(PresentablePartFo lder.java:270)
      at org.eclipse.ui.internal.presentations.util.LeftToRightTabOrder.select(LeftToRightTabOrder .java:65)
      at org.eclipse.ui.internal.presentations.util.TabbedStackPresentation.selectPart(TabbedStack Presentation.java:473)
      at org.eclipse.ui.internal.PartStack.refreshPresentationSelection(PartStack.java:1254)
      at org.eclipse.ui.internal.PartStack.setSelection(PartStack.java:1207)
      at org.eclipse.ui.internal.PartStack.showPart(PartStack.java:1606)
      at org.eclipse.ui.internal.PartStack.add(PartStack.java:497)
      at org.eclipse.ui.internal.EditorStack.add(EditorStack.java:103)
      at org.eclipse.ui.internal.PartStack.add(PartStack.java:483)
      at org.eclipse.ui.internal.EditorStack.add(EditorStack.java:112)
      at org.eclipse.ui.internal.EditorSashContainer.addEditor(EditorSashContainer.java:63)
      at org.eclipse.ui.internal.EditorAreaHelper.addToLayout(EditorAreaHelper.java:225)
      at org.eclipse.ui.internal.EditorAreaHelper.addEditor(EditorAreaHelper.java:213)
      at org.eclipse.ui.internal.EditorManager.createEditorTab(EditorManager.java:778)
      at org.eclipse.ui.internal.EditorManager.openEditorFromDescriptor(EditorManager.java:677)
      at org.eclipse.ui.internal.EditorManager.openEditor(EditorManager.java:638)
      at org.eclipse.ui.internal.WorkbenchPage.busyOpenEditorBatched(WorkbenchPage.java:2860)
      at org.eclipse.ui.internal.WorkbenchPage.busyOpenEditor(WorkbenchPage.java:2768)
      at org.eclipse.ui.internal.WorkbenchPage.access$11(WorkbenchPage.java:2760)
      at org.eclipse.ui.internal.WorkbenchPage$10.run(WorkbenchPage.java:2711)
      at org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator.java:70)
      at org.eclipse.ui.internal.WorkbenchPage.openEditor(WorkbenchPage.java:2707)
      at org.eclipse.ui.internal.WorkbenchPage.openEditor(WorkbenchPage.java:2691)
      at org.eclipse.ui.internal.WorkbenchPage.openEditor(WorkbenchPage.java:2674)
      at com.adobe.model.fb.extensions.handlers.OpenModelHandler.execute(OpenModelHandler.java:237 )
      at org.eclipse.ui.internal.handlers.HandlerProxy.execute(HandlerProxy.java:293)
      at org.eclipse.core.commands.Command.executeWithChecks(Command.java:476)
      at org.eclipse.core.commands.ParameterizedCommand.executeWithChecks(ParameterizedCommand.jav a:508)
      at org.eclipse.ui.internal.handlers.HandlerService.executeCommand(HandlerService.java:169)
      at org.eclipse.ui.internal.handlers.SlaveHandlerService.executeCommand(SlaveHandlerService.j ava:241)
      at org.eclipse.ui.internal.handlers.SlaveHandlerService.executeCommand(SlaveHandlerService.j ava:241)
      at org.eclipse.ui.menus.CommandContributionItem.handleWidgetSelection(CommandContributionIte m.java:820)
      at org.eclipse.ui.menus.CommandContributionItem.access$19(CommandContributionItem.java:806)
      at org.eclipse.ui.menus.CommandContributionItem$5.handleEvent(CommandContributionItem.java:7 96)
      at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
      at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1053)
      at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:4066)
      at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3657)
      at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:2640)
      at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2604)
      at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2438)
      at org.eclipse.ui.internal.Workbench$7.run(Workbench.java:671)
      at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
      at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:664)
      at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)
      at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:115)
      at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
      at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLau ncher.java:110)
      at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.jav a:79)
      at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:369)
      at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:619)
      at org.eclipse.equinox.launcher.Main.basicRun(Main.java:574)
      at org.eclipse.equinox.launcher.Main.run(Main.java:1407)
      However, the plug-ing works perfectly under Eclipse 3.5

       

      I conclude that the plug-in is not compatible yet with Eclipse 3.6 (as the name of the downloaded archive suggests)

       

      Any plans for releasing an Eclipse 3.6 compatible version?