8 Replies Latest reply on Nov 11, 2010 12:31 PM by matthaze

    Play button will not work

    matthaze

      Hi!

       

      I'm running OS X 10.6.4 2.4 GHz core 2 duo with 4 GB of RAM on my mac.

       

      I was successfully using the software all day and then after changing the input and output sound settings, files will not play.  I have tried numerous formats and files and when I hit space or physically hit the play button, it says it's playing, but it is not.  The marker won't move at all.  Just sits still and no sound comes out.

       

      I attempted to change the sound preferences again to see if that would trigger it, and it did not.  It's set appropriately to built-in audio.

       

      Was working fine until that moment a bit ago.

       

      Thanks!

        • 1. Re: Play button will not work
          Charles VW Adobe Employee

          Out of curiosity, what does the status bar show while in this state.  I'm wondering if you look in the bottom-left corner of the app window if you see something like "Calculating Playback"

          • 2. Re: Play button will not work
            matthaze Level 1

            It says "Playing" on the status bar.  I've tried with a few different files and it says it with each.

            • 3. Re: Play button will not work
              JGrabowMST

              I had this similar problem, after setting Audition up to use my M-Audio ProFire 2626. After trying to use Audition again, without the 2626, it did not work, it would say playing, but not actually play. Once I got my interface plugged in again, it worked just fine.

               

              A bug? Maybe in how the software handles hardware changes. I've had similar Problems with Pro Tools 9, so if it works with my interfaces, then at least I know the software hasn't crapped out.

              • 4. Re: Play button will not work
                matthaze Level 1

                good point... I was attempting to use a CenTrance MicPort Pro though it earlier, but the recording was not a quality sound.  Very tin can-like.  It WAS after I unplugged it that playback didn't work. 

                 

                I just plugged my MicPort Pro in again, and still no playback.  Then after unplugging it again, still no playback.

                • 5. Re: Play button will not work
                  JGrabowMST Level 1

                  You've got me, but at the same time, I'm still thinking that maybe it has to do with how Audition handles hardware changes. In a sense, maybe once it's set to use one interface Core Audio might change, but Audition might not recognize the change.

                   

                  Is there a way to reset that? I don't spend 100% of my time on Mac, so I have to admit that I don't know that.

                   

                  Maybe someone from Adobe could comment on the effect 3rd party hardware has on Audition, and how Audition handles a change in that? I know Audition opens up and flat out says there's a change in hardware, but it still doesn't actually make that change...or so it seems?

                  • 6. Re: Play button will not work
                    Charles VW Adobe Employee

                    JGrabowMST wrote:

                     

                    Is there a way to reset that? I don't spend 100% of my time on Mac, so I have to admit that I don't know that.

                     

                    In general, you can hold down the [ Shift ] key on startup and Audition should ignore any previous preferences or settings.  However, this is a pretty blunt approach and wouldn't be helpful if you customized your app heavily.  Also, Audition should be pretty flexible with yanking out hardware and so forth, but it is difficult to test with every audio device that is out there (you guys are a tremendous help).

                    • 7. Re: Play button will not work
                      Scott Carver

                      In general, Audition won't automatically switch around your hardware configuration for you. Meaning - if you disconnect a device and then reconnect it, we should immediately pick it back up again with the previous settings and channel mappings intact - but we won't try to pick another device and use that one. When there's a hardware change, we should show a dialog notifying you that there's been a change, and giving you an option to open the hardware preferences to change your settings. If you disconnected a device, you'll see it show up as "Not working" in the hardware prefs.

                       

                      So - the play button issue...

                       

                      If you're set up to use a device, and that device is disconnected, you may experience a situation where you can't play (no device to play to). The solution there is to go to hardware prefs and choose another device.

                       

                      If you have a device connected (i.e. it's turned on, you've selected that device in the hardware prefs, it's not listed as "not working"), playback should always work. If you have problems at this point, some possible causes:

                      • Device can't play at the sample rate Audition wants to play at (try changing the sample rate in hardware prefs and see if it helps)
                      • Master clock issue (this can happen occasionally when you're using a different input and output devices, even different internal mac inputs/outputs, since these are actually separate devices - try switching the Master Clock to see if it fixes)
                      • Um, something else....

                      In general, any of these three things are potentially bugs, so even if you get it working eventually, you should report the issue - both so others can see what you did, but also so we can look into it and potentially improve things. Make sure you let us know all the hardware details (i.e. input device X, output device Y, sample rate, buffer size, clock set to X, etc etc).

                       

                      - Scott

                      • 8. Re: Play button will not work
                        matthaze Level 1

                        Great points so far!

                         

                        When I unplugged the device, a window did pop up and tell me the settings have been changed and if I would like to review them.  So it DID successfully do that, very happy about that.  And it was automatically set appropriately with the changes to input and output device.  But again, play STILL wouldn't work.  I could not play an audio file at all.

                         

                        I just tried the holding the shift at startup feature, and that did the trick!  I can play files again without a problem.

                         

                        So it must be something with changing audio devices so quickly.  I will let you know if it happens again.  (I use my micport pro daily so good chance it will)