2 Replies Latest reply on Nov 12, 2010 8:46 AM by LisaR18

    XPJ file appears to be corrupt -- have exhausted all known fixes


      Hello all,


      Before I forget, here's the rundown on our system:


      • RoboHelp 8, version (all patches up-to-date, to our knowledge); RoboHTML used exclusively
      • Microsoft Visual SourceSafe 2005, version 8.0.50727.42
      • Windows XP
      • Three help projects
        • Two on VSS; third does not work right from VSS, so we update it separately
        • One of the two on VSS appears to be corrupt (see below) -- RoboHelp hangs when trying to launch the XPJ file
        • All other help projects are fine
      • Four help authors


      Background of the problem:


      On Tuesday late afternoon, one of our authors was in the help project in question and had several topics checked out when our network went down. She closed the help project with the files still checked out, and when the network came back up, she went back in, got the expected messages about "files are checked out, do you want to replace them with the version from source control or keep them checked out and use your local copy." Since she didn't want to lose her changes, I instructed her to keep them checked out, and then check them back in when everything came up. However, when she tried to check them back in, RoboHelp hung. This was late in the day, so she closed down RH manually and resolved to deal with it in the morning.


      The next morning, one of our other authors, who gets in very early, was able to get into the help project just fine and work in it all day. This second author was not aware that the problems from the previous day continued. I was also able to get into the help project at this time. The first author then tried to get into the help project, but wasn't able to get in at all. The second author needed to get into the checked out files to make changes, so I instructed the first author on how to go into VSS and check those files in directly from there, without having to get into RH. At this point, I assumed the problem resided only with the first author's instance of the project, but I didn't think that checking in some topics would exacerbate the problem. (Maybe it did.) I figured, at most, we might need to pull down the help project from the network to her C drive again to fix the problem.


      A little while later, the third author and I both tried to get into the help project and were not able to. At this point, only the second author, who had gotten into the project early in the morning, was in the help project and was not having any problems. At the end of the day yesterday, she saved and checked in all of her files. However, this morning, she came in and now she is not able to get into the help project, either.


      Troubleshooting attempted:


      • The error dialog that displays when you shut down an app manually indicates that the app has hung. (No kidding, but thought I'd better say I looked at it.) The actual error reports, of course, were incomprehensible.
      • Attempted to launch XPJ without source control: Made a copy of the help project to a different location and deleted the vssver2.scc files in the copy. Tried to launch XPJ and it hung.
      • Attempted to rebuild the XPJ and CPD files: Backed up the help project on C drive, deleted CPD file, renamed XPJ file, and then double-clicked the HHP file. Had to copy and paste the path to the RoboHTML.exe file in the Locate Program dialog box. Received an error that the HHP file is corrupt. Then opened RoboHelp and tried launching the HHP file from the Starter window. Received messages about making various APJ and FPJ files writable. Thought this was a good sign, so I clicked OK on all of them, and then RH hung again.
      • Pulled down a new version in source control to my C drive, but RH still hangs when launching XPJ. This problem appears to be with the version in source control as well.


      At this point, we're afraid our only course of action is to get our IT department to revert the entire help project in source control to the version that existed before the network went down on Tuesday and then pull that version to our C drives. However, we will lose some work from late Tuesday and yesterday. Is there anything else we should try before doing this?


      Thank you in advance for your help. I apologize for the novel, but I figured I better be thorough.




        • 1. Re: XPJ file appears to be corrupt -- have exhausted all known fixes
          Amebr Level 4

          First, check that the cpd, ldb and pss files aren't included in source control.

          With Robohelp closed, ensure that there isn't an ldb file in your project directory - this should only exist while Robohelp is open but sometimes gets left behind when Robohelp crashes.


          If you any of the above existe in the specified locations, delete them (and the cpd on the c drive for good measure) and try to open the project again.


          If you want to test the project outside source control, there is an additional step which you don't mention, so I'll put it here in case you didn't do it and want to try again. As well as deleting the .scc files, you also need to manually edit the xpj file. Open it in Notepad and delete everything between the <miscproperties> tags. (If you only see <miscproperties/> don't do anything to the file. This can cause other issues, but I won't go into them right now. It might be relevent to the 3rd project you mentioned depending on what 'doesn't work right' means.)


          See how that goes,


          • 2. Re: XPJ file appears to be corrupt -- have exhausted all known fixes
            LisaR18 Level 1

            Hi Amber,


            Thank you so much for your response. Since we are on monthly releases with our next one coming up in a week, we didn't have time to tinker around with it further. We decided to revert our help project to the version as it was in the early morning before the network outage. It meant a bit of rework for a couple of people, but we felt this was the best course of action at this point.


            However, your instructions are still valuable and I will be putting them into our department's RoboHelp User Guide for future reference. I really, really appreciate your time in posting them. Much of this was stuff I didn't know about, so I'll be happy to make that section of our user guide more complete. If this ever happens again, your instructions will be valuable, and may help us solve the problem completely on our own, without posting to the forum.


            Many, many thanks again!