5 Replies Latest reply on Nov 11, 2011 2:40 AM by xandout

    MySQL connection not working

    jeffcg2 Level 1

      java.io.FileNotFoundException:  http://localhost/burrito/burrito/bin-debug/gateway.php


      When I try to create a data service to a MySQL data source using the "Connect to Data/Service.." I get this error. Is this supposed to work in this preview release?

       

      I don't have any trouble creating a Coldfusion Data/Service.

       

      I get the same error when I try to connect to a PHP Data/Service that is working in Flash Builder 4.

       

      If it is supposed to work, what did I miss?

        • 1. Re: MySQL connection not working
          techmagus7

          I had this problem before in using PHP data services. The fix for my problem was to edit the file amf_config.ini

          to set the zend_path =C:\www\ZendFramework\library

          This tells Flex where to find your ZendFramework library which makes your PHP data connection for your flex code.

           

          You may also need to set the webroot as in webroot =C:/www/flex4/DBWorkspace/DBaccess

          The webroot should be the path to your current project workspace.

          The amf_config.ini file is listed under Flash Builder's package exlporer in bin-debug then services.

          I hope this helps, it solved my problems.

          • 2. Re: MySQL connection not working
            natdrip

            I Just wanted to throw in my 2 cents.

             

            This may help some one in the future.

             

            I was getting the error  java.io.IOException:

             

            turns out that my virtual path was not being compenstated for

             

            when I set it up.

             

            the server location was not validating occording to the FLEX rules

             

            my file is located here

            C:\wamp\www\metrix

             

            and my v-host is this

            http://metrix.localhost/

             

            because the validation button did not work did not validate the config

             

            I changed this=>C:\wamp\www\metrix to this C:\wamp\www\

             

            This messed everything up and cost me many hours to discover my error

             

            you can correct this

             

            package(right click)->preferances->Flex Server

             

            Don't worry about the validation configuration if you know it is correct!

            • 3. Re: MySQL connection not working
              AsPacIn

              Did you get this to work, as i am having the same issue, and have tried the changes refered to below, but still no JOY!!!

              • 4. Re: MySQL connection not working
                jeffcg2 Level 1

                Did you get it figured out?

                • 5. Re: MySQL connection not working
                  xandout Level 1

                  I had that issue last night and realized that my apache service had been shutdown.