0 Replies Latest reply on Nov 12, 2010 10:54 AM by mike stephenson

    Help! Error #1014: Class flash.net::NetGroup could not be found?

    mike stephenson

      Hi,

       

      I've gone the Apche HTTP Server 2.2 route, bypassing FMS.  I'm very stuck, and have no clue how to move forward w/OMSF.  After update of playerglobal.swc for CS4 from 10.0 to 10.1, I receive:

       

      VerifyError: Error #1014: Class flash.net::NetGroup could not be found.

       

          at global$init()
           at org.osmf.media::DefaultMediaFactory/init()
           at org.osmf.media::DefaultMediaFactory()
           at org.osmf.media::MediaPlayerSprite/get mediaFactory()
           at org.osmf.media::MediaPlayerSprite/set resource()
           at BasicPlayback()

       

      By updating I 1) created a new folder in [app]/Common/Configuration/ActionScript 3.0, named it FP10.1, and dropped the .swc in there, 2)

      then  opened the file FlashPlayer10.xml located in /Applications/Adobe  Flash  CS4/Common/Configuration/Players and changed the following lines  to  this:

       

      <player id="FlashPlayer10.1" version="10" asversion="3">

      <name>FlashPlayer10.1</name>

      <PlayerDefinitionPath as3="$(AppConfig)/ActionScript 3.0/FP10.1/playerglobal.swc"/>

       

      then saved the file as FlashPlayer10_1.xml

       

      and 3) changed the publish settings in the .fla file to target flash player 10.1

       

       

      my code - a simple adaptation from OSMF developers guide - is:

       

      package
      {
      import flash.display.Sprite;
      import org.osmf.media.MediaPlayerSprite;
      import org.osmf.media.URLResource;
      import org.osmf.media.MediaFactory;
      import org.osmf.net.*;

       

      [SWF(width="480", height="360")]
      public class BasicPlayback extends Sprite
      {
      public function BasicPlayback()
      {
      // Create the container class that displays the media.
      var sprite:MediaPlayerSprite = new MediaPlayerSprite();
      addChild(sprite);
      // Assign the resource to play. This generates the appropriate
      // MediaElement and passes it to the MediaPlayer. Because the MediaPlayer
      // autoPlay property defaults to true, playback begins immediately.
      sprite.resource = new URLResource("videoFile.flv");
      }
      }
      }

       

      Any clue why I receive the NetGroup could not be found error?  Wishing this wasn't so complicated...

       

      Thanks very much in advance to anyone who can clue me in.

      Mike