0 Replies Latest reply on Nov 14, 2010 9:23 AM by jijw

    IE8 SSL the flex application don't start

    jijw

      I have a problem with the delivery of a Flex - application and SSL.
      In Firefox it works just fine in IE8, however, the Flex - Application delivered not start.

      The web.xml file:

       

      l version="1.0" encoding="UTF-8"?>
      <web-app xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
          xmlns="http://java.sun.com/xml/ns/javaee" xmlns:web="http://java.sun.com/xml/ns/javaee/web-app_2_5.xsd"
          xsi:schemaLocation="http://java.sun.com/xml/ns/javaee http://java.sun.com/xml/ns/javaee/web-app_3_0.xsd"
          id="WebApp_ID" version="3.0">
         
          <!-- Default Appliation Configuration -->
          <display-name>Inex 24 Market Work Place</display-name>
          <welcome-file-list>
              <welcome-file>index.html</welcome-file>
          </welcome-file-list>
         
          <!-- Configure Container Login BASIC -->
          <login-config>
              <auth-method>BASIC</auth-method>
              <realm-name>file</realm-name>
          </login-config>
         
          <!--  Define the Roles -->
          <security-role>
              <role-name>ROLE_USER</role-name>
          </security-role>
         
          <security-role>
              <role-name>ROLE_SUPERVISOR</role-name>
          </security-role>
                     
          <!-- Web Security Configuration -->      
          <security-constraint>
              <display-name>Inex24 Security</display-name>
              <web-resource-collection>
                  <web-resource-name>Inex24 Web Resources</web-resource-name>
                  <url-pattern>/*</url-pattern>
              </web-resource-collection>
              <auth-constraint>
                  <role-name>ROLE_USER</role-name>
              </auth-constraint>
              <user-data-constraint>
                  <transport-guarantee>CONFIDENTIAL</transport-guarantee>
              </user-data-constraint>
          </security-constraint>
         
          <!-- Session Configuration --> 
          <session-config>
              <session-timeout>15</session-timeout>
              <cookie-config>
                  <domain>inex24</domain>
                  <http-only>true</http-only>
                  <secure>true</secure>
                  <max-age>-1</max-age>
              </cookie-config>
              <!-- The COOKIE mode doesn't realy work well with this version of blazeds
                   Using URL Parameters for Session Tracking
                   The <tracking-mode> element in the Servlet 3.0 specification allows you to define whether the
                   JSESSIONID should be stored in a cookie or in a URL parameter. If the session id is stored
                   in a URL parameter it could be inadvertently saved in a number of locations including the browser
                   history, proxy server logs, referrer logs, web logs, etc. Accidental disclosure of the session
                   id makes the application more vulnerable to session hijacking attacks. Instead, make sure the
                   JSESSIONID is stored in a cookie (and has the Secure flag set) using the following configuration. -->
               <!-- tracking-mode>COOKIE</tracking-mode-->
          </session-config>

       

          <!-- Disable default error page (Stack dump)
          <error-page>
                <exception-type>java.lang.Throwable</exception-type>
                <location>/error.html</location>
          </error-page> -->
         
          <!-- Flex Spring Integration -->
          <context-param>
                <param-name>contextConfigLocation</param-name>
                <param-value>
                    /WEB-INF/config/spring-config.xml,
                    /WEB-INF/config/spring-security.xml,
                    /WEB-INF/config/spring-jee.xml
                </param-value>
            </context-param>
            <!--  Flex Spring Securtiy -->
          <filter>
              <filter-name>filterChainProxy</filter-name>
              <filter-class>org.springframework.web.filter.DelegatingFilterProxy</filter-class>
          </filter>
          <filter-mapping>
              <filter-name>filterChainProxy</filter-name>
              <url-pattern>/*</url-pattern>
          </filter-mapping>
         
          <!--  Flex Session Management -->
          <listener>
              <listener-class>org.springframework.web.context.ContextLoaderListener</listener-class>
          </listener>
          <listener>
              <listener-class>flex.messaging.HttpFlexSession</listener-class>
          </listener>
          <!-- Flex Sprint Integration Dispatcher Servler -->
          <servlet>
              <servlet-name>Flex Spring Integration</servlet-name>
              <servlet-class>org.springframework.web.servlet.DispatcherServlet</servlet-class>
              <init-param>
                  <param-name>contextConfigLocation</param-name>
                  <param-value></param-value>
              </init-param>
              <load-on-startup>1</load-on-startup>
          </servlet>
          <servlet-mapping>
              <servlet-name>Flex Spring Integration</servlet-name>
              <url-pattern>/messagebroker/*</url-pattern>
          </servlet-mapping>
                 
      </web-app>

       

      It would be nice if you could help me here.

      Thanks and Greetings
      Sepp