13 Replies Latest reply on May 12, 2011 4:16 AM by dofoooo

    iPad Packager - iOS Deployment Target problem

    kevkong1971 Level 1



      I've been working on an iPad app (using CS5), got everything in place, i.e. apple dev account, all my details cleared to sell apps, got my development app working great on my iPad.




      When I'm trying to upload the finished version using Application Loader I get the following message:


      This bundle is invalid. When supporting iPad only, the iOS Deployment Target must be 3.2.


      There is no way to set the deployment target in the flash CS5 settings, I've looked on various forums but can't find any answers to this. Can't believe I've got to this last step and I'm hit with this. Are adobe bringing any fixes out for this?


      Any Ideas please???





        • 1. Re: iPad Packager - iOS Deployment Target problem
          markerline Level 4

          Not to fret KevKong . . . .


          iOS 4.2 is coming out with support for the iPad very shortly from what several internet resources say.  So you won't have to worry about deploying for 3.2 (Well, that is assuming that Application Loader is an Apple product?  I really don't know much since I haven't developed for this platform before).



          1 person found this helpful
          • 2. Re: iPad Packager - iOS Deployment Target problem
            kevkong1971 Level 1

            Cheers for the reply, that's good news about ios 4.2 hopefully that will sort it.


            Until that happens anybody else had this issue and used any type of workaround??

            • 3. Re: iPad Packager - iOS Deployment Target problem
              kevkong1971 Level 1

              Can nobody from Adobe answer this???? It's pointless to upgrade to CS5 with the promise that I can create iPad Apps, OK you can create the Apps but the packager outputs it with the incorrect deployment target which renders this process useless!!

              • 4. Re: iPad Packager - iOS Deployment Target problem
                tom65536 Level 1



                Now that 4.2 is available -- I tried to upload my ready-to-go iPad only application and I am still getting the "you must target 3.2" error!!  I saw a post online that talks about modifing plist files --- I don't even see that?  I see my app's xml file but when I go through it there is nothing that looks like it could be set to 3.2.....


                Has anyone got this to work. I'd really like to get my iPad app on the store.  Really really appreciate guidance... if it is a plist modification can someone give more detail on how exactly you find that file, what needs to be done to it?



                Best Regards,


                • 5. Re: iPad Packager - iOS Deployment Target problem
                  kevkong1971 Level 1

                  Hi Tom,


                  to see your p-list file you must (if using a mac) right click on your  .app file and and choose 'show package contents'. You will see info.plist, you need to double click it and open it with 'property list editor' which I think comes with xcode. Inside that you will see minimum os version, change that to 3.2.



                  Anyway, try this post..





                  This is the one I used and it worked perfect for me read from the part of the post where Samlms chips in.





                  • 6. Re: iPad Packager - iOS Deployment Target problem
                    tom65536 Level 1

                    Awesome -- I wish I could mark as "Answered" for this post -- Kevkong1971 I really really really appreciate being shown that post.  Of course you can search and search but if you don't find the right one.....  Well thanks..


                    I thought I would distill the answer and post again for those who need it.  Here is the proceedure I followed (gleaned entirely from the work of others) And yes, it does work.  I have both of my "iPad" only apps now up for Apple's review.


                    Here you go:


                    this is a copy and paste of something I popped up on my personal weblog---------



                    The following post addresses the “you must target a minimum of IOS 3.2” when you try to publish an app you’ve written with Adobe Tools and targeted “iPad Only”.


                    So thanks to the guys on the Adobe Forums, there are a lot of posts so I hope to distill it down for anyone who needs and also for myself (for future apps!)


                    Step 1: Copy your .IPA file to a MAC

                    Step 2: Rename file to .zip

                    Step 3: Extract contents of .zip

                    Step 4: Pull out the “yourApplication.app” file from the “Payload” folder you extracted

                    Step 5: Right click on .app file and select “show package contents”

                    Step 6: Edit the info.plist file

                    Step 7: Change the “MinimumOSVersion” entry to 3.2

                    Step 8: Close and Save

                    Step 9: Download THIS .PY Python script you will need to make your .xcent file authentic

                    Step10: write your .xcent file using pico or your favorite pure-text editor.  Just create this file from scratch and name it yourApplication.xcent As Follows:


                    <?xml version="1.0" encoding="UTF-8"?>

                    <!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">

                    <plist version="1.0">









                    step 11: assuming the .py file you just downloaded and .xcent file you just created above are in the same directory execute the following in the terminal:


                    python gen_entitlements.py 10DIGITCODE.COM.YOURDOMAINAND.APPNAMEHERE yourAppName.xcent


                    OK So far so good.  Now you have a valid .xcent file, and you have fixed your .plist.  Now you have to put them together and resign with your credentials.  To do this execute the following in your terminal:


                    /usr/bin/codesign -f -s "iPhone Distribution: YOUR NAME" "--resource-rules=/Users/yourusername/Desktop/yourAppName.app/ResourceRules.plist" --entitlements "/Users/yourusername/Desktop/yourAppName.xcent" "/Users/yourusername/Desktop/yourAppName.app"


                    Note:  The “iPhone Distribution: YOUR NAME” needs to match your distribution certificate in your keychain.  Open KeyChain and make sure you type it exactly as it is in there.


                    step 12: Right click the .app file and select “compress”

                    step 13: upload your app!!!


                    Hope that helps someone!!




                    • 7. Re: iPad Packager - iOS Deployment Target problem

                      Tommy - I just want to say THANK YOU for that awesome post!  I was totally stuck and I doubt I ever would have gotten past editing the plist file.... with your handy tutorial, however, I was able to able to upload my iPad *only* app within 15 min of reading.  Really appreciate the post! 

                      • 8. Re: iPad Packager - iOS Deployment Target problem
                        miquael Level 1

                        Thanks for posting this info guys!

                        • 9. Re: iPad Packager - iOS Deployment Target problem
                          kevkong1971 Level 1

                          Hi Guys,


                          I've just had my app rejected but it was on the grounds that it did not orientate in all directions on the ipad.


                          So using this method to package up and re-sign seems to be OK with apple or I'm sure that would have been mentioned in my rejection email also.


                          Just thought this info might be useful,





                          • 10. Re: iPad Packager - iOS Deployment Target problem
                            briandkinney Level 1

                            I followed tom65536's steps to the period, however on the last step where you do the codesign, I continually get "iPhone Distribution: (MY NAME) no identity found".  My certification is in my keychain, and it matches it to the capitalization.


                            Of course, even with that I attempted to still submit it, and I got two errors.


                            I really hope there's a solution for this, as this is the only thread on the 'net I found that has this problem specifically.



                            • 11. Re: iPad Packager - iOS Deployment Target problem
                              briandkinney Level 1

                              Still no solution yet.  I'm surprised no one else is having this issue (as CS5 can be used to deploy for iPad apps).


                              I'm also surprised Adobe hasn't caught on to this, this is a pretty huge issue.

                              • 12. Re: iPad Packager - iOS Deployment Target problem
                                briandkinney Level 1

                                Apple's apploader still errors out saying it isn't signed correctly, however I was able to get through the python scripts as listed above.


                                As it sits, there's no solution for iPad development with CS5?  This is really awful.

                                • 13. Re: iPad Packager - iOS Deployment Target problem


                                  this discussion is now obsolete, with Flash CS5.5 there are no problems with the iPad only target.