3 Replies Latest reply on Nov 15, 2010 11:43 PM by charles_newman-GG8xMm

    Anyone else seen this while loading a plugin: "Error #2044: Unhandled IOErrorEvent:"

    charles_newman-GG8xMm Level 1

      Hello All,

       

      I'm curious if anyone else has seen this error while loading an OSMF plugin dynamically:

       

      "Error #2044: Unhandled IOErrorEvent:. text=Error #2124: Loaded file is an unknown type."

       

      You will only see this with the debug version of the Flash Player. The plugin loads fine, but the RTE appears. I've submitted a bug for this (http://bugs.adobe.com/jira/browse/FM-1104) but apparently no one at Adobe can reproduce it while everyone on our team can easily reproduce it at will. Some use Windows, some use Macs.

       

      I've written a very simple player and a very simple plugin, you can simply refresh your browser to try to reproduce the error. You won't see anything on the page, just hit refresh a few times until you see it. You'll need the debug version of the Flash Player to see the RTE. One guy on our team (uses Windows) claims he sees it after he clears his browser cache. I can make it happen on Safari for Mac by simply hitting Cmd-R a few times.

       

      http://mediapm.edgesuite.net/chuck/osmf-test/OSMFPluginErrorTest.html

       

      I also see this on cnn.com. I've attached a screen shot.

       

      Screen shot 2010-11-15 at 2.43.34 PM.png

       

      Go to cnn.com and watch any video. I get the RTE every time on the first try. We are seeing this repeatedly on OSMF built players that load OSMF plugins dynamically.

       

      Reply if you see the error. This will greatly help in determining that I've not completely lost my mind

      In the mean time, I'll be working locally on a work around and hopefully submit that to the OSMF trunk.

       

      Thanks,

      - charles