3 Replies Latest reply on Dec 22, 2010 6:03 AM by John Wolfsteiner

    Export Air file is failing with no results or messages

    captain_code-KOo9rr Level 1

      Hello all,

       

           I don't know if I am just being stupid, as what I am doing should be simple, but maybe I am. I am using the Burrito Preview, and I have an air app that I am trying to do a release export build to produce an AIR file from. However, when I do the release export build wizard, I get no output. I follow all of the steps of the output, and if I navigate to the folder I can watch the swf and air get created, along with a .tmp file. However, when the export completes, Flash Builder deletes these files AND the folder that they were supposed to be exported to. Thank goodness I was just trying to output to the standard bin-release not somewhere else. Has anyone else seen this problem? I looked through the log file and it doesn't seem to be appending anything to the file after I attempt a release. Any ideas would be appreciated.

       

      Thanks,

       

      Josh

        • 1. Re: Export Air file is failing with no results or messages
          captain_code-KOo9rr Level 1

          Update:  I switched over to a machine running Flash Builder 4 (not burrito) and it exports fine. Any one have any ideas on how I can find what is wrong so that I can report it to Adobe?

          • 2. Re: Export Air file is failing with no results or messages
            John Wolfsteiner

            BUMP

            I'm getting the same problem with Burrito and Air Export using a trusted certificate.

            Steps,

            1) Project -> Export Release Build

            2) Select "Export and sign an AIR file" Click Next (the build starts)

            3) In the new dialog I enter the password for the selected certificate and press Finish

            4) a popup "Updating compiler settings..." a background (re)build task starts.

            5) Nothing happens, the "Package Settings" dialog does not go away and I can press Finish for ever.

            • 3. Re: Export Air file is failing with no results or messages
              John Wolfsteiner Level 1

              Update

              The problem seems to be the verbosity level of the compiler and incorrect Application Descriptor file content (which Burrito generates)

              I started compiling the app using the command line (amxmlc and adt) and got various error messages.

              These errors where not reported during a regular build/test inside Burrito and are introdcued with Buritto/SDK 4.5.

               

              These where some of the issues with my project:

              1) c:\PATH\TO\PROJECT\App.xml: error 303: Icon icons/appIcon_32.png is missing from package (manual addition to the App Descriptor file)

              2) c:\PATH\TO\PROJECT\App.xml(11): error 105: application.initialWindow.content contains an invalid value (generated on project creation in Burrito)

              3) c:\PATH\TO\PROJECT\App.xml(29): error 103: application.autoOrients is an unexpected element/attribute
              4) c:\PATH\TO\PROJECT\App.xml(30): error 103: application.fullScreen is an unexpected element/attribute
              5) c:\PATH\TO\PROJECT\App.xml(31): error 103: application.visible is an unexpected element/attribute

              6) undefined property: var appXML:XML = NativeApplication.nativeApplication.applicationDescriptor;

               

              Error 2: Change the line: <content>[This value will be overwritten by Flash Builder in the output app.xml]</content>

              With: <content>YourApp.swf</content>

              Error 6:

              Apparently NativeApplication.nativeApplication.applicationDescriptor is not available in Hero ?

               

              Commenting out the offending lines solved the problems, the command line build succeeded and starting the build from Burrito worked also flawlessly