4 Replies Latest reply on Nov 12, 2007 1:53 AM by MILFAQ

    installed fine, just can't run flex 2 on Vista

    masterkrang Level 1
      here's the contents of the error metadata\.log from trying to run flex 2 on Vista. Any help?

      !SESSION 2007-07-11 18:52:10.275 -----------------------------------------------
      eclipse.buildId=unknown
      java.version=1.4.2_12
      java.vendor=Sun Microsystems Inc.
      BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US
      Command-line arguments: -os win32 -ws win32 -arch x86

      !ENTRY org.eclipse.update.configurator 2007-07-11 18:52:12.50
      !MESSAGE Cannot backup current configuration

      !ENTRY org.eclipse.update.configurator 2007-07-11 18:52:12.98
      !MESSAGE Could not rename configuration temp file

      !ENTRY org.eclipse.osgi 2007-07-11 18:52:15.185
      !MESSAGE Application error
      !STACK 1
      java.lang.UnsatisfiedLinkError: no swt-win32-3139 in java.library.path
      at java.lang.ClassLoader.loadLibrary(Unknown Source)
      at java.lang.Runtime.loadLibrary0(Unknown Source)
      at java.lang.System.loadLibrary(Unknown Source)
      at org.eclipse.swt.internal.Library.loadLibrary(Library.java:123)
      at org.eclipse.swt.internal.win32.OS.<clinit>(OS.java:18)
      at org.eclipse.swt.widgets.Display.<clinit>(Display.java:125)
      at org.eclipse.ui.internal.Workbench.createDisplay(Workbench.java:381)
      at org.eclipse.ui.PlatformUI.createDisplay(PlatformUI.java:155)
      at com.adobe.flexbuilder.standalone.FlexBuilderApplication.run(FlexBuilderApplication.java:4 5)
      at org.eclipse.core.internal.runtime.PlatformActivator$1.run(PlatformActivator.java:226)
      at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:376)
      at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:163)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
      at java.lang.reflect.Method.invoke(Unknown Source)
      at org.eclipse.core.launcher.Main.invokeFramework(Main.java:334)
      at org.eclipse.core.launcher.Main.basicRun(Main.java:278)
      at org.eclipse.core.launcher.Main.run(Main.java:973)
      at org.eclipse.core.launcher.Main.main(Main.java:948)

      !ENTRY org.eclipse.osgi 2007-07-11 18:52:15.197
      !MESSAGE Bundle update@plugins/com.adobe.flexbuilder.debug.e32_2.0.155577/ [70] was not resolved.
      !SUBENTRY 1 org.eclipse.osgi 2007-07-11 18:52:15.198
      !MESSAGE Missing required bundle org.eclipse.debug.ui_[3.2.0,99.0.0).
      !SESSION 2007-07-11 22:37:40.508 -----------------------------------------------
      eclipse.buildId=unknown
      java.version=1.4.2_12
      java.vendor=Sun Microsystems Inc.
      BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US
      Command-line arguments: -os win32 -ws win32 -arch x86

      !ENTRY org.eclipse.update.configurator 2007-07-11 22:37:43.69
      !MESSAGE Cannot backup current configuration

      !ENTRY org.eclipse.update.configurator 2007-07-11 22:37:43.140
      !MESSAGE Could not rename configuration temp file

      !ENTRY org.eclipse.osgi 2007-07-11 22:37:45.150
      !MESSAGE Application error
      !STACK 1
      java.lang.UnsatisfiedLinkError: no swt-win32-3139 in java.library.path
      at java.lang.ClassLoader.loadLibrary(Unknown Source)
      at java.lang.Runtime.loadLibrary0(Unknown Source)
      at java.lang.System.loadLibrary(Unknown Source)
      at org.eclipse.swt.internal.Library.loadLibrary(Library.java:123)
      at org.eclipse.swt.internal.win32.OS.<clinit>(OS.java:18)
      at org.eclipse.swt.widgets.Display.<clinit>(Display.java:125)
      at org.eclipse.ui.internal.Workbench.createDisplay(Workbench.java:381)
      at org.eclipse.ui.PlatformUI.createDisplay(PlatformUI.java:155)
      at com.adobe.flexbuilder.standalone.FlexBuilderApplication.run(FlexBuilderApplication.java:4 5)
      at org.eclipse.core.internal.runtime.PlatformActivator$1.run(PlatformActivator.java:226)
      at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:376)
      at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:163)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
      at java.lang.reflect.Method.invoke(Unknown Source)
      at org.eclipse.core.launcher.Main.invokeFramework(Main.java:334)
      at org.eclipse.core.launcher.Main.basicRun(Main.java:278)
      at org.eclipse.core.launcher.Main.run(Main.java:973)
      at org.eclipse.core.launcher.Main.main(Main.java:948)

      !ENTRY org.eclipse.osgi 2007-07-11 22:37:45.198
      !MESSAGE Bundle update@plugins/com.adobe.flexbuilder.debug.e32_2.0.155577/ [70] was not resolved.
      !SUBENTRY 1 org.eclipse.osgi 2007-07-11 22:37:45.200
      !MESSAGE Missing required bundle org.eclipse.debug.ui_[3.2.0,99.0.0).