3 Replies Latest reply on Oct 11, 2006 4:19 PM by dbeebe

    Help!  Lost WYSIWIG and TrueSource content

    dbeebe
      I'm using X5. Everthing worked fine yesterday, but today I can't view or edit any topic in the WYSIWIG and TrueCode tabs. If I select a topic from the TOC or Topics tab, I can only preview it. I can generate a CHM, but that's really pointless if I can't edit the content.

      Every project is behaving this way, so I think I can rule out a single corrupted file. Does anyone know of a fix, or should I just uninstall and reinstall?

      Thanks!
      Diana
        • 1. Re: Help!  Lost WYSIWIG and TrueSource content
          RoboWizard Level 4
          Hi Diana

          What happens if you right click the topic and choose Edit?

          What do you see if you click Tools > Options... > HTML Editors tab? Which is configured as the Default editor? Is the option at the bottom of the dialog set for Auto-select or is it Use Default?

          Cheers... Rick
          • 2. Re: Help!  Lost WYSIWIG and TrueSource content
            dbeebe Level 1
            Rick,
            I get the same result from right-clicking a topic from the TOC--no editing capabilities and the WYSIWYG editor stays blank. No error messages either. When I right-click in the WYSIWYG editor, I get no menu options at all.

            However, in the Topics tab, I can right-click a topic and select Edit with > RoboHelp WYSIWYG. Then I get this message, "Changing editors can cause changes to your HTML code. Do you wish to proceed?" If I click yes, I can view the topic and edit it.

            In the Tools > Options... > HTML Editors tab, the default editor is the WYSIWYG editor. Auto-select is the option at the bottom.

            So why is this the only way I can access topics today, when it worked yesterday. Is there a fix?
            Thanks,
            Diana
            • 3. Re: Help!  Lost WYSIWIG and TrueSource content
              dbeebe Level 1
              Rick,
              I've been playing with the options in the Tools > Options... > HTML Editors tab that you mentioned before. When I set it to Use Default Editor, it fixed the entire problem.

              Thanks so much for pointing me in the right direction! I really appreciate it!
              Diana