3 Replies Latest reply on Jul 11, 2007 1:18 PM by Chaz, W

    Why are my results returning to flex from CFC’s are slow?

    Chaz, W Level 1
      When I call my CFC’s from coldfusion the results come back fast, but call the same CFC using flex the results are slow, how can I get my results back to flex quicker.
        • 1. Re: Why are my results returning to flex from CFC’s are slow?
          ntsiii Level 3
          The speed bottleneck in a Flash Player based app is the rendering of the UI, not the data transfer. Benchmark the actual time taken to get the data, exclusive of any UI renderering. I suspect those times will be comparable to the other.

          How are you displaying the data?

          Tracy
          • 2. Re: Why are my results returning to flex from CFC?s are   slow?
            Level 7
            I had similar behavior but unfortunately, to be of help to Chaz, it just
            started working better with no effort on my part that I know of.

            I am pretty sure it was not UI, because I wasn't making any UI changes.
            I had a simple form that sent data through the remoteObject to the
            CFC. When done, all that I did was display an Alert with "Data Saved",
            no other UI change.

            When I did this the "busy" cursor would spin for many seconds (15-20 it
            felt like). Then one test I ran it and the busy cursor barely made an
            appearance when I saved data. It was gone in less then a second.

            ntsiii wrote:
            > The speed bottleneck in a Flash Player based app is the rendering of the UI,
            > not the data transfer. Benchmark the actual time taken to get the data,
            > exclusive of any UI renderering. I suspect those times will be comparable to
            > the other.
            >
            > How are you displaying the data?
            >
            > Tracy
            >
            • 3. Re: Why are my results returning to flex from CFC’s are slow?
              Chaz, W Level 1
              I am displaying the data in a datagrid…

              I don’t believe it’s the UI, I put an alert before calling the CFC and after the results return and it took sometime before the results alert to display.

              I could be wrong about this, but I think it’s the connection between flex and CFC’s that is slow.

              Thanks