5 Replies Latest reply on Apr 24, 2014 4:25 PM by BoggyPhoto

    Super white - proc amp - clipping - YUV to RGB

    dwcar49

      I have been investigating the issue of clipping with YUV to RGB conversions (from DV) and found that as Stu Maschwitz pointed out in DV Rebel, there are a couple of ways to save the higher dynamic range of YUV video without clipping when converting into RGB for editing and effects. The Premier Proc amp function works in YUV and does this as does the interpret footage color management tab in AE.

       

      HOWEVER. It seems something may have broken the proc amp effect in CS5 as it no longer seems to save super white and super black values. Perhaps there is now another recommended way to save the higher dynamic range that some DV and HDV cameras will capture in YUV?

       

      Also, there is no longer a "maximum bit depth" setting in Project settings, so maybe this is where things got broken, as in earlier versions of Premier that setting on was required for proc amp to work correctly.

       

      I took some DV footage that has 110% signal highlights and tried to adjust it in CS5 proc amp and it was clipped. The same footage was recoverable in AE CS5 with  the interpret footage color management tab "wide Gamut RGB". This footage also is recoverable with proc amp in CS3 and CS4 Premier.

       

      Any suggestions??

       

      David

        • 1. Re: Super white - proc amp - clipping - YUV to RGB
          shooternz Level 6
          Also, there is no longer a "maximum bit depth" setting in Project settings, so maybe this is where things got broken, as in earlier versions of Premier that setting on was required for proc amp to work correctly.

           

           

           

          I have this "maximum bit depth" setting  option in CS5

          • 2. Re: Super white - proc amp - clipping - YUV to RGB
            SteveHoeg Adobe Employee

            Max bit depth is a sequence, no longer a project setting, so be sure you are looking in the right place.  With this set of-of-range values will be preserved with supported effects as indicated by icons in the effects panel. Also note that with GPU acceleration enabled, all rendering done on the GPU will always be at maximum bit depth. The icons in the effects panel indicate the abilities of the software effect, not the GPU effect, so for example crop will render in 32-bit when on the GPU even though it never will on the CPU.

            • 3. Re: Super white - proc amp - clipping - YUV to RGB
              dwcar49 Level 1

              I thought the proc amp was broken in Premier CS5 but later found that the critical setting was just moved as was pointed out in the post..

               

              The proc amp effect in CS5 still works to save super white and super black values, however, there is no longer a "maximum bit depth" setting in Project settings, it has been moved into the General tab of the new sequence dialog. As with previous versions of Premier, Proc amp won't help high dymamic range YUV video unless the "maximum bit depth" setting is enabled.

              • 4. Re: Super white - proc amp - clipping - YUV to RGB
                shooternz Level 6

                Huh..Steve gets the points...

                 

                 

                • 5. Re: Super white - proc amp - clipping - YUV to RGB
                  BoggyPhoto

                  Hi Guys,

                   

                  Without opening a new thread, I just wanted to say that I can't get ProcAmp to work on my footages. And I remember it worked in the past.

                   

                  I have footage from Nex-7, D4s, GoPro Hero 3 Black. At least on the GoPro & Nex-7 footage it was easy to recover highlights. But when I try it now, I just grey out the highlights without recovering anything.

                   

                  Original here:

                  premiere1.JPG

                   

                  ProcAmp applied:

                   

                  premiere2.JPG

                   

                  Of course, Maximum Bit Depth is enabled in the sequence. I cleaned the cache, I enabled Maximum Render Quality as well, and also tried with Mercury on/off.

                   

                  Any suggestions in fixing this?

                   

                  Thanks a lot,

                  Bogdan