2 Replies Latest reply on Dec 4, 2010 2:14 AM by nikos101

    New unit tests aren't being ran in my test application

    nikos101 Level 2

      For some reason my new unit tests aren't being ran in my test application , even though I see them all in the Unit Application

       

      <?xml version="1.0" encoding="utf-8"?>

      <!-- This file is automatically generated by Flash Builder to compile FlexUnit classes and is not intended for modification.
      Please click on the "Refresh" icon in "FlexUnit Results" view to regenerate this file. -->

      <s:Application xmlns:fx="http://ns.adobe.com/mxml/2009"
                     xmlns:s="library://ns.adobe.com/flex/spark"
                     xmlns:mx="library://ns.adobe.com/flex/mx" minWidth="955" minHeight="600">
          <fx:Script>
              <![CDATA[
                  import tests.model.ModelTestSuite;
                  import tests.view.TestLoginForm;
                  import tests.model.TestReviewModel;
                 
                  private var tests_model_ModelTestSuite_obj:tests.model.ModelTestSuite;
                 
                 
                  private var tests_view_TestLoginForm_obj:tests.view.TestLoginForm;
                 
                 
                  private var tests_model_TestReviewModel_obj:tests.model.TestReviewModel;
                 
              ]]>
          </fx:Script>
          <fx:Declarations>
              <!-- Place non-visual elements (e.g., services, value objects) here -->
          </fx:Declarations>
      </s:Application>

       

       

       

       

      ideas friends?

        • 1. Re: New unit tests aren't being ran in my test application
          nikos101 Level 2

          Sorry to bump but this is such a frustrating issue.

           

          Any ideas what I can do to fix?

          • 2. Re: New unit tests aren't being ran in my test application
            nikos101 Level 2

            I've noticed that my new  tests were not added to the FlexUnitApplication.

             

            Is this something I have to add manually?

             

            <?xml version="1.0" encoding="utf-8"?>

             

            <!-- This is an auto generated file and is not intended for modification. -->

             

            <s:Application xmlns:fx="http://ns.adobe.com/mxml/2009"
                           xmlns:s="library://ns.adobe.com/flex/spark"
                           xmlns:mx="library://ns.adobe.com/flex/mx" minWidth="955" minHeight="600" xmlns:flexui="flexunit.flexui.*" creationComplete="onCreationComplete()">
                <fx:Script>
                    <![CDATA[
                        import tests.model.TestReviewModel;
                       
                        public function currentRunTestSuite():Array
                        {
                            var testsToRun:Array = new Array();
                            testsToRun.push(tests.model.TestReviewModel);
                            return testsToRun;
                        }
                       
                       
                        private function onCreationComplete():void
                        {
                            testRunner.runWithFlexUnit4Runner(currentRunTestSuite(), "Main");
                        }
                       
                    ]]>
                </fx:Script>
                <fx:Declarations>
                    <!-- Place non-visual elements (e.g., services, value objects) here -->
                </fx:Declarations>
                <flexui:FlexUnitTestRunnerUI id="testRunner">
                </flexui:FlexUnitTestRunnerUI>
            </s:Application>