5 Replies Latest reply on Dec 8, 2010 8:33 AM by JacquelynA

    Running as Admin and Contents

    JacquelynA Level 1

      I'm using RoboHelp 8 with the latest patches to create WebHelp with a custom skin. It works fine for me until it is incoporated with our software. The Contents displays for some and works fine but not for others. Originally we thought it was based on the Operating System. However, it is not the case (we think). It appears that when one is logged in as an Administrator and spawns the help the Contents do not display. When logged in as an ordinary user it works fine.

       

      Has anybody encountered this?

       

      Unfortunately, the majority of our users are administrators.

       

      One of our IT guys is working on it and we had an idea that it may be about Group Policy? Not that I know anything about that.

       

      Best Regards

       

      Jacquelyn

        • 1. Re: Running as Admin and Contents
          JacquelynA Level 1

          One of ourTech specialists has been looking into this.

           

          Apparently, Administrators on certain OS' have the Script ActiveX Control Marked Safe for Script option locked down.

           

          zone.PNG

           

          The Webelp is (somewhere) attempting to activate and use an ActiveX object that is ordinarily marked safe for scripting and therefore allowed. However, attempting to determine which object it is is difficult as it requires stepping through all of the script logic that RoboHelp emits.

           

           

          Anybody any ideas where to find such an object.

          • 2. Re: Running as Admin and Contents
            Captiv8r Adobe Community Professional & MVP

            Hi there

             

            I think the whole ActiveX thing is confusing. To my knowledge, there is no ActiveX control used in WebHelp. Only JavaScript.

             

            It seems very odd that only folks logged in with Admin privileges see this. One might think if issues ensued it would be on the other end of the stick. The issue would erupt when logged in as a normal user, not an Admin. Go figure.

             

            Cheers... Rick

             

             

            Helpful and Handy Links

            RoboHelp Wish Form/Bug Reporting Form

            Begin learning RoboHelp HTML 7 or 8 moments from now - $24.95!

            Adobe Certified RoboHelp HTML Training

            SorcererStone Blog

            RoboHelp eBooks

            • 3. Re: Running as Admin and Contents
              JacquelynA Level 1

              Yes, that is what I would have thought. Don't know if this will provide more detail but this is exactly what the guy discovered:

               

              "At first it looked like it may be an IFRAME issue (IFRAMES can be very problematic). However that didn't appear to be a problem in this case, after this I tried to determine what the difference was between working and not.

               

              The obvious difference was Protected Mode - if you look in the screenshots the state of this changes between working and not. Protected mode in IE will only work if UAC is enabled.

               

              So I asked Tim to determine if UAC made a difference and it did not. So I then checked out the accounts, the problem occurs in the session logged in as Administrator, if you look at the UAC setting on the server box it is enabled and yet IE still won't go into Protected Mode - this is because the Administrator account is special and will not honour UAC.

               

              Also as it is a Server OS and on 2008 Administrative accounts have all kinds of special rules and advanced lock down, so armed with this knowledge I worked through the IE settings in both Administrator account and a working user one. First obvious difference was the security level  - in the working account it is Med-High for Internet zone, but in the Administrator account it is custom (again, special account and locked down).

               

              Working through the setting that were different, one-by-one, I changed the setting state and reloaded the Help to see if it made a difference. Eventually I got to the "Script ActiveX controls marked safe for scripting*".

               

              By default it is locked down, enabling this and then restarting IE caused the EM Help to work as expected.

               

              So this is the setting in question, basically the EM help is (somewhere) attempting to activate and use an ActiveX object that is ordinarily marked safe for scripting and therefore allowed. Attempting to determine which object it is will be difficult as it requires stepping through all of the script logic that RoboHelp emits.

               

              Creating a regular Administrator or Power User account does not appear to fix the issue either as they seem to inherit the "Custom" IE settings which contain this particular disabled setting."

              The graphic is the WebHelp with no contents. That's  our issue.

               

              Thanks :-)

               

              NoContents.png

              • 4. Re: Running as Admin and Contents
                Captiv8r Adobe Community Professional & MVP

                Hello again

                 

                Sorry, but about the only thing I can think of to suggest at this point is to file a Bug Report and hope Adobe gets back with you to deal with the issue. If so, perhaps they can help sort what is happening.

                 

                Link to the Bug Report is in my sig.

                 

                Cheers... Rick

                 

                 

                Helpful and Handy Links

                RoboHelp Wish Form/Bug Reporting Form

                Begin learning RoboHelp HTML 7 or 8 moments from now - $24.95!

                Adobe Certified RoboHelp HTML Training

                SorcererStone Blog

                RoboHelp eBooks

                • 5. Re: Running as Admin and Contents
                  JacquelynA Level 1

                  Thanks, again.

                   

                  I'll post back if I get an answer.