2 Replies Latest reply on Nov 30, 2010 1:47 AM by director87

    App outside of LAN not connecting users to group?

    director87

      I am pulling my hair out. I've worked day and night on this app and tested it internally on several computers on my LAN. Now I've uploaded it to a server and have tried connecting with other people and I have asked them to report the output in the status box. They've all told me they receive

       

      NetConnection.Connect.Success

       

      nothing more. I receive, when the application works correctly, the following:

       

      NetStream.Publish.Start

      NetGroup.Connect.Success

      NetStream.Connect.Success

      NetStream.Connect.Success

      NetGroup.Connect.Success

       

       

       

      What could this be attributed to? I had them try other P2P / Cirrus apps and they were able to enter fine. I'm willing to send my code to whomever is willing to take a quick look at it (it's too much to post on here I think). I'll post the function where I believe the problem is:

       

      private function setupGroup():void

      {

       

      user = "user"+Math.round(Math.random()*10000);

       

      var groupspec:GroupSpecifier = new GroupSpecifier("vid_sid");

       

      groupspec.postingEnabled = true;

      groupspec.serverChannelEnabled = true;

      groupspec.multicastEnabled = true;

       

      trace("Groupspec: "+groupspec.groupspecWithAuthorizations());

       

      netGroup = new NetGroup(nc,groupspec.groupspecWithAuthorizations());

      netGroup.addEventListener(NetStatusEvent.NET_STATUS,netStatus);

       

      netVideo = new NetStream(nc,groupspec.groupspecWithAuthorizations());

      netVideo.addEventListener(NetStatusEvent.NET_STATUS,netStatus);

       

      netVideob = new NetStream(nc,groupspec.groupspecWithAuthorizations());

      netVideob.addEventListener(NetStatusEvent.NET_STATUS,netStatus);

       

       

      user = "user"+Math.round(Math.random()*10000);

      updateUserStream(user);

       


      var ul:UserList = new UserList(nc, groupspec.groupspecWithoutAuthorizations(), user);

      ul.addEventListener(UserListStatusEvent.CONNECTED, debug);

      ul.addEventListener(UserListStatusEvent.USER_ADDED, debug);

      ul.addEventListener(UserListStatusEvent.USER_REMOVED, debug);

       

      }

       

       

      Any help or suggestions would be very much appreciated. If you want to reproduce this: http://demo.rebien.es

       

      Thanks,

      Mark

        • 1. Re: App outside of LAN not connecting users to group?
          Michael Thornburgh Adobe Employee

          i see exactly as you describe, getting only "NetConnection.Connect.Success" and nothing else.  some of the stuff in particular i'm not seeing is very telling and is almost certainly your problem:

           

          i'm not seeing the "Peer Assisted Networking" permission dialog pop up, which means you must be doing something (other than just adding event listeners) to the NetGroup and group NetStreams you've created *before* you receive the "NetStream.Connect.Success" and "NetGroup.Connect.Success" events.  you must wait for these events for each object before invoking any methods (other than adding an event listener).  and note those connect events will be posted to the NetConnection's NetStatusEvent.NET_STATUS listener, not the new objects' listeners.

           

          most likely you're getting an exception somewhere trying to invoke a method or poke at a property on one of these objects before the user has had a chance to accept the P2P permission dialog.  that's why the dialog never even appears.

           

          it may work for you i've you previously told the permission dialog to "remember" an "allow" for your domain.

          • 2. Re: App outside of LAN not connecting users to group?
            director87 Level 1

            You were right. I was calling a function to GroupSpecifier before I even established those. Demo works and you've saved me a lot of headache. Thank you !