3 Replies Latest reply on Dec 4, 2010 4:50 AM by Perfect_Nemus

    [Issue] FLVPlayBack component in browser visualizzation

    Perfect_Nemus Level 1

      Hi to everyone,

       

      I need help abput the FLVPlayback component:

       

      I create a project with several 3D-animated movieclip, each one of them containing a FLVPlayback component.

      When I run this project in a stand alone flashplayer or in an empty HTML page everything works fine, when I run it inside target website like IE or Firefox, the FLVPB doesn't  show is control skin (like volume, play/pause and so on) when a mouse over/out event occured.

       

      Can anyone give me an help? Thanks

        • 1. Re: [Issue] FLVPlayBack component in browser visualizzation
          Perfect_Nemus Level 1

          OK, breaking news:

           

          when I put the skin swf in the html page folder, FLVPlayback find it and works!

           

          Now the gib issue is: if I have to use FLVPlayback swf (which has is own folder) in more than one page, I need to copy skin swf in every html containing folder.

          Is There a way to tell HTML to use another path different from the current one? Maybe through the param tag?

           

          Here is the html code I use till now:

           

          <div id="flashContent">
                      <object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000" width="590" height="470" id="photoshow3D" align="middle">
                          <param name="movie" value="../swf/photoshow3D.swf" />
                          <param name="quality" value="high" />
                          <param name="bgcolor" value="#ffffff" />
                          <param name="play" value="true" />
                          <param name="loop" value="true" />
                          <param name="wmode" value="window" />
                          <param name="scale" value="showall" />
                          <param name="menu" value="true" />
                          <param name="devicefont" value="false" />
                          <param name="salign" value="" />
                          <param name="allowScriptAccess" value="sameDomain" />
                          <!--[if !IE]>-->
                          <object type="application/x-shockwave-flash" data="../swf/photoshow3D.swf" width="590" height="470">
                              <param name="movie" value="../swf/photoshow3D.swf" />
                              <param name="quality" value="high" />
                              <param name="bgcolor" value="#ffffff" />
                              <param name="play" value="true" />
                              <param name="loop" value="true" />
                              <param name="wmode" value="window" />
                              <param name="scale" value="showall" />
                              <param name="menu" value="true" />
                              <param name="devicefont" value="false" />
                              <param name="salign" value="" />
                              <param name="allowScriptAccess" value="sameDomain" />
                          <!--<![endif]-->
                              <a href="http://www.adobe.com/go/getflash">
                                  <img src="http://www.adobe.com/images/shared/download_buttons/get_flash_player.gif" alt="Get Adobe Flash player" />
                              </a>
                          <!--[if !IE]>-->
                          </object>
                          <!--<![endif]-->
                      </object>
                  </div>
          </div>
          • 2. Re: [Issue] FLVPlayBack component in browser visualizzation
            adninjastrator Level 4

            Looks like your original problem was just one of pathing... a pretty common issue. And yes, you can reuse the skin on multiple pages as long as the pathing is correct. So when used on different pages, just be sure that the path used is correct for that page.

            As a little refresher on pathing:

             

            Pathing issues

             

            Almost always when it works on the local machine and not the server, it's a pathing problem.
            You can put your Flash related files in whatever folders you want, they do not have to be in the root. But if sticking them in there worked, then you know that the issue was a pathing problem.
            Just remember that paths become relative to the Web page on which those Flash files are used. So for example, if your .swf is in the flash/data folder and you use that .swf on a Web page in the root, you are in effect, removing that .swf from flash/data and putting it in root. So if the .swf is loading any related files (xml, etc), the path used inside the .swf to the .xml file has to be relative to it's new location in root and back down into flash/data. This is true even though when testing the .swf by itself, it can be inside flash/data and work just fine, since relative to it's location, the path is just fine, they are in the same folder. But if that same path is used when the .swf is placed on a page two folder levels up, the relative path has changed, the old "same folder" path will not work.
            So just be sure that you use addresses relative to the final locations and you can put the files wherever you want.
            Best wishes,
            Eye for Video
            www.cidigitalmedia.com

             

            Best of luck to ya!

            Adninjastrator