6 Replies Latest reply on Dec 15, 2010 7:58 PM by Dubulous

    Major "Skipping" problem during playback.

    Dubulous

      Hello,

       

      I posted this on a different forum already, but maybe this time I will re-phrase it so my message is received a little better.

       

      When I snip a 5 second or so loop of audio, and open it in a new file, I am getting very serious "skips" during playback.  This does NOT only occur at the end of the loop where it starts over at the beginning.  It is actually happening at random, sporadic moments throughout the loop during playback.  It is not a "break" that occurs after dragging or anything like that.  This is something that is definitely not supposed to be happening.  It is blatantly a problem.  And my computer is not old or cluttered.  I got it several months ago, and it's in fine working order.  These skips are real.

       

      I have been asked to send a copy of something so you guys can see what I mean, but that is not possible.  When the file is saved, and opened in iTunes or whatever, it plays perfectly fine.  This is only happening during playback on AA.  The problem is that it's very annoying and breaks up your concentration during a time when concentration and precision are essential to creation.

       

      Here is the thing, I'm not asking for a way to fix this on the beta release.  I know there is no setting to change or anything like that.  I'm just asking for you to review this and take it into consideration before releasing the final product.

       

      Thank you in advance for your time.  And thank you for providing me with a creative outlet throughout the years.  I was very, very pleased to hear that AA was coming to the mac!

        • 1. Re: Major "Skipping" problem during playback.
          Dubulous Level 1

          okay, to add onto this, there is something else I just noticed.

           

          when I take that same 5 second loop, copy it, and paste it immediately after itself one or two times....basically making the track 10 or 15 seconds long instead of 5 seconds...it no longer does the skipping! 

           

          this makes me think there must be some type of minor flaw on looped playback of very small audio files of 5 seconds or less.   maybe?

           

          thanks

          • 2. Re: Major "Skipping" problem during playback.
            JGrabowMST Level 1

            Macs are touchy beasts, but I would blame this on your audio buffer size being too large or too small. When this problem occurs, in the lower right hand corner of Audition, does it say that there are "Dropped Samples"? If it does, your buffer size is set incorrectly. There is no universal buffer size, it takes a bit of testing and trial and error to find the correct size for your computer.

             

            I don't know what hardware you're using, or if it's just whatever is built into the Mac that you have, but in the Adobe Audition preferences, there should be a buffer size setting, which you should try adjusting to see if it changes the problem you're having.

             

            Additionally, this could relate to having the sample rate set incorrectly in Audition vs what your hardware supports/uses as default. I do believe Macs default with 48kHz, but I'm not 100% sure on that off the top of my head. Audition might default to something else, maybe 44.1kHz.

            • 3. Re: Major "Skipping" problem during playback.
              Dubulous Level 1

              Okay thank you for the help.  Much appreciated, and thank you for putting it in lamen's terms.  I am not a computer genius by any means, just a musician.

               

              I will try your suggestions and see if I can find something that flows better.  thanks again.

              • 4. Re: Major "Skipping" problem during playback.
                marchvet
                I do believe Macs default with 48kHz, but I'm not 100% sure on that off the top of my head. Audition might default to something else, maybe 44.1kHz.

                So does that mean you should be recording at 48khz on macs?  I have been using the 44.1khz...

                • 5. Re: Major "Skipping" problem during playback.
                  _durin_ Adobe Employee

                  The sample rate you record at should depend on the material you're recording and the expected destination.  There's no "preferred" sample rate on Macs, though the hardware generally defaults to 48K.  If you want to record at a different sample rate, it is recommended you configure your Device Sample Rate to match to minimize any conversions.  You can do this by selecting Preferences > Audio Hardware and adjusting the "Sample Rate" drop-down.

                   

                  (Note: This is a list of sample rates indicated as supported by the  hardware driver.  In Audition, you can record using almost any arbitrary sample rate.)

                   

                  As for Dubulous' skipping problems, I'll agree that it sounds like a buffer issue, although this should really only be an issue if a clip is smaller than the device buffer, which I doubt is the case for a 5-second file.  If you save the skipping file, close it, then reopen it, do you still experience skipping?  I'm curious if the problem is related to NEW short files or ALL short files.

                  • 6. Re: Major "Skipping" problem during playback.
                    Dubulous Level 1

                    I think you guys are right.  It seems like there is just a little something off.  I started using 48k and it seems to work a bit better so far.

                     

                    If it happens again, I will immediately save the file and open it back up to see if it does the same thing.

                     

                    I do know, however, that if I save the file and open it in iTunes it works just fine.  So it's obviously something that is only occuring during playback.

                     

                    Hey I also have a side question - is there any way to do a simple bass increase, or a simple treble reduction?  It was very easy on AA3, but I can't find it anywhere here.  I know there are a lot of other ways to achieve this, but I always liked the simple little "small bass increase" option.