3 Replies Latest reply on Dec 8, 2010 8:02 AM by Mete Atamel

    Messaging SocketServer stops to accept new connections on Solaris

    Hans Moreels

      We have migrated our application from LCDS2.6 to LCDS3.1 on Tomcat 5.5 running on Solaris 10.

      Since we have done this our SocketServer (used by rtmp & nio-channel) stops accepting new connections after X time (sometimes some hours, some time some minutes). Connected clients keep getting messages on port 2037, but any new connection on this port fails. (also a telnet is no longer possible)

      Does any one has seen this problem?

      Any help is welcome !

       

      This is the situation:

       

      We have 1 message destination in our messaging-config

       

       

      <destination id="marketdataStream">

      <properties>

       

      <server><message-time-to-live>12000</message-time-to-live>

      <durable>false</durable>

      <allow-subtopics>true</allow-subtopics></server>

      </properties>

       

      <channels>

      <channel ref="serverRtmp"/>

      <channel ref="serverNio"/>

      <channel ref="serverHttp"/>

      </channels>

      </destination>

       

      The SocketServer configured in flex-config

      <servers>

      <server id="nioserver" class="flex.messaging.socketserver.SocketServer">

      <properties>

      <http>

      <cross-domain-path>crossdomain.xml</cross-domain-path>

      </http>

      </properties>

      </server>

      </servers>

       

      the 2 channels use the same socketserver. (serverRtmp & serverNio)

       

      <channel-definition id="serverNio" class="mx.messaging.channels.AMFChannel">

      <endpoint url="http://localhost:2037/nio" class="flex.messaging.endpoints.NIOAMFEndpoint"/>

      <server ref="nioserver"/>

      <properties>

      <polling-enabled>true</polling-enabled>

      <polling-interval-millis>0</polling-interval-millis>

      <wait-interval-millis>-1</wait-interval-millis>

      </properties>

      </channel-definition>

       

       

      <channel-definition id="serverRtmp" class="mx.messaging.channels.RTMPChannel">

      <endpoint uri="rtmp://localhost:2037/rtmp" class="flex.messaging.endpoints.RTMPEndpoint"/>

      <server ref="nioserver"/>

      <properties>

      <block-rtmpt-polling-clients>true</block-rtmpt-polling-clients>

      </properties>

      </channel-definition>

      </channels>