2 Replies Latest reply on Apr 25, 2011 12:03 AM by umarmalik

    RDS - data connection

    |3uddy

      So i have been following the steps in the Burrito 'learn to build an app in an hour' and so far it's taken me 2 days!!

       

      The problems seems to be with connecting to the data service.
      I have followed the instructions for the Java developers but i get the message: 
      "RDS server message: could not initialize class com.adobe.rds.core.services.Messages"
       
      This is after selecting BlazeDS as the service type and checking the 'no password required' box in the Authentication window. 
       
      There doesn't seem to be any help on google for this issue either. I had 1 hit when searching for the above error message and that lead to a dead end. 
       
      Any help would be greatly appreciated!

        • 1. Re: RDS - data connection
          Aymen.Dev

          After setting up BlazeDS, you have to enable RDSDisptachServlet, which is used by Flash Builder to get destination details. This is disabled by default. It’s very simple all you have to do is to un-comment/add the Servlet mapping in the web.xml.

           

            <servlet>
                  <servlet-name>RDSDispatchServlet</servlet-name>
            <display-name>RDSDispatchServlet</display-name>
                  <servlet-class>flex.rds.server.servlet.FrontEndServlet</servlet-class>
            <init-param>
             <param-name>useAppserverSecurity</param-name>
             <param-value>false</param-value>
            </init-param>       
                  <load-on-startup>10</load-on-startup>
              </servlet>

              <servlet-mapping id="RDS_DISPATCH_MAPPING">
                  <servlet-name>RDSDispatchServlet</servlet-name>
                  <url-pattern>/CFIDE/main/ide.cfm</url-pattern>
              </servlet-mapping>

          • 2. Re: RDS - data connection
            umarmalik

            I am having the same issue as I3uddy, but even after implementing the solution you proposed. Flex Builder 4.5 gives the same error. Any other suggestion what can be causing this error.

             

            Thanks.