5 Replies Latest reply on Dec 22, 2010 2:41 PM by Maverick8581

    Imported SWF Issues

    Maverick8581

      Here's the issue:

       

      Running FC, imported a .swf. Set an action sequence to play imported .swf on application start. Locally, it plays great. Deployed to a server, and sometimes the imported .swf freezes after one or two seconds of playback. I've tried it on several machines, both PC & Mac, Firefox, IE, yadda yadda yadda...same thing happens regardless. If you're lucky, you can only hit Refresh twice before getting it to play again...recently though, the number of F5 hits has jumped.

       

      The imported .swf was generated from a Flash 8/CS3 file, so the highest Flash Player compatibility available was 9. It is using AS3, and it is set at 24fps. The total animation runs for about 40 seconds (its two banners back-to-back). The total .swf file size is about 158kb. The total file size of the FC .swf is only 83kb (there's a menu/navigation bar on top, then the .swf banner plays at the bottom).The rest of the components work without a hitch (a few rollover effects, etc), by the way

       

      You may wonder why I combined the two banners into one long animation...I'm not as skilled at Flash. I struggle with Actionscript, yet have very few issues with the animation part. Being a designer and finding out about Catalyst, I immediately jumped at the chance to try it out. So far, I like it...there are some items that leave much to be desired, but hey...it's a first-gen release.

       

      Moving on...so, I did try and create another .fla file that loaded the banners outside of the .swf (the animations were initially separate). Using some code I found in a "Learn Flash CS3 in 24 Hours" book, I cobbled together a .swf that loaded the external animations and got it working...'til I ported it into Catalyst. I referenced nearly every resource on this site to help me get this working: publishing the Catalyst file, dropping the external animations into the assets folder, then uploading to the server, or something to that effect. The .swf that was supposed to load the animations had a nifty pre-loader progress bar on it that just left spinning....no animations loaded. I tried tweaking settings here and there, both in the imported .swfs and in Catalyst...I did read this though: http://forums.adobe.com/thread/748841?tstart=90. Really? Can anyone verify this?

       

      In short, I'm at a loss. I really would appreciate any assistance provided, becuase I'm not entirely sure what else to try. I'll try and provide additional details if anyone needs them.

       

      Thanks in advance.

        • 1. Re: ok, so search out my posts...
          cachefinder

          I struggled with this for the last few days.

          Pretty much, it works locally, but not on the server, right?  Ok all the stuff in 'deploy to web', ftp it to your server on the same file/level as your MAIN, etc.

          It needs to be next to the MAIN so that MAIN knows omgwtfbbq and does its stuff.

           

          Your post was sort of tl;dr but I just slogged through this stuff.  It is not how you are exporting the catalyst stuff etc, it is what resources are available to the browser/player once you are up and running.

          • 2. (Update) Re: ok, so search out my posts...
            Maverick8581 Level 1

            Ok...so, I  tried placing the long banner swf in the directory where my main.swf is (the one generated by Catalyst). It appeared to run ok, so then I tried my other option of using the pre-loader .swf. I dropped it into the same location where the main.swf is (as well as keeping the same files in their pre-existing locations)...no dice. The preloader is still just spinning, but not loading the external swf.

             

            I'm going to try out my first option and see if the banner loads without very few hiccups. I'll also go back and check my .fla files again to make sure I didn't miss or remove anything. Aside from that though, I do appreciate your assistance and I'll check out your previous posts in the meantime. As always, I'm open to other suggestions!

             

            Update: So, I tried just the banner again. Made sure the swf is in the same folder that the main FC swf is in...its still locking up, but not as often. Oy...

             

            Message was edited by: Maverick8581

            • 3. Fixed It...
              Maverick8581 Level 1

              Unbelievable...

              So after two days of trying shorter animations, pouring over countless amounts of code, sifting through result after result of google searches, it all came down to a 2-second delay.

               

              When I imported the .swf into Catalyst, I set the delay to 2 seconds before playing the animation. I uploaded it to the test server, and the freezing went away. I tried several other swf files, and they all played perfectly! Granted, there's a tiny delay before the animation plays, but its better than having it play right off the bat then watching it hang.

               

              Is this a caching or buffering issue? I would think that, when the Catalyst swf loads, it would start pre-loading the animations before it played (unless if there's a way to do that on the original .swf, but I'm not that versed in AS3 to figure it out). That may be a feature worth having in future Catalyst versions.

               

              So, for anyone experiencing an issue where their animations hang (i.e.: an imported banner): when you import it into Catalyst and set it to play, place a 1 or 2 second delay on it before it starts playback. That should give it time to load up.

              • 4. Re: Fixed It...
                Francisco Quaresma

                Thanks for letting us know how you fixed the problem, I had a similar problem and delaying the animation fixed it!

                • 5. Re: Fixed It...
                  Maverick8581 Level 1

                  Anytime, Francisco! Glad to have helped out