5 Replies Latest reply on Jul 20, 2007 11:07 AM by Peter Flynn (Adobe)

    Up grade from flex2 to flex3

    aprildavid Level 1
      I use eclipse. After I upgrade Flex2 to Flex 3, I got following error:
      "Unable to resolve a class for ResourceBundle:charts. Does any one knows why?

      Thanks!
        • 1. Re: Up grade from flex2 to flex3
          kasiopi
          I have the same problem. Have you find anything yet?

          Thanks in advance...
          • 2. Re: Up grade from flex2 to flex3
            Peter Flynn (Adobe) Adobe Employee
            Can you tell us more about how you've upgraded? If you are using the plugin version, make sure you didn't install into the same copy of Eclipse that FB 2 was installed in. You'll need a fresh copy of Eclipse to install FB 3 into.

            If you did install it onto the same copy, however, try starting Eclipse with the -clean option. Some users have reported success after doing this.

            - Peter
            • 3. Re: Up grade from flex2 to flex3
              Peter Flynn (Adobe) Adobe Employee
              Ok, I did a little more research on this. It looks like you're hitting this LCDS-related bug:
              https://bugs.adobe.com/jira/browse/FB-7179
              This is already fixed for FB's next beta. In the meantime, see the 05/30/07 comment for our suggested workaround.

              Although note that you may also see this issue:
              http://bugs.adobe.com/jira/browse/SDK-11438

              Hope that helps,

              - Peter
              • 4. Re: Up grade from flex2 to flex3
                kasiopi Level 1
                thanks for the reply Peter...
                I have downloaded the latest release, and copied the old files related with charts:
                - libs/charts.swc
                - locale /charts.properties
                -charts_rb.swc
                -lib/charting-source.jar

                But now mxml files are not compiled:

                --------------------------------
                Error: Declaration of style 'leading' conflicts with previous declaration in ...\flex_sdk_3\frameworks\libs\fr
                amework.swc(mx/controls/alertClasses/AlertForm).

                ...\flex_sdk_3\frameworks\libs\charts.swc(mx/charts/AxisRenderer)

                Error: Declaration of style 'textDecoration' conflicts with previous declaration in ...\flex_sdk_3\frameworks\
                libs\framework.swc(mx/controls/alertClasses/AlertForm).

                ...\flex_sdk_3\frameworks\libs\charts.swc(mx/charts/series/PieSeries)

                Error: Declaration of style 'textDecoration' conflicts with previous declaration in ...\flex_sdk_3\frameworks\
                libs\framework.swc(mx/controls/alertClasses/AlertForm).
                --------------------------

                Any ideas ??
                Thanks again...
                • 5. Re: Up grade from flex2 to flex3
                  Peter Flynn (Adobe) Adobe Employee
                  Hi, the workaround listed in the bug is as follows:

                  "What we need to do when you don't use the server's SDK or do server compile is make sure to add both fds.swc and the {locale} folder to the libpath so we pick up fds_rb.swc automatically. The workaround for Beta is to tell people to add the fds_rb.swc manually to their libpath."

                  Afaik you shouldn't have to do anything with charts. If you've linked in the 2.0.1 charting SWCs to your 3.0 project, that probably would cause an error.

                  - Peter