5 Replies Latest reply on Feb 16, 2011 8:25 AM by Steve Grisetti

    Alpha Channel Quicktime MOV

    NALRB

      Hello all.

       

      I have rendered out a 3D logo from a 3D program to a quicktime movie and had set my background on the rendered file to be a transparent alpha channel. Once I import the 3D logo MOV into premiere elements, add it to my timeline, choose keying, choose alpha adjust I had expected that there would be a selection to use the alpha channel so that the background would turn off to reveal the video clip underneath.

       

      Nope. All it did was give me a slider to adjust the alpha which fades the entire clip and the 3D logo fades as well. I don't get it!

       

      In premiere pro trial version all I had to do was place the 3D MOV into the timeline, check off that I wanted to use the clips alpha and bingo! The background turned off to reveal the clip below. Simple.

       

      Where is that setting in elements? Does it support quicktime movies with built in alpha channels?

       

      Chroma keying is not an option as the 3D logo has many shades of colours.

       

      Has anyone found the option for this or know of a workaround?

        • 1. Re: Alpha Channel Quicktime MOV
          Steve Grisetti Adobe Community Professional

          If your program is outputting and MOV with a true alpha channel, you won't need to key it all.

           

          The transparent areas will simply be transparent. I do it all the time with video from After Effects.

          • 2. Re: Alpha Channel Quicktime MOV
            the_wine_snob Level 9

            Like you, and Steve both state, with a proper Alpha, things should just work.

             

            I'd go back to the 3D program and check the Export settings. Likely a checkbox missed, or similar, there.

             

            Good luck,

             

            Hunt

            1 person found this helpful
            • 3. Re: Alpha Channel Quicktime MOV
              NALRB Level 1

              In flash CS4 where the 3D logo had been imported to from swift 3D, placed instance on stage, then re-exported as a quicktime MOV, in the QT export settings there is a check box "Ignore stage color (generate alpha channel)" is checked. I guess I will do further testing.

               

              In the mean time I decided to just use the export swf rather than a QT MOV and the alpha worked great.

               

              I would have rather been able to use the raster setting in swift 3D for ultimate look and feel as when I export from swift 3D as a video file the background remains. When I had used the raster render then export as a QT from swift 3D its all weird.

               

              I will continue to test from swift 3D directly.

               

              Thank you for your responses!

              • 4. Re: Alpha Channel Quicktime MOV
                NALRB Level 1

                I solved it!!  It was because I was using compression mpeg ( to save on file size ) on my export from flash. I set compression to none and the clip once placed onto the timeline in premiere elements the background automatically is gone.

                 

                ------------------------------------------------------------------------------------------ ----------

                 

                Ok after much frustration Adobe Premiere Elements 9 Pro Will not use the alpha channel of my QT MOV.



                Again here is the scenario:


                Using Flash I have created a vector animation;


                I then choose to export movie from the flash file menu and select type quicktime movie, click ok;


                At this time the QuickTime Export Settings Dialog Box appears;


                There is a check box " Ignore stage color (generate alpha channel)" Which I select;


                I then select which compression I want to use, then click ok;


                Movie is created, I import into Premiere elements 9;


                Select interpret footage from file menu;


                selecting Invert Alpha channel does nothing to my clip " background is still solid"


                selecting Ignore Alpha channel does nothing to my clip " background is still solid"


                What could be the problem here? I just do not understand why there is no setting to "Use Clips Alpha channel" like in other versions of premiere???


                You would think that a clip with an already built in alpha channel I could just drop the clip into a video layer and the background would automatically be transparent revealing the video layer underneath...

                • 5. Re: Alpha Channel Quicktime MOV
                  Steve Grisetti Adobe Community Professional

                  Yes, that is correct. The MOV must be uncompressed in order to carry the alpha channel information.