10 Replies Latest reply on Jan 5, 2011 7:06 PM by phsjr

    Importing video from Fraps

    drlemur67 Level 1

      I am trying to use Adobe Premiere to edit screen capture video collected with Fraps during video game play.  The video is captured at1680x1050, 1:0 pixel aspect ratio (depth 32, frame rate 30).  During editing the video looks fine with some very minor padding (black bars) left and right.

       

      But when exporting the video (for upload to youtube), I end up with much more padding (black bars) around all four edges of the video.  I have tried a variety of output settings, but why is the video not at least filling the vertical aspect?  I have also tried some different input settings and cannot tell if these are making much of a difference.

       

      How do I convince Premiere not to shrink the video into the middle of the screen?

        • 1. Re: Importing video from Fraps
          John T Smith Adobe Community Professional & MVP

          You might want to use the forum search, and enter

           

          fraps

           

          to read previous discussions

          • 2. Re: Importing video from Fraps
            Steve Grisetti Adobe Community Professional

            There are a number of problems with using FRAPS in Premiere Elements. The program generally doesn't work well with it.

             

            But, if you're able to get it to work, it's wise to first ensure that the FRAPS video is a standard size (e.g., 640x480 square pixels) so that it will fit in a standard 720x480 anamorphic pixels project. You're not going to be able to get the project to size to the video.

             

            For hi-def video, try 1920x1080 square pixels in a project set to those specs.

            • 3. Re: Importing video from Fraps
              the_wine_snob Level 9

              This THREAD has several links. I'd follow each of those for some tips.

               

              Good luck,

               

              Hunt

              • 4. Re: Importing video from Fraps
                drlemur67 Level 1

                I have been importing the video as 1920x1080, which seems to work well.  It imports fine, I can edit it and it actually looks great in the preview window in the Premiere editor (it's padding black, probably to fill in from 1680 to 1920 horizontally, which I'm fine with).

                 

                I just can't figure out which of the output settings to use to not screw up the size.  I'd like it resampled to 720x480 for youtube, but when I pick a smaller output resolution, I end up with upper and lower black bars as well.

                 

                I feel like this is a Premiere 9 interface problem -- I'm finding the interface very difficult to navigate even when I know what I want to d.  Where is the button to press or check to "not squash my output video"?  Or where might a box be checked in my project that is squashing it?

                 

                If my output looked at all like the preview in the editor, I'd be thrilled.

                 

                P.S. Searching prior fraps threads seems to turn up a lot of people wrestling with other adobe programs and or having more difficulties.  I just want to fix the output problem without having to manually test all zillion options (it takes awhile to test each one and I haven't found one that doesn't squish yet).

                • 5. Re: Importing video from Fraps
                  the_wine_snob Level 9

                  Look at down-rezzing to 720 x 480 Widescreen (16:9) with PAR = 1.2 (1.212 in PrPro, but do not think that PrE has adopted the BBC PAR).

                   

                  You have a Widescreen Project with square pixels, but for SD playback, you will want to use the SD Widescreen setting of PAR = 1.2 to "unsqueeze from 4:3. With SD material, one uses non-square pixels, and my guess is that you chose the the 4:3 w/ PAR = 0.9.

                   

                  Now, to get rid of the black bars in your Project, you could Scale your FRAPS footage to match the 1920 x 1080 with either the fixed Effect>Motion>Scale, or via Scale to Default Frame Size, or similar syntax. I forget if the term changes between PrE and PrPro. Now, the quality with any Scale will degrade, but for such a slight Scaling, you might never notice. Also, as you are down-rezzing, I doubt that Scale will ever be noticed. Check it out though, as you might think that the degrading is too much to live with.

                   

                  Good luck,

                   

                  Hunt

                  • 6. Re: Importing video from Fraps
                    drlemur67 Level 1

                    Thanks very much for trying to help, Hunt.

                     

                    I just tried various output settings, including widescreen (DV NTSC Widescreen) and 1.2 PAR and I'm still getting sizeable black bars at the top and bottom of the screen.  I think the bars are smaller at 1.2 PAR than they were at 1.0 PAR.

                     

                    There does not seem to be any options to try any other settings that I can find in PrE9.

                     

                    Also, I cannot find a scaling option in the Effects options list either (there's no Motion subgroup either).

                     

                    I zoomed in and out in the Editor and confirmed that it looks exactly as I would like in the preview.  Why is it rendering the video into/onto a black field and not scaling it to fit at output?  Where's the option to turn that off?

                     

                    Merry Christmas, too.

                    • 7. Re: Importing video from Fraps
                      the_wine_snob Level 9

                      In Effects, one would Select the Clip that needs to be Scaled, then click the Effects tab, which will open up the Effects Control Panel. Near the bottom-left, there is Edit Effects. Each Clip automatically has several fixed Effects, and Motion is one of those. Open that, and you will see both Scale and Position. That is where the Effect>Motion>Scale is adjusted.

                       

                      One Export/Share option, that does allow Cropping is Flash. I cannot recall which others allow for that. The DV Export/Share options are basically set to the DV attributes.

                       

                      Good luck,

                       

                      Hunt

                      • 8. Re: Importing video from Fraps
                        drlemur67 Level 1

                        I think I got it -- Windows Media, HD 720P 30 fps as the output format seems to be just what I was looking for.

                         

                        Hopefully this is helpful to anybody else who runs into this problem:

                        1) Import using a HD spec slightly larger than your Fraps (game) resolution

                        2) Export with WMV, HD 72P 30 fps

                        3) Upload to youtube (if desired)

                        • 9. Re: Importing video from Fraps
                          phsjr Level 1

                          I'm having similar issues but I use Playclaw to record my game video instead of Fraps. However, APE won't even let me import the AVI that Playclaw creates, error is claiming unsupported file (coded?).

                           

                          What are your settings in Fraps? Do you use compression? Are you recording at full size?

                           

                          Thanks!

                          Paul

                          • 10. Re: Importing video from Fraps
                            the_wine_snob Level 9

                            Paul,

                             

                            What are the full specs. of those AVI's? This ARTICLE will give you some background and detail. The "devil" is likely in those details, with a CODEC like Xvid, or DivX.

                             

                            Let us know all about those files, and someone can likely help you.

                             

                            Good luck,

                             

                            Hunt