0 Replies Latest reply on Dec 28, 2010 10:38 AM by RajMu

    Error #2036: Load Never Completed.

    RajMu

      Hi All,


      I'm a flex newbie. I have a flex 3 swf application which is running in http domain. I'm trying to load a jpg image from a https .net webservice. my code works perfectly fine in FireFox. but I'm getting "Error #2036: Load Never Completed." in IE browser.

      I have a crossdomain.xml under .net webservice root folder.

       

      Also, I'm using an encoded URL to load the image from webservice.


      Here is my code,


      private function onAppComplete():void

      {


           var loaderContext:LoaderContext = new LoaderContext();

       

           loaderContext.checkPolicyFile = true;


           var loader:Loader = new Loader();


           loader.contentLoaderInfo.addEventListener(Event.COMPLETE,

                                                                            function(event:Event):void

                                                                            {

                                                                                 image.source = event.currentTarget.content;

                                                                            }

                                                                         );


           loader.contentLoaderInfo.addEventListener(IOErrorE vent.IO_ERROR, ioErrorHandler);

       

           Security.loadPolicyFile("https://webservicedomain.com/crossdomain.xml");


           var request:URLRequest = new URLRequest("https://webservicedomain.com/Ashx/SecureThumbnailAsync.ashx?TNPath=PJzVVE2P0kAY7gft0 sWNPzIPORhPMOkUupUDB4WNoyKQ8BEjJd22DDDYTpFO1%2bDVo z%2fFn%2bCf8Or%2fMd503roaNZqVPZg4zUynb9953uf9GkoWJ OozGPCGcUMRyyxMYpQobIfSDUHzPIkyToPKKUkr5Q2fWJOQt%2 fxrRQpCVWn11co4rZx25bMDSZKVoyKQNFSxnN3SPrzl798AdR2 Ubz%2fr4I3JguGD9dN%2bo%2f8ID80X4%2bhls3kT1F8LFPX3P oP%2fEKKolcRxrtAp49f1HFsLKrgWZoAdP3AsknvuXGUIjVZZH DCfRgOfr1oJ4z5lZKuLs%2bqoNxCzpzrZqfc7bXXcaR%2f3%2f JhM%2fCgjA59uuyoXZWFFNYx38nCXchIL%2bCgS8RTMU%2fSQC CQaoo5N%2bToPTq%2fk8hN6pfrPgjSbQTp0SNfSdUVlsMjEUCG UcSu3oxMQTMTPrPnccb%2fHK3UtE5sutlx84oa2FPDrpFbFuGZ X62Jb9YMartqobRNnHgb3nHoVO2o9WR4PHtcN6cdhQC0VYPl%2 baOABvj8ooqBBJdKXrA79aCK&MimeType=image%2fjpg&Dela y=0&MimeTypeId=0");

       

      loader.load(request,loaderContext);

       

      }


      would be really appreciated, if anyone could tell me what i'm going wrong here.