7 Replies Latest reply on Feb 7, 2011 3:57 PM by pixlor

    Fireworks CS5 Font Problem

    delacombo Level 1

      I have a non system font installed and when I choose it in Fireworks CS5, it doesn't select it, but goes back to the font it was on.  I checked my fonts and it's installed correctly.  Any ideas?  These fonts worked with CS3.  I'm on Windows 7 64bit, 4Gigs RAM, CS5 Design Premium. Thank you.

        • 1. Re: Fireworks CS5 Font Problem
          Linda Nicholls Level 4

          Have you checked the font to make sure it's not corrupted? Here's a link to a useful article on managing fonts in Windows OS.

          http://graphicssoft.about.com/od/aboutgraphics/a/fontoverload_2.htm

          • 2. Re: Fireworks CS5 Font Problem
            delacombo Level 1

            Thanks for your help.  It's a font group we've used for the last handful of years, and it's only not working on my Windows 7 machine.  I'm one of the first 2 in the company that have became a tester for Windows 7 (for good reason, considering this and other permissions issues).

             

            I've tried installing on my desktop, and a few other locations as shortcuts too, and in one instance, it worked as a shortcut on my desktop, for one file I was trying to create, but once I went back into Fireworks, it wasn't letting me select a font in that group again.  Really weird.

            • 3. Re: Fireworks CS5 Font Problem
              pixlor Level 4

              What do you mean by "custom font?" Is it a professional font purchased from a reputable foundry or is it a one-off by a designer specifically for your company?

               

              Is the font installed in your fonts folder (are the files actually there)? Can you use this font in other applications? Can you use it in Photoshop?

               

              If the font has permissions problems, have you tried running FW as an administrator? (To do so, right-click the shortcut in the Start menu and click "Run as asministrator.")

              • 4. Re: Fireworks CS5 Font Problem
                delacombo Level 1

                It's a purchased font, from around 2002 by HTF.  We've used it as our corporate font set since about 2005.

                 

                I am able to use it in MS Office, but in Adobe Fireworks, I select it from the properties list, and upon selection it bounces back to the previous font selected. 

                 

                Previously, I could have swore that it did this across all of CS5 programs, but appears to just be doing this behavior in FW at the moment.  Now, that could be because I checked the fonts settings box for allowing shortcuts (even though they aren't shortcuts), but that would mean FW should work too I would guess.

                 

                Sorry for my confusion or lack of font installation knowledge.

                • 5. Re: Fireworks CS5 Font Problem
                  delacombo Level 1

                  I checked over the article and it's great.  However, it doesn't appear that it relates to the issue I'm dealing with in regards to CS5's Fireworks.  It's come down to an issue with FW not allowing me to select any font in that font set.

                   

                  I'm thinking it may be due to being a font installed per our domain's Group Policy, and the Junction.exe feature we use to map locations on the drives.  The few of us that are on Windows 7 seem to be having some permissions and mapping issues that may be related...  (But again, I'm only having issues with FW at the moment).

                  • 6. Re: Fireworks CS5 Font Problem
                    delacombo Level 1

                    New info:  I didn't even try this originally, but if I type the font, and don't select with my mouse in FW, it lets me pick it!  So I've narrowed it down to selecting with pointer/mouse.  Weird.

                    • 7. Re: Fireworks CS5 Font Problem
                      pixlor Level 4

                      Fireworks has always been a little fussy about fonts, especially if they are even a tad wonky. A little research shows that HTF, Hoefler Type Foundry, became Hoefler & Frere-Jones in about 2005. I found a list of HTF fonts (looks like possible unsavory activity, though, so I won't post the link), but the company's current list of available fonts is somewhat different: http://www.typography.com/fonts/index.php. If you are using a font that is specifically HTF, you might want to check that there isn't a revised version available, perhaps an OpenType version, that may be more robust.

                       

                      Anyway... If the font is installed in your Fonts folder, then I wouldn't think it should matter if it was put there by GP or not. Can you check that the file is on your hard drive? From the Start button, click Control Panel. Hmm...try Classic View and you should be able to get to see your Fonts folder. Open that. Scroll until you see the font. See if you actually have a file or if you have a shortcut to something on a network drive. Check the Properties (right-click, select Properties) of the font and see if they're the same as a font that works in FW.

                       

                      Also, did you try running Fireworks as an administrator? If there are permissions problems, sometimes this mode will be the answer.

                       

                       

                      Edit based on the new info: Well...that's really cool! Glad you found that out!