6 Replies Latest reply on Feb 13, 2012 10:58 PM by Tracey.superchick

    CF Administrator Scheduled Tasks not working after upgrade to version 9


      I am running Coldfusion 9 on Windows Server 2008. Before we upgraded to 9, the scheduled tasks in CF Administrator were working but since the upgrade they have stopped working.


      I have a username and password and proxy server settings for this task.

      The CFIDE, cfschedule and the sites are running Anonymous Authentication, Windows Authentication is disabled.

      The url runs in the browser and when I run it manually in the Administrator I see a message saying that the task has run successfully but I am getting the following in my log file:



        • 1. Re: CF Administrator Scheduled Tasks not working after upgrade to version 9
          Adam Cameron. Level 5

          The error from the log did't come through in your post.  Sometimes these forums (which are running the most sh!t forums software I have ever encountered on a commercial website) get confused with formatting and truncate posts, or drop bits of them.  It's a neat feature.


          Can you repost the log entry?




          • 2. Re: CF Administrator Scheduled Tasks not working after upgrade to version 9
            Tracey_B Level 1

            <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
            <HTML dir=ltr><HEAD><TITLE>The page cannot be displayed</TITLE>
            <STYLE id=L_defaultr_1>A:link {
            FONT: 8pt/11pt verdana; COLOR: #ff0000
            A:visited {
            FONT: 8pt/11pt verdana; COLOR: #4e4e4e

            <META content=NOINDEX name=ROBOTS>
            <META http-equiv=Content-Type content="text-html; charset=UTF-8">

            <META content="MSHTML 5.50.4522.1800" name=GENERATOR></HEAD>
            <BODY bgColor=#ffffff>
            <TABLE cellSpacing=5 cellPadding=3 width=410>
                <TD vAlign=center align=left width=360>
                  <H1 id=L_defaultr_2 style="FONT: 13pt/15pt verdana; COLOR: #000000"><ID id=L_defaultr_3><!--Problem-->The page cannot be displayed
                <TD width=400 colSpan=2><FONT id=L_defaultr_4
                  style="FONT: 8pt/11pt verdana; COLOR: #000000"><ID id=L_defaultr_5><B>Explanation: </B>There is a problem with the page you are trying to reach and it cannot be displayed.</ID></FONT></TD></TR>
                <TD width=400 colSpan=2><FONT id=L_defaultr_6
                  style="FONT: 8pt/11pt verdana; COLOR: #000000">
                  <HR color=#c0c0c0 noShade>

                  <P id=L_defaultr_7><B>Try the following:</B></P>
                    <LI id=L_defaultr_8><B>Refresh page:</B> Search for the page again by clicking the Refresh button. The timeout may have occurred due to Internet congestion.
            <LI id=L_defaultr_9><B>Check spelling:</B> Check that you typed the Web page address correctly. The address may have been mistyped.
            <LI id=L_defaultr_10><B>Access from a link:</B> If there is a link to the page you are looking for, try accessing the page from that link.

                  <HR color=#c0c0c0 noShade>

                  <P id=L_defaultr_11>Technical Information (for support personnel)</P>
                    <LI id=L_defaultr_12>Error Code: 400 Bad Request. The data is invalid. (13)


            • 3. Re: CF Administrator Scheduled Tasks not working after upgrade to version 9
              Charlie Arehart Adobe Community Professional & MVP

              First, Tracey, to be clear, did you notice that among all that html ultimately it is about a status code 400 result in trying to execute the page, "400 Bad Request. The data is invalid. (13)"? Just something to note for perhaps later use. (A 400 code can indicate a variety of things.)


              Before going down that route, though, is this from the log in the \logs\scheduler.log? I suspect not, as it's all HTML. I suspect that's the output that perhaps you told the scheduled task to "save" its output to. Can you confirm? And If so, can you check your scheduler.log? If you don't have one, turn it on in the CF Admin, on the Logging Settings page (in the debugging and logging section of the admin), and run the test again.


              Speaking of that, you say that when you run in the CF Admin, it works ok. By what measure do you affirm that? Again, are you "saving" the output of the task? And that's different when you run it manually from the Admin? It just doesn't make much sense that the saved output generated by your running the task in the admin manually would be any different from it running at a scheduled time.


              Finally, if none of that that proves helpful, here's a trick: try setting up a test page that does a CFHTTP to call the same page that the scheduled task would (and you can provide the same username and password as attributes to that tag). Run that and see what output you get. That's effectively the same thing that a scheduled task does, but it may be subtly different. If it fails, it may give more information. If it works, we can go from there.


              /charlie arehart


              Providing CF and CFBuilder troubleshooting services

              at http://www.carehart.org/consulting

              • 4. Re: CF Administrator Scheduled Tasks not working after upgrade to version 9
                Tracey_B Level 1

                Its taken me a year to reply because I found a work around for this but I need to get this working now.


                I have a log file for the scheduled task and the message that is in the log file is "Connection failure". So ithe scheduled task does not run successfully whern I run it manually from the Administrator.


                I've created a page with a CFHTTP as per the above suggestion and it runs successfully, ie. no errors, from my browser and from the server's browser but when I run the url that the CFHTTP calls or the url of the test page I get the "Connectyion failure" message.


                I've tried a combination of usernames and passwords and none at all but nothing works.


                I don't know if this makes a difference but the server that Coldfusion 9 is running on is 64 bit


                Can anybody suggest anything else I can try?

                • 5. Re: CF Administrator Scheduled Tasks not working after upgrade to version 9
                  carl type3 Level 4

                  Are the scheduled task URLs https? If so I have seen "connection failure" occur where the ssl certificate chain is not satisfied. I could post more so if this sounds about right and you need more information post again.


                  HTH, Carl.

                  • 6. Re: CF Administrator Scheduled Tasks not working after upgrade to version 9

                    Hi Carl


                    Thanks for replying, no the urls aren't https, just plain http.

                    Any other suggestions?


                    Thank you