2 Replies Latest reply on Oct 17, 2012 10:37 AM by KScale

    mxmlc/compc error

    MartinHviid Level 2

      Hi

       

      I'm trying to setup a Ant script to compile my code, but I keep getting an error regarding an [Embed]

       

      Kol: 3: Fejl: '/../assets/images/info.png' kan ikke fortolkes til kodeoverførslen
          [compc] 
          [compc]           [Embed(source="/../assets/images/info.png")] 
          [compc]   ^
          [compc] 
          [compc] C:\Documents and Settings\Administrator\.hudson\jobs\ProcessGuide\workspace\src\dafolo\processguide\core\components\AbstractModelCommitingUIComponent.as(46): 
      Kol: 3: Fejl: Koden /../assets/images/info.png kan ikke overføres.
      
      I can't seem to get an english version of the error, but translated directly it says:
      
      Col: 3: Error:'/../ assets / images / info.png 'can not be interpreted to code transfer
      Col: 3: Error: Code / .. / assets / images / info.png cannot be transferred.

      I've also tried calling it directly from command, but I get the same error.
      I've tried changing the [Embed] a bunch of times, but it just keeps on failing.

      Thanks
      Martin

        • 1. Re: mxmlc/compc error
          MartinHviid Level 2

          Sry, I'll just post my Ant script:

          <project name="ProcessGuide" default="compile">

           

          <!-- load previously defined configuration properties file -->

          <property file="build.properties" />

           

          <!-- points to our flexTasks.jar we copied to the libs folder to distribute with the project -->

          <taskdef resource="flexTasks.tasks" classpath="C:/Documents and Settings/Administrator/Desktop/flexTasks.jar"/>

           

          <!-- Build and output the Main.swf-->

          <target name="compile">

          <compc output="Main.swc">

          <include-sources dir="./src" includes="**/*.as **/*.mxml" />

          <source-path path-element="C:/Documents and Settings/Administrator/Desktop/4.5.0.17689/frameworks"/>

          <compiler.debug>false</compiler.debug>

          <compiler.library-path dir="C:/Documents and Settings/Administrator/Desktop/4.5.0.17689/frameworks" append="true">

                          <include name="libs" />

                      </compiler.library-path>

          </compc>

          </target>

           

          </project>

          • 2. Re: mxmlc/compc error
            KScale

            The error in English says that it can't be transcoded.

            I ran into a lot of these when I switched to command-line building. My embedded resources were coming from another project. I had to change the path in the Embed and add the resources folder as a -source-path.