0 Replies Latest reply on Jan 5, 2011 5:14 AM by Avijit_1979

    INK Api Error while connecting to webservice using BlazeDS using Proxy

    Avijit_1979

      Hi,

       

      I'm new FlashBuider. Please help me to connect to webservice using BlazeDS.

       

      I'm getting 'INK Api Error'. I'm using Proxy to connect to my webservice my proxy-config.xml looks like

       

      <?xml version="1.0" encoding="UTF-8"?>
      <service id="proxy-service"
          class="flex.messaging.services.HTTPProxyService">

          <properties>
              <connection-manager>
                  <max-total-connections>100</max-total-connections>
                  <default-max-connections-per-host>2</default-max-connections-per-host>
              </connection-manager>
              <allow-lax-ssl>true</allow-lax-ssl>
         </properties>

          <adapters>
              <adapter-definition id="http-proxy" class="flex.messaging.services.http.HTTPProxyAdapter" default="true"/>
              <adapter-definition id="soap-proxy" class="flex.messaging.services.http.SOAPProxyAdapter"/>
          </adapters>

          <default-channels>
              <channel ref="my-amf"/>
        <channel ref="my-http"/>
          </default-channels>

          <destination id="DefaultHTTP">
          </destination>


      <destination id="testNetapp" adapter="soap-proxy">
           <properties>
                  <wsdl>http://ws.xwebservices.com/XWebEmailValidation/V2/XWebEmailValidation.wsdl</wsdl>
                  <soap>*</soap>
              </properties>
              <adapter ref="soap-proxy"/>
          </destination>

      </service>