11 Replies Latest reply on Oct 4, 2017 10:41 AM by Genw

    "No Camera Detected" when try tethered shooting




      Windows 7 Ultimate 32 Bits

      Lightroom 3.3(just updated to the latest version)

      Nikon D700 / D3s (supported according to this)




      When I connect any of my cameras (D700 / D3s) to my computer and fire up LightRoom and try to do a Tethered shooting, I get a "No Camera Detected" on the tethered shooting bar.




      - The cable works and the Windows driver works as my cameras are detected by Windows, show up in the devices list and I can browse the CF card content from the computer, so it is not a cable problem. It might be a driver issue with lightroom...


      - USB Mode: the D700 and D3 series only have PTP mode, no USB Mass storage (MSC Mode), so suggestions to turn on USB Mass Storage mode are just not going to work.


      - Both the D700 and D3 are listed as compatible cameras for tethered shooting in Adobe release notes


      Any ideas / fix / suggestions appreciated.



        • 1. Re: "No Camera Detected" when try tethered shooting

          I get something similar too - it's more intermittent than your problem but happens during EVERY single tethered session that I have done with LR3.


          I use a Nikon D700 and Windows 7 Home Edition 32 bit and the very latest LR3.3.  This problem has happened with every single revision of LR3.


          Unlike you it connects ok to begin with and then half way through a shoot everything locks up and the images won't load anymore. Sometimes it says the camera isn't detected but, as you have experienced, outside of LR3 Windows sees it fine and you can browse the compact flash card on board the camera with Windows Explorer i.e. there's no "Windows" problem apparently.


          I've tried the following when this happens:


          1. Stop & restart tethered shooting - magically Lightroom will start loading the "missing" images and I can continue a bit longer


          2. Switch the camera off and on - this works less frequently but sometimes the images will start loading, this implies to me the images are already in the PC buffer and it's not the camera - I assume the camera memory is cleared during a restart.


          3. Do a full reboot of the PC


          A lot of the time I simply lose the shots - which is extremely frustrating and not great when you've got clients in front of you.


          As I said I can absolutely gaurantee this will happen EVERY time I shoot tethered with Lightroom and I've worked out how to get around it BUT losing shots is ridiculous for what's supposed to be a pro product - NOT HAPPY



          • 2. Re: "No Camera Detected" when try tethered shooting

            Did anyone find out the answer to this problem? I have the same problem with my D300s... Crap, now what?

            • 3. Re: "No Camera Detected" when try tethered shooting
              Hal P Anderson Level 6

              Make sure your camera(s) have PTP specified in the USB menu item. "Mass storage" won't work.



              • 4. Re: "No Camera Detected" when try tethered shooting

                I had a similar problem with Nikon Camera Control 2 Pro where the camera not detected message appeared. Nikon told me the usual things to check, USB cable provided by Nikon with ferrite coil surrounding the cable, fully charged batteries etc. None of that worked! I finally figured out the problem with my system and offer my solution in hope that it will solve your problem. I'm running Win 7 Pro so my keystrokes may vary for your OS version:


                Here goes:

                1. Start, Run, Type services.msc in the Open box, hit enter
                2. Scroll to Windows Image Aquisition (WIA) service and double click the name
                3. In the startup type pulldown menu select Automatic (don't click OK yet, do it after you are all done)
                4. Select the Dependencies tab at the top of the WIA properties box to see the dependencies
                5. Click on the + sign to the left of the Remote Procedure Call (RPC) dependency to see the system components
                6. Go back to the services window and scroll to the Remote Procedure Call (RPC) line and double click it to open the properties box
                7. In the startup type pulldown menu select Automatic, then click OK
                8. Scroll to Remote Procedure Call (RPC) Locator service and double click the name
                9. In the startup type pulldown menu select Automatic, then click OK
                10. Scroll to RPC Endpoint Mapper service and double click the name
                11. In the startup type pulldown menu select Automatic, then click OK
                12. Scroll to DCOM Service Process Launcher service and double click the name
                13. In the startup type pulldown menu select Automatic, then click OK
                14. Scroll to Shell Hardware Detection service and double click the name
                15. In the startup type pulldown menu select Automatic, then click OK
                16. Click OK to finish closing the WIA properties box


                You should be done at this time and may need to re-start the computer. (not sure of that but why not at this stage)


                Hope that helps slve your problem, It did for me, at least the camera is now detected all the time and no dropouts..


                • 5. Re: "No Camera Detected" when try tethered shooting

                  Use a memory card formatted (no pictures inside). The Lightroom will recognize the camera.

                  • 6. Re: "No Camera Detected" when try tethered shooting
                    J S Mott

                    My D90 doesn't even show USB or PTP in the set up menu like my D200 does.  Unfortunately the camera that we need to shoot tethered with is the D90 at my business not my personal D200. What now?

                    • 7. Re: "No Camera Detected" when try tethered shooting

                      Initially when I read this I was hopeful.  But after following the steps - I still got the same results - No Camera Detected.



                      Dell Core I5 Inspiron Laptop (new)- got it to do tethered capture on location.

                      Windows 7 home premium 

                      LightRoom 4.2 (just purchased 2 weeks ago)

                      Nikon D300s


                      Initially when I connected my Nikon D300s - it worked perfectly with LR 4.2.  Weeks prior to that the D300s tethered perfectly to my desktop computer (Windows 7 Home Premium; LR 3.6) as well.

                      After about 30 photos while tethered to the laptop (all photos transferred to the LR 4.2 on the laptop) - I took a break and disconnected (not positive I did - may have left connected) the camera.  Later I re-attached and got the no Camera Detected Message.  Tried switching USB cables(to Nikon's supplied USB cable).  No camera detected.   Tried switching USB ports - same result.  In both instances Windows detected the camera and reported its battery life and space remaining on the card.


                      Found this posting, logged on as Admin and went through the steps, all of the services were already set to Automatic except RPC Locator. Set it to automatic  and saved.  Rebooted started LR and a tethered connection and connected the camera.  Windows detected it as before, but LR was clueless.  Realized that I had closed WIA before going to next step.  Started Services and repeated steps this time leaving WIA open after opening each service.  Set RPC Locator to manual and applied and then set to |Automatic and applied.  Went through steps, then clicked OK on WIA.  Closed out Services and rebooted.  Started up LR, opened Tethered Connection and attached camera.  No camera detected.  In all cases I tried depressing the shutter button half way to see if it awoke LR Tethered connection.

                      Decided to try the D300s on my Desktop (with LR 3.6).  Got the same results.  Windows 7 recognized the camera, and LR was clueless.  To me this strongly points to a problem with the camera, except that Windows recognized the camera both times - thus the USB port seems to e working fine.  Read through the D300s menu options in case there was a setting there that I had missed.  I didn't see anything relevant (plus I hadn't messed with it while Tethered).


                      So right now I'm up the creek with an on site session looming the horizon!

                      • 8. Re: "No Camera Detected" when try tethered shooting
                        Film4Now Level 1

                        To follow up on my post above - I was able to fix the problem.  By upgrading my firm ware to the latest version (1.01 released over 2 years ago), it solved the problem.  Although the release notes for that upgrade (the only one available) did not say anything about capture or anything that seemed related - the firmware fixed it.  Yes!

                        • 9. Re: "No Camera Detected" when try tethered shooting

                          I have similar problem.  I've just upgraded to LR6.  I am using Canon 70D.  My Canon 70D tethering was working a couple days ago.  Now it's not detecting my Canon 70D.  Is it possible the jack is broken? Did anyone ever has to repair the jack?  I plugged in with my old Canon T3i and tethering worked just fine. 

                          • 10. Re: "No Camera Detected" when try tethered shooting
                            Bob Somrak Level 6

                            Try importing directly from the camera using Lightroom or the Canon software.  If import works than the USB jack is OK.  Tether seems randomly problematic in LR from what I have seen on the forum although its worked ok for me the FEW times I have used it.

                            • 11. Re: "No Camera Detected" when try tethered shooting

                              I had to close out the EOS Utility and that fixed the problem.  I believe it was interfering with the connection with Lightroom.