4 Replies Latest reply on Jan 10, 2011 1:34 PM by Flexin10

    Flash Builder 4.0 configuration ??

    Flexin10

      Hello,

       

      To make a long story short I'm trying to create a simple SWF with Flash Builder with a width="1500" and a height="591". After compiling I copy the .swf from bin-release to my desktop. When I double click on the .swf it does not show up the size I want and has scroll bars on it. Is there a setting either within Flash Builder 4 to  or within Flex that makes this happen?  Below is my simple code which I have reduced to it's simplest form:

       

       

       

       

       

      xmlns:mx="http://www.adobe.com/2006/mxml"

       

      >

       

       

      <mx:Canvas

       

      1500" height="591" >

       

       

      <mx:Label fontSize="20" fontWeight="bold" color="#6a6a6a"

       

      325" y="10" text="POUNDS RECYCLED PER SCHOOL - 3RD QUARTER 2010" />

       

       

      </mx:Canvas>

       

       

       

      Thanks in advance.

      </mx:Application>

       

       

       

      x="

       

       

      width="

       

       

       

      <mx:Application

      <?xml version="1.0" encoding="utf-8"?>

       

       

        • 1. Re: Flash Builder 4.0 configuration ??
          Lee Burrows Level 4

          try putting the width and height within the mx:Application tag itself rather than its children (and maybe minWidth/minHeight too)

          • 2. Re: Flash Builder 4.0 configuration ??
            satheeshmekala

            Remove width/height from child and give it to application and remove minwidth and max width for application , by default flex will will add scrollbars when childerns width/height is more than application.

             

             

            <?xml version="1.0" encoding="utf-8"?>
            <mx:Application xmlns:mx="http://www.adobe.com/2006/mxml" layout="absolute" width="1500" height="591">
                <mx:Canvas  >
                   
                   
                   
                   
                   
                    <mx:Label fontSize="20" fontWeight="bold" color="#6a6a6a"
                             
                             
                             
                              width="325" y="10" text="POUNDS RECYCLED PER SCHOOL - 3RD QUARTER 2010" />
                                               
                                               
                                               
                                               
                                               
                </mx:Canvas>
            </mx:Application>

            • 3. Re: Flash Builder 4.0 configuration ??
              Flexin10 Level 1

              Thanks for the reply but that doesn't work. I have tried about every combination I can think of in that respect. To explain further I'm working with a 3rd party company on this project. They have an AIR app that is supposedly configurable. I'm supposed to be able to add my .SWFs to a directory and then change the applicable XML to change the look and feel of the app. The SWF must be 1500x591. I can add a SWF that I create in Flash with no problem. When I try to do the same with Flash Builder it doesn't work. The 3rd party says that they use Flex 3.5 while I'm using Flash Builder 4.0. Is there maybe a setting difference? I've even tried to create the project in 3.5 but that doesn't work.

               

              Thanks

              • 4. Re: Flash Builder 4.0 configuration ??
                Flexin10 Level 1

                Thanks for the reply but that doesn't work. I have tried about every combination I can think of in that respect. To explain further I'm working with a 3rd party company on this project. They have an AIR app that is supposedly configurable. I'm supposed to be able to add my .SWFs to a directory and then change the applicable XML to change the look and feel of the app. The SWF must be 1500x591. I can add a SWF that I create in Flash with no problem. When I try to do the same with Flash Builder it doesn't work. The 3rd party says that they use Flex 3.5 while I'm using Flash Builder 4.0. Is there maybe a setting difference? I've even tried to create the project in 3.5 but that doesn't work.

                 

                Thanks