2 Replies Latest reply on Jan 17, 2011 8:05 AM by don't need another login

    Most recent version of Adobe Reader for Mac OS Intel 10.4.11?

    Ctruelove01

      I needed to update my version of Adobe Reader. I clicked the appropriate designation - "Mac OS Intel 10.4.11-10.5.5" - downloaded the software, and then tried to install it.

       

      I got the error message "Couldn't open "Adobe Reader X Installer.pkg". This package type requires Mac OS X 10.5."

       

      Has anyone else experienced this problem? Other than a $39 call to Adobe to find out WHY the software they designated for my version of Mac OS doesn't seem to work, what can I do?