9 Replies Latest reply on Jan 13, 2011 9:56 AM by achem101

    Dynamic Link not working

    achem101

      I have two problems  that I have ran into regarding the dynamic link between Premiere Pro and After Effects.

       

      1. I started out keying a video in After Effects and brought it into Premiere and then I wanted to bring it back into After Effects. I selected "replace with After Effects composition. After it was done rendering in after effects the keyed video showed up as a rainbow colored block.

       

      2. When I did this, Premiere showed the keyed video as (in diffrent places on the timeline) as either not there or the same rainbow block.

       

      Does this mean that adboe cannot find the orgional After Effects comp?

       

      Any help would be appreciated,

      Alex

        • 1. Re: Dynamic Link not working
          Jim_Simon Level 8

          It sounds like you're taking it one step to far.

           

          You can't bring an AE comp into Premiere Pro, then back into AE.  It's a one way trip.  Instead of trying to go from Premiere Pro into AE, go back to the original AE comp that is being used inside of PP and do what you need to on that original.

          1 person found this helpful
          • 2. Re: Dynamic Link not working
            achem101 Level 1

            Thanks alot! I have another quick question. How can I re-obtain the (for me atleast) lost composition that used to be in Premiere.

            • 3. Re: Dynamic Link not working
              shooternz Level 6

              Re link it.

               

              Open AEFX and reopen the comp.

               

              Hopefuly you did not overwrite it by what you did.

              1 person found this helpful
              • 4. Re: Dynamic Link not working
                HarryPutnam Level 1

                achem101 wrote:

                 

                Thanks alot! I have another quick question. How can I re-obtain the (for me atleast) lost composition that used to be in Premiere.

                If its still in that pink color of AE projects inside premiere you can right click and choose edit original.  That would bring AE up with that project loaded.

                • 5. Re: Dynamic Link not working
                  HarryPutnam Level 1

                  HarryPutnam wrote:

                   

                  achem101 wrote:

                   

                  Thanks alot! I have another quick question. How can I re-obtain the (for me atleast) lost composition that used to be in Premiere.

                  If its still in that pink color of AE projects inside premiere you can right click and choose edit original.  That would bring AE up with that project loaded.

                   

                  Whoops sorry, I've never actually used the that `replace with AE comp' switch... I missed the part about `replace' so please disregard my reply

                  • 6. Re: Dynamic Link not working
                    achem101 Level 1

                    error.jpg

                    Ok,

                     

                    Well when I go back into after effects it shows the original comp as a placeholder. I tried right clicking, replace footage, and selecting the first after effects document. But, it still comes up with the same rainbow colored box around where it should be.

                     

                    Can the picture help at all?

                    • 7. Re: Dynamic Link not working
                      anuraggrwl Level 2

                      In after effects you will have two comps now with linked word for example anu linked comp1 and anu linked Comp2 just drag the linked comp1 from project pannel into linked Comp2 and you will be goog to go.

                       

                      Rightnow the new linked com2 that you created by mistake is empty and by default it always shows that rainbow blocks.

                       

                      Actually by clicking replace with after effect comp second time you have created a new dynamic link which is comp2 draging the linked com1 into linked comp2 solve your problem.

                       

                      you only need to click edit original for editing the same back in after effect for future.

                      • 8. Re: Dynamic Link not working
                        Jim_Simon Level 8
                        when I go back into after effects it shows the original comp as a placeholder

                         

                        That's because you now have two AE projects, with the first (PAS.aep) imported into the second (PSA 2.aep).  Go into the first and do all your work there.  Don't have two projects.

                        • 9. Re: Dynamic Link not working
                          achem101 Level 1

                          Hey guys,

                           

                          Thanks for all the response. Unfortunately because I am still a new user it's hard for me to understand exactly what to do. Would anyone care to do a quick Skype screen share to help me resolve this issue?

                           

                          Thanks a lot,

                          Alex