2 Replies Latest reply on Jan 11, 2011 2:20 PM by dblomquist

    Fiber Modeler - JavaMail Error

    dblomquist Level 1

      I've been working with the Fiber Modeler recently and everything works great in certain situations.  When I deploy my model to the server from Flash Builder 4 using RDS the server logs display all the endpoints created and the Hibernate relationships properly.

       

      Then problem that I'm facing is when I stop the server and restart it again.  If the model is already deployed to the server upon startup, I continually get the following stack trace:

       

      ------------------------------------------------------------------------------------------ ---------------

       

       

      Starting Macromedia JRun 4.0 (Build 108858), MyServer server

      01/11 13:03:19 info JRun Naming Service listening on *:2909

      01/11 13:03:20 info JRunDataSource bound to JNDI under name MyDB_Dev

      01/11 13:03:20 info JRun DataSourceService: Created JDBC XA Connection Pool named MyDB_Dev

      01/11 13:03:20 info Bound a LinkRef from "DefaultDataSource" to the default DataSource "MyDB_Dev"

      01/11 13:03:20 info JRun Web Server listening on *:8302

      01/11 13:03:20 info JRun Proxy Server listening on *:51002

      01/11 13:03:21 info Deploying enterprise application "JRun 4.0 Internal J2EE Components" from: file:/C:/JRun4/lib/jrun-comp.ear

      01/11 13:03:21 info Deploying EJB "JRunSQLInvoker" from: file:/C:/JRun4/lib/jrun-comp.ear

      Server CatAuctions-Data ready (startup time: 5 seconds)

      01/11 13:03:21 info Deploying enterprise application "default-ear" from: file:/C:/JRun4/servers/MyServer-Data/default-ear/

      01/11 13:03:21 info Deploying web application "JRun Default Web Application" from: file:/C:/JRun4/servers/MyServer-Data/default-ear/

      01/11 13:03:22 info Web Services in default-ear#default-war:

      01/11 13:03:22 info AdminService

      01/11 13:03:22 warning default-war web application has 'reload' as true in jrun-web.xml. Consider setting it false if the application is running in production environment.

      01/11 13:03:22 warning default-war web application has 'compile' as true in jrun-web.xml. Consider setting it false if the application is running in production environment.

      01/11 13:03:22 user JSPServlet: init

      01/11 13:03:23 info Deploying web application "LiveCycle Data Services" from: file:/C:/JRun4/servers/MyServer-Data/lcds/

      01/11 13:03:23 user JSPServlet: init

      01/11 13:03:24 user MessageBrokerServlet: init

      [LCDS]Adobe LiveCycle Data Services: 3.1.0.273931

      [LCDS]Server 'my-nio-server' of type 'flex.messaging.socketserver.SocketServer' created.

      [LCDS]Endpoint 'my-rtmp' created with security: None

      at URL: rtmp://{server.name}:2038

      [LCDS]Endpoint 'my-polling-amf' created with security: None

      at URL: http://{server.name}:{server.port}/{context.root}/messagebroker/amfpolling

      [LCDS]Endpoint 'my-amf' created with security: None

      at URL: http://{server.name}:{server.port}/{context.root}/messagebroker/amf

      [LCDS]Endpoint 'my-secure-amf' created with security: None

      at URL: https://{server.name}:{server.port}/{context.root}/messagebroker/amfsecure

      [LCDS]ModelDeploymentService: initializing...

      [LCDS]ModelDeploymentService: Getting persistence class

      [LCDS]ModelDeploymentService: Using default persistence class.

      [LCDS]ModelDeploymentService: Using model deploy directory: C:\JRun4\servers\MyServer-Data\lcds\WEB-INF\datamodel\

      [LCDS]ModelDeploymentService: Deploying model AuctionCast

      [LCDS]ModelDeploymentService: Error deploying model AuctionCast: Error loading model 'MyModel': java.lang.UnsupportedOperationException: This parser does not support specification "JavaMail(TM) API Design Specification" version "1.3"

      [LCDS]ModelDeploymentService: initialization completed.

      [LCDS]MessageBroker id: __default__ classLoader is: the MessageBroker's class loader and the context class loader (classLoader hashCode: 550132735 (parent hashCode: 1453771767 (parent hashCode: 855703640 (parent system)))

      [LCDS]Starting Adobe LiveCycle Data Services: 3.1.0.273931 Developer License

      [LCDS]SocketServer 'my-rtmp-SocketServer' is starting.

      [LCDS]SocketServer 'my-rtmp-SocketServer' is using an assigned executor of type: flex.messaging.util.concurrent.DefaultThreadPoolExecutor

      [LCDS]SocketServer 'my-rtmp-SocketServer' has determined the default thread priority for its executor to be 5.

      [LCDS]Reactor 'Reactor1' for SocketServer 'my-rtmp-SocketServer' is starting.

      [LCDS]Reactor 'Reactor1' for SocketServer 'my-rtmp-SocketServer' has started and is running at priority 5.

      [LCDS]Reactor 'Reactor2' for SocketServer 'my-rtmp-SocketServer' is starting.

      [LCDS]Reactor 'Reactor2' for SocketServer 'my-rtmp-SocketServer' has started and is running at priority 5.

      [LCDS]Acceptor 'Acceptor1' for SocketServer 'my-rtmp-SocketServer' is starting.

      [LCDS]Acceptor 'Acceptor1' for SocketServer 'my-rtmp-SocketServer' has successfully bound '/0.0.0.0:2038' to accept new client connections.

      [LCDS]Acceptor 'Acceptor1' for SocketServer 'my-rtmp-SocketServer' has started and is running at priority 5.

      [LCDS]SocketServer 'my-rtmp-SocketServer' has started.

      [LCDS]Server 'my-nio-server' is not referenced by any endpoints.

      [LCDS]SocketServer 'my-nio-server' is starting.

      [LCDS]SocketServer 'my-nio-server' will not start because no endpoints are configured to use it.

      01/11 13:03:27 user RDSDispatchServlet: init

      01/11 13:03:27 user RDSDispatchServlet: init

      01/11 13:03:27 user RDSDispatchServlet: init

      [LCDS]Model deployer servlet initializing

      01/11 13:03:27 user RDSDispatchServlet: init

      [LCDS]Model deployer servlet init completed successfully

      01/11 13:03:27 user RDSDispatchServlet: init

      01/11 13:03:27 user RDSDispatchServlet: init

       

       

      ------------------------------------------------------------------------------------------ ------------------------------

       

      I've tried adding the mail.jar file and mailapi.jar files to my classpath and also tried adding them straight to the lib folder of the JRun server instance.  Does anyone have a suggestion for me?

        • 1. Re: Fiber Modeler - JavaMail Error
          tomj Adobe Employee

          Two things:

           

          1. JRun isn't supported.  I know JRun is most excellant and I am very sad about it, but we don't test on it.  If you are running ColdFusion standalone, perhaps the CF folks may be able to help.  I would recommend checking the JRun property file in WEB-INF/lib/bootstrap.jar (open it with WinZip or similar) and playing with the javax.mail.* packages in there to see if you can fix things, but that really isn't a user serviable part.

           

          2. Check the XML parser, including dom4j.jar and its classes. It may be that the newer XML parsing classes are getting mixed in with the older JDK or CF jar files.  I am stumped as to why JavaMail comes in to the picture.  Do you have a stack trace (exception.log maybe)?  It certainly seems that this error happens because the XML parser that is loading the FML file is just not happy because dom4j is trying to use a newer function that it doesn't have.

           

          Have you tried the exact same thing on Tomcat?

          • 2. Re: Fiber Modeler - JavaMail Error
            dblomquist Level 1

            The above output is all I have to work off of.  We currently are using Jrun 4 exclusively.  We are running JRun 4 in a multi-server configuration, with LiveCycle and ColdFusion 9 on their own instances.  I'm using dom4j-1.6.1.jar that comes preinstalled with LCDS.  I don't really know what I'm looking for when I dive into that jar's files using 7Zip.  Do you have any further suggestions?