2 Replies Latest reply on Jul 11, 2007 10:40 AM by Grizzly9279

    CFHTTP SSL Connection Failure

      About a month ago, I updated the SSL key for one of our websites called webA. One of our other websites, webB, on the same server is making a CFHTTP call to webA using SSL. This has worked fine for the past 2-3 years. It seems that after I renewed and installed the SSL key for webA, webB gets the following error when using CFHTTP:

      Connection Failure: Status code unavailable <br>The error occurred on line 1.

      I was reading this article that says CF doesn't support newer SSL keys using SSL v3.
      http://www.talkingtree.com/blog/index.cfm/2006/11/14/ColdFusion-Protocol-Tags-CFHTTP-CFINV OKE-CFLDAP-support-SSLv2#more

      So, I tried using another JAVA library to simulate CFHTTP, but ran into the same problem

      So I started searching the SUN website and got a hint that perhaps the JVM was the problem. So I upgraded my JVM from j2sdk1.4.2_11 to j2sdk1.4.2_15

      I tried again and my CFHTTP tag was working again and so was the java HTTPClient library I tried.

      Has anyone else had this problem?
      Has anyone tried and had any problems with using CF with j2sdk1.4.2_15 ? I don't think CF officially supports it.

      I've only done this on our development server and need to perform more testing with this new JVM before putting into production.

      Thank you for any feedback.,
      Carlos Vazquez
      Senior Web Developer / MySQL DBA