9 Replies Latest reply on May 12, 2012 5:16 PM by ozzie cadenza

    Why am I getting "CA Headless has encountered an error" suddenly?

    Togo1518

      In the past few days, when I am in Elements Organizer 9 I get this message.  I'm not sure what damage is being done, Organizer, Photoshop Elements and Premiere Elements still seem to work OK.  However, when I tried to back up my Organizer catalog today, I got an error message part-way through and the backup terminated, and about the same time (I was multi-tasking and didn't see when this happened) I got another CA Headless error message.

       

      What exactly does this mean, and what can I do about it?  And why is my backup not working?

       

      And why can't Adobe engineers write error messages in plain English that mere mortals can understand without having to scratch their heads (no pun intended) and slog through forums and help menus to find out what the bloody error message means?  This error message is utterly useless to me, and I'm not stupid (I earned a PhD 40 years ago, though not in software engineering ...)  This is NOT helpful.

        • 2. Re: Why am I getting "CA Headless has encountered an error" suddenly?
          the_wine_snob Level 9

          I think that the thread that Steve linked to will probably solve the issue. For a bit of background on the "headless" part of the error message, it normally appears around Halloween... No wait, just kidding there.

           

          The headless is a sub-set of instructions for various Adobe programs. It is invoked when only a part of a certain program is needed, so that the entire program is not launched and loaded. A good example of this is the use of ADL (Adobe Dynamic Link) between the authoring program, Encore and the video editor Premiere Pro. When one has linked a Sequence (think mini-Project in PrPro) to a Project in Encore, it is not necessary to have PrPro open, but Encore needs some of it opened (is hidden in the background, and one does not see this), and then the "headless" sub-set is invoked. When there is a problem, the workaround is usually to just Delete any ADL links back to PrPro, and redo them - usually works perfectly.

           

          I can only interpolate and guess with regards to Organizer. As it relates to PSE and/or PrE, I assume that it will need the headless sub-set of one, or both, to fully function, depending on how an catalog has been used in the past. In the case of the error, something is getting in the way of the headless sub-set of code running properly. The new catalog creation, gets one into Organizer, and nothing has yet been linked to either PrE, or PSE. I hope that this simple method clears up the issue with the linking, and that the headless sub-set can then function, as it is designed to. Not sure what goes off with the linking, but getting to a point, where one can redo the links is most often the answer, and the error goes away.

           

          Good luck,

           

          Hunt

          • 3. Re: Why am I getting "CA Headless has encountered an error" suddenly?
            Togo1518 Level 1

            Unfortunately this doesn't seem to help.  I went into Organizer, created a new catalog called "temp 1", then changed the catalog back to mycatalog1 which is the one I use.  For a while everything seemed to be working normally, but then when I tried to do a backup of mycatalog1 the CA Headless error message re-appeared and the backup attempt failed.

             

            Either I'm missing a step here, or this isn't the fix I need.

             

            I still can't create a backup of the catalog.

            • 4. Re: Why am I getting "CA Headless has encountered an error" suddenly?
              the_wine_snob Level 9

              Just as a test, I would open both PrE and PSE, and just minimize them. Then go to Organizer, and attempt the backup again.

               

              Fingers are X'ed in AZ for your success.

               

              Good luck,

               

              Hunt

              1 person found this helpful
              • 5. Re: Why am I getting "CA Headless has encountered an error" suddenly?
                Togo1518 Level 1

                Thanks for that, Bill.  Not at all sure why this should have worked, but it seems to have.  I went to Organizer, opened a video file in PrE, minimized PrE, then back to organizer, opened a JPG in PSE, minimized PSE, back to Organizer, and then ran a backup of my catalog.  It ran and completed normally, no CA Headless error messages in sight.

                 

                I'm not going to mark this as "answered" just yet, I want to give it a couple of days of working with the program to make sure the "fix" "took," but for now things look encouraging.

                 

                So I guess the (or a) solution is to create a new catalog, then go back to the old catalog, open the editor(s), minimize both, then back to Organizer and then try the backup ... in case anyone else runs into this problem, that's a sequence that seems to have worked for me.

                • 6. Re: Why am I getting "CA Headless has encountered an error" suddenly?
                  the_wine_snob Level 9

                  Because the "headless" version is but a sub-set of the code in PrE and PSE, I was looking for a way to bypass the need for the program to access the headless version of the code. The test only allowed Organizer to access the full programs, and not their headless versions.

                   

                  Though this is not the way things should work, it does give you a workaround, and after the "reset," might get the headless versions working too - at least in my dreams.

                   

                  It could be as simple as a reset, or it could be that either the calls for the headless versions are messed up, or the installation of the headless versions are corrupt, or something totally different.

                   

                  At least we got you a workaround, and it seems that PrE, PSE and Organizer are OK, just maybe something with headless.

                   

                  Good luck, and keep us posted,

                   

                  Hunt

                  • 7. Re: Why am I getting "CA Headless has encountered an error" suddenly?
                    Togo1518 Level 1

                    Unfortunately the CA Headless message re-appeared today.

                     

                    I launched Elements Organizer 9 and left it open, planning to return to it after doing some other things on my computer.  Neither of the editors were open.  After a couple of minutes, I noticed the error message.

                     

                    I hadn't actually done anything yet in Organizer, other than navigate to a specific album.  However, I should perhaps mention that under Edit>Preferences I had set Organizer to auto-analyze media when the system is idle.  The album to which I had navigated contained some new video files that I had added yesterday, and there is no evidence of any analysis having been done to them yet (no purple tag on the corner of any of the thumbnails).  So I suppose it is possible that the auto-analyzer had started to run once the system was idle and generated the error message.  I can't think of anything else that Elements 9 could have been doing that could have triggered an error message, once I'd opened the software and navigated to the album I wanted.  The error message appeared "behind" the Organizer screen, I didn't notice it until I Alt-Tabbed to the desktop.

                     

                    I haven't actually started any editing of video files yet, will do so probably later today, will report any problems encountered.

                     

                    So far the CA Headless message is no more than annoyance.  Haven't tried backing up the catalog again, but no need for that as nothing in it has changed since yesterday.

                     

                    LATER IN THE DAY -- I've spent most of the afternoon editing and combining about 15 video clips in Premiere Elements, with Organizer open in the background.  The software seems to behave normally, and I haven't had a repetition of the CA Headless error since opening PrE and beginning work on the video files.  Whatever this problem is, except for the catalog-backup issue resolved earlier in this thread, it doesn't seem to be affecting the software in ways that matter to me.  If problems return later, I'll re-open this thread, but for now I think it's answered as much as it needs to be from my perspective.

                     

                    Message was edited by: Togo1518 at 1732 EST 20110116

                    • 8. Re: Why am I getting "CA Headless has encountered an error" suddenly?
                      DIS1234

                      I suddently began seeing this same error message "CA Headless has encountered an error" after using the auto-analyzer in PS Elements 9.  I do not have the Premier version.  I have tried the couple of suggestions in this thread with no results.

                      Please help.

                      • 9. Re: Why am I getting "CA Headless has encountered an error" suddenly?
                        ozzie cadenza

                        I used a utility available from Microsoft called "autoruns" to disable CAheadless at startup.  Unchecking CAheadless from the list keeps it from starting at boot, and the error message goes away.

                         

                        I have no idea what trouble this might cause but it does get rid of the error message.  So far no unpleasant side effects with either  Premiere elements 10 or photoshop elements 9.