12 Replies Latest reply on Jun 21, 2016 9:37 AM by ndunn219

    tabs and autoindenting

    lwfg Level 1

      How do you turn autoindenting off ?

      I tried windows -> coldfusion -> editor profiles -> editor and could not find how to do that.

        • 1. Re: tabs and autoindenting
          Charlie Arehart Adobe Community Professional & MVP

          I've looked and looked and don't see any option, either in the CF, HTML, or General preferences related to editing.


          You may want to clarify just what you mean, such as if you have an indented line, and you enter a new line, you don't want it to stay indented at that level?


          If that's it, here's another thought: sometimes it helps to stop and ask--if they have not provided a way to do it, maybe there's reason to question going against the flow. Don't get me wrong, I know that sometimes one "just has their preferences", but let's ask: is that what you mean above, and if so, why do you not want it to doing that?



          • 2. Re: tabs and autoindenting
            Bert.Dilliën Level 1

            When in Preferences, search for 'Formatting'. You will see all different categories in which you can set/modify/disable the formatting rules. (e.g. CSS, HTML, Javascript,...)


            Cheers Bert.

            • 3. Re: tabs and autoindenting
              Charlie Arehart Adobe Community Professional & MVP

              But Bert, none of those seem to have to do with auto-indenting. That's why I didn't propose them. Do you see something different?



              • 4. Re: tabs and autoindenting
                Bert.Dilliën Level 1

                If you would disable the formatting in Javascript for instance, you will notice that CFBuilder does not auto-format the text with tabs and spaces anymore when you would write an if statement around existing code.


                Could you give an example of what you exactly mean with auto-indenting?

                • 5. Re: tabs and autoindenting
                  Charlie Arehart Adobe Community Professional & MVP

                  Bert, while we await a reply from the original poster (OP), I have been assuming that they mean how, if you're on a line that is already indented, and you hit enter to go to a new line, CFB (like most editors) puts the new line auto-indented to the same level (and I assume can be configured even to indent another level under some tags).


                  My sense is that the OP wants to control when it does and doesn't do that indenting, at all. While I do believe there is control over what tags it does or doesn't do additional indents for, I could not find (for them, under my assumption) any means to tell it, "don't auto-indent, even to the same level as a current tag" for all tags by default. (I also didn't find any way to control it for specific tags, but again, I think that may exist.)


                  (FWIW, I did find this page in preferences>HTML>Editors>HTML>Typing and the setting "Auto-indent Child Tag on carriage return", but I turned that off, and even closed and reopened CFB, but it made no affect on the auto-indent I see. I even tried it in a straight HTML page, but still no change.)



                  • 6. Re: tabs and autoindenting
                    Bert.Dilliën Level 1

                    Indeed, I did not find any options to control indenting for CF either.  All other languages (presumable made by Aptana) have much more control  options. (like I really mis the code folding on tags I choose -> see  CFEclipse)

                    Maybe Adobe must peek inside Aptana a little more?
                    • 7. Re: tabs and autoindenting
                      lwfg Level 1

                      If there is something like

                      <cfif a eq 1>

                         <cfif b eq 1>

                         </cfif>         Prefer this line not to automatically tab over to sit under the <cfif b eq 1>, automatically going under it is ok, just by spaces, not tabs.




                      • 8. Re: tabs and autoindenting
                        Bert.Dilliën Level 1

                        You could change the CFBuilder preferences to insert spaces instead of tab, but I do not think that would be a best practice.


                        Anyway you will find it under Preferences -> General -> Editors -> Text Editors : check option 'insert spaces for tabs'


                        Cheers Bert.

                        • 9. Re: tabs and autoindenting
                          Charlie Arehart Adobe Community Professional & MVP

                          I thought CFB did include coldfolding. I don't use the feature myself, but I've seen mention of it, and I thought in the CFB docs. Are you saying it doesn't work at all, or not as well as you know it to work with pure Aptana in some way?


                          Keep in mind also that there is another version of CFB in the works (referred to in past conferences and such as "Storm"), so we can certainly hope that any missing features will be addresed then, and that any with a sincere interest in such things can get on the beta when announced, to help influence such directions/interests.



                          • 10. Re: tabs and autoindenting
                            Charlie Arehart Adobe Community Professional & MVP

                            Oh my goodness, if that's what you meant from the beginning, I do wish you'd said so. You just asked how to turn it off, not how to change it from tabs to spaces. We could have pointed that tabs as spaces feature last week.


                            Then again, though Bert noted the feature in his subsequent reply, I'm not sure that's really going to solve your concern. I'll reply to that separately.



                            1 person found this helpful
                            • 11. Re: tabs and autoindenting
                              Charlie Arehart Adobe Community Professional & MVP

                              You're about that feature existing, Bert, and I would have pointed it out to the OP as well last week, if that's all he'd asked.


                              But I have a feeling it's still not really going to satisfy him/her.


                              I just checked and while that setting does indeed control whether a tab that you enter manually uses spaces or not, it does NOT change the editor putting in a real tab on a new line when it auto-indents. That will likely frustrate the OP's real goal.


                              Not sure if there's an answer, currently. Something to raise to the team for consideration as a bug, though (which you can do at http://cfbugs.adobe.com/bugreport/flexbugui/cfbugtracker/main.html, which for future reference to readers is offered as a link on the right of the web interface for this forum, at http://forums.adobe.com/community/coldfusion/coldfusionbuilder).



                              • 12. Re: tabs and autoindenting

                                I know this is old, but JFYI, I've submitted a bug that I believe relates to this same issue.