7 Replies Latest reply on Jun 2, 2012 3:09 PM by A Unique Username

    ASDOCS Error Interface IFlexModuleFactory was not found

    MotionMaker Level 1

      I got an error with ASDOCS that I do not understand. I am using Flash Builder 4 on MAC and it is an Actionscript project.

       

      Loading configuration file /Applications/Adobe Flash Builder 4/sdks/4.0.0/frameworks/flex-config.xml
      _8a96cd3a25128dbd315708caff56516b3c3e83309abd23b6fb42e1b21d033d59_mx_core_FlexModuleFactor y.as(26): col: 16 Error: Interface IFlexModuleFactory was not found.

       

          implements IFlexModuleFactory, ISWFContext
                     ^

       

      _8a96cd3a25128dbd315708caff56516b3c3e83309abd23b6fb42e1b21d033d59_mx_core_FlexModuleFactor y.as(26): col: 36 Error: Interface ISWFContext was not found.

       

          implements IFlexModuleFactory, ISWFContext
                                         ^

       

      I had cleaned up all the errors that related to content in the project folder, but was left with the one above that seems unrelated to content.

       

      If it helps the ASDoc configuration file is this:

       

      -source-path src
      -doc-sources src
      -library-path "assets/flash/swcs" "libs" "src/foomonger"
      -lenient=true
      -warnings=false 
      -strict=false
      -main-title "Sprycel Unbranded"


      -exclude-sources "/Users/ahosford/Documents/Adobe Flash Builder 4/SprycelCML/sprycel-cml-tracker/trunk/client/SprycelCML/src/com/sprycel/model/Calendar.a s" "/Users/ahosford/Documents/Adobe Flash Builder 4/SprycelCML/sprycel-cml-tracker/trunk/client/SprycelCML/src/com/sprycel/ui/IDateItem.as" "/Users/ahosford/Documents/Adobe Flash Builder 4/SprycelCML/sprycel-cml-tracker/trunk/client/SprycelCML/src/foomonger/utils/LoadWatcher. as"


      -define+=CONFIG::local,true

        • 1. Re: ASDOCS Error Interface IFlexModuleFactory was not found
          badaboom_55 Level 1

          I was getting this error as well... did you find out was happening?

           

          I have a project that uses the FLVPlayback component and needs several embedded custom fonts.

          I've stored those assets in a Library.fla and export a Library.swc

           

          When using the ASDoc command line I set the library-path option as:

          -library-path /Path/To/SWC/Library.swc

           

          This works fine if I have ONLY the FLVPlayback component in Library.fla; however as soon as I add an embedded Font in the Library.fla library, I get a similar error to what you were receiving.

           

          If I change the library-path to:

          -library-path+=/Path/To/SWC/Library.swc

           

          The error no longer appears, but now in my documentation there is a crazy-weird _8a96cd3a25128dbd315708caff56516b3c3e83309abd23b6fb42e1b21d033d59_mx_c ore_FlexModuleFactory class in the classes list.

           

          Also, I recently converted Library.fla from CS4 to CS5 file format, not sure if it matters, but I didn't seem to have this problem with the CS4 version.

          • 2. Re: ASDOCS Error Interface IFlexModuleFactory was not found
            MotionMaker Level 1

            No I was not able to solve the issue. Have seen other references to it on the net where there is no solution.

             

            I suspect it has to do with some sequencing and the number of libraries that creates the issue and the hit at needing ANT to handles such issues.

             

            However I intend to try your fix and see if I get some progress - an extra class seems to be something I could live with versus the unproductivity of not having a fully searchable code doc.

            • 3. Re: ASDOCS Error Interface IFlexModuleFactory was not found
              badaboom_55 Level 1

              I can't believe how absolutely dreadful the Adobe's ASDoc help documentation is.

              Anyway, I seem to have found a "possible solution" or maybe just a bug that happens to work... who the hell knows.

               

              So, I found a reference to the "-external-library-path" argument in some random post on the internets... of course, it's completely undocumented by Adobe. Using that instead of the documented "-library-path" argument seems to work... the class documentation seems to be output without any errors.

               

              So, for prosterity's sake, and anyone who is just trying to get ASDoc to work in a minimal configuration...

              Working with Flash CS5 Professional (ActionScript 3.0), an install of Flash Builder 4.0 (Standard Edition), the Flex SDK 4.1 and using an external library (.swc) that contains embedded fonts and an FLVPlayback Component.

              A command line execution of ASDoc would need these basic arguments (most at least have SOME sort of reference in Adobe's online "help"):

               

              -source-path /Path/To/Your/Custom/Class(es)

              -doc-sources /Path/To/Your/Custom/Class(es)

              -external-library-path /Path/To/Your/External/Library/SWC/library.swc

              -output /Path/To/Output/The/Documentation/HTML/Files

               

              I would say that there's a 50/50 chance of this working for anybody else but me... Adobe is awesome.

              • 4. Re: ASDOCS Error Interface IFlexModuleFactory was not found
                MotionMaker Level 1

                Thanks for this feedback.

                 

                Still no luck. This was a badly assembled AS project I inherited so I was up against the wall from the start.

                 

                I started a new Flex 4 project in Flash Builder 4 and it is relatively clean - just MXML and AS files. There are two swcs. One with embedded fonts and the other with a preloader animation. It uses Parsley and I see the Parsley config file gets rejecteds. So I excluded that.

                 

                The error I get is:

                 

                Error: unable to open 'Flash'

                 

                Use 'asdoc -help' for information about using the command line.

                 

                -source-path src
                -doc-sources src
                -external-library-path libs/CMLBrandedPreloader.swc libs/CMLBrandedPreloader.swc
                -exclude-sources  /Users/ahosford/Documents/Adobe Flash Builder 4/SprycelCML/sprycel-cml-tracker-unbranded-reskin/sprycel-unbranded/trunk/client/SprycelC MLTrackerBranded/src/ParsleyConfiguration.mxml

                 

                Pretty frustrating you cannot say limit the ASDOCs just to the MXML and AS so you have something more than nothing.

                • 5. Re: ASDOCS Error Interface IFlexModuleFactory was not found
                  jcarpe87

                  I know this thread is from quite some time ago, but I am getting the same error ( Error: unable to open 'Flash' ) when I try to use the command line to use asdoc to generate my documentation. It is extremely frustrating finding anyone else who even has this same error, much less a solution to this problem.

                   

                  Grant Skinner has a tool that worked for me called ASDocr, but also I have used VisDoc in the past to generate documentation that worked well.

                  • 6. Re: ASDOCS Error Interface IFlexModuleFactory was not found
                    MotionMaker Level 1

                    I will have to check out ASDocr VisDoc.

                     

                    However I gave up on ASDoc in Flash Builder a long time ago. I think from my reading, the solutions may require doing ASDocs with other tools like ANT to help resolve dependencies of a complex integration of libraries. It was enough for me to abandon it as time is important and having a digital reference for the effort did not justify all the work and special skills to overcome it.

                     

                    They should remove the choice really or still build the docs with a error output file so you can evaluate if the errors are a problem but still retain a doc for the source in the project.

                     

                    Have not tried it with FB 4.6.

                    • 7. Re: ASDOCS Error Interface IFlexModuleFactory was not found
                      A Unique Username

                      Just to inform others that spend entire days on solving this issue and getting frustrated by Adobe's lack of interest in improving this (when it works) excellent tool.

                       

                      The first solution provided by badaboom_55 suggesting to add a '+' (plus) to the -library-path did it for me.

                      I have several selfmade SWC-files in my assetsfolder and I kept getting the crazy long reference error based on the FlexModuleFactory. Also I have two embedded fonts in one of my SWC-files. I do not exactly what caused the problem but I do know that I've spent a lot of time on this issue and just addig the + in the -library-path line did it for me. Now I'm generating documentation like never before. Big thanks goes badaboom_55!

                       

                      My script now looks like this:

                      -source-path "./src"

                      -doc-classes "Main"

                      -output "Documentation"

                      -library-path+="./src/assets"

                      -main-title "Documentation"

                      -window-title "Documentation - Documentation"

                      -strict=false

                      -lenient

                      -exclude-dependencies=true