10 Replies Latest reply on May 14, 2011 2:01 AM by ErwinDC

    Extension Manager (CS4 & CS5) shows wrong language

    melt4u2 Level 1

      What more can I say? I discovered this problem running the CS4 Master Suite but fumbled through the dialog box and got the install of PixelBender to work. Now that I'm back with CS5 I'm still having the same problem. No language problems anywhere else but in Extension Manager. I'm using a Mac Pro, Snow Leopard, and the CS5 Design Premium Suite. The incorrect language appears to be German, though I don't speak or write German, so I'm not certain. Screen shot below. Thanks!

       

      Extension-mgr-screen.png

        • 1. Re: Extension Manager (CS4 & CS5) shows wrong language
          Carl Sun Level 4

          The language in your screen shot is Danish, not German. Could you tell me the OS language you used and language of CS5 Design Premium Suite?

          • 2. Re: Extension Manager (CS4 & CS5) shows wrong language
            melt4u2 Level 1

            Hello. Thanks for your question. I speak and read only two languages: English, and bad English. My installs have always been in English. My OS language and everything else is all English. Extension Manager is the only app I have that shows up in a language other than English. My system is a Mac Pro, running OSX (10.6.5). 8gb RAM and four internal drives. Hope this helps.

            • 3. Re: Extension Manager (CS4 & CS5) shows wrong language
              Carl Sun Level 4

              Have you made any change to language order in "Language & Text" preferences? If English is still the first language in the language list,  it is really strange. Extension Manager uses OS language if that language is supported when launched standalone. Please double check you have correct code page.

               

              The following solution is not ideal solution, but it should works.
              1. Go to the installation folder of Extension Manager, right click "Adobe Extension Manager CS5.app", select "Show Package Contents".
              2. Select "Contents"->"MacOS"->"ZStringResources".
              3. Move da_DK.xml out of "Adobe Extension Manager CS5.app" as a backup, rename en_US.xml to da_DK.xml.
              4. Select "Contents"->"Resources".
              5. Move folder da.lproj out of "Adobe Extension Manager CS5.app" as a backup, rename en.lproj to da.lproj.
              6. You may have to unlock file to get write privilege when you renames file.

              • 4. Re: Extension Manager (CS4 & CS5) shows wrong language
                melt4u2 Level 1

                Your solution worked! I did a small modification to your steps. BTW I first I double-checked my "Languages & Text" prefs and it is correctly set to English. Now to my slight modification to your instructions. I duplicated the English files in both steps 3 and 5. I then copied the exact names of the Danish files, then deleted the original Danish files. I then renamed those duplicate English files with the Danish names. This way I keep the original English files too. Last, I launched Extension Manager and tested a plug-in install, and all is in English as should be.

                 

                Thanks very much for your help on this!

                 

                language_prefs.png

                • 5. Re: Extension Manager (CS4 & CS5) shows wrong language
                  adaceyphoto Level 1

                  I just hit the same issue and managed to fix it without having to modify the package contents.

                   

                  Thanks to melt4u2 for getting me 90% of the way there. I checked my "Languages & Text" preferences as indicated in that post. My screen showed a similar list with English as the first item but several other languages listed as well (I think the same list as in the screenshot, I've never edited this so I suspect it's the system default list).

                   

                  What I did was simply click on the "Edit List" button below that list, this allows you to select which languages will be available in the list. Since I'm only using English on my computer I have no need for the other languages so I unchecked them all. This left only English in the list and on re-opening Extension Manager I got English text.

                   

                  To me, this sounds like there's a bug in Extension Manager where it's not honouring the language order that the user has set and is simply looking at the available languages and selecting the first one that it has (which alphabetically is Dansk, or Danish instead of English).

                  • 6. Re: Extension Manager (CS4 & CS5) shows wrong language
                    Guo Liu Level 1

                    Thanks adaceyphoto to report this issue and provide another workaround. So far we haven't reproduce this problem in our environment, in order to help us catch it and do further analysis, could you please help to reproduce it in your Mac again and send us the log messages?

                     

                    First, you need to restore the deleted languages again, and don't forget Danish.

                     

                    Here are the steps to generate log messages:
                    1. Go to the installation folder of your Extension Manager, right click "Adobe Extension Manager.app", and select "Show Package Contents".
                    2. In the new Finder windows, select "Contents" --> "MacOS". In the MacOS folder, create a file named "ExManLog.YES", please make sure the created file has extensions ".YES". (You can right click on that file and select GetInfo to check the Name&Extension).
                    3. Launch Extension Manager, try to reproduce the language problems.
                    4. Close Extension Manager, open folder "/Users/$YOURNAME/Library/Application Support/Adobe/Extension Manager CS5/", there should be some files with ".log" format. These are the log files generated by Extension Manager.
                    5. Delete the ExManLog.YES file which is created in step 2, otherwise it will slow down your Extension Manager to generate log files.

                     

                    It seems not able to attach files here, so please send the packaged log files to my email address. You can find my email address from your private message box.

                    Thanks.

                    • 7. Re: Extension Manager (CS4 & CS5) shows wrong language
                      adaceyphoto Level 1

                      Hi Guo,

                       

                      Unfortunately I've tried to reproduce it and can't seem to now. I did notice that there was an update to extension manager so I'm not sure if that's fixed it. I even tried changing my language list to include Dansk as the first item, which does result in Danish text as expected, but then when I moved English back to the top of the list it stayed on English.

                       

                      Still, glad that I was able to offer another possible solution to the problem.

                      • 8. Re: Extension Manager (CS4 & CS5) shows wrong language
                        Guo Liu Level 1

                        I'm not sure if it's the update fixed this issue. Since it's no longer a problem to you, you don't have to delete all the other languages of your system.

                        Anyway, thank you to try to reproduce this problem for us. And please delete the ExManLog.YES file if you had created it.

                        • 9. Re: Extension Manager (CS4 & CS5) shows wrong language
                          adaceyphoto Level 1

                          Yes, unfortunately I had the problem removed the languages from my preferences (note, this just removes them from the list of available languages, nothing's deleted) and saw that fixed the problem. I then installed the update before I received your message asking to try to reproduce the problem so I didn't get a chance to try doing that on the same version so it's hard to say if simply making that change forced something to register properly or if the update has resolved the issue.

                           

                          Meanwhile, everything seems to be working great so no complaints on this side and I haven't made any permanent changes to my OS so that's good.

                          • 10. Re: Extension Manager (CS4 & CS5) shows wrong language
                            ErwinDC Level 1

                            Keep it simple:

                            On Windows the only thing to do is: make an alias of your Extension Manager, right click on it and choose Properties.

                            In the popup window go to the second tab proposing the path and the target folder of your alias.

                            You will see a string like:

                            "C:\Program Files\Adobe\Adobe Extension Manager CS5\Adobe Extension Manager CS5.exe"

                             

                            Add  -locale lang="en_US" or what ever language you prefer in the end of this string like this

                            "C:\Program Files\Adobe\Adobe Extension Manager CS5\Adobe Extension Manager CS5.exe" -locale lang="en_US"

                             

                            Watch out, add the extra string at the end NOT within the quotes.

                            Start your Extension manager by double clicking the alias, and off you go!

                             

                            Succces,
                            ERwin