25 Replies Latest reply: Nov 2, 2011 8:21 AM by Janatwork RSS

    LMS compatibility issues with Captivate 5

    Saurabh_Flex Community Member



      As we know, Captivate is based on Flash, and Flash includes what is called ActionScript (AS) programming language which helps developers create course interactivity easily. Adobe recently updated Captivate 5 to include a new version of AS (AS3)- which supposedly makes programming even simpler. But, Adobe also removed the option for developers to select AS2 or AS3 when creating a course and now developers MUST go with AS3 alone.


      Our development group has started using Captivate 5 and the courses don’t work in the Cornerstone LMS- they never load- see screenshots below.


      We have already escalate to Cornerstone OnDemand and they have their engineering group looking at the issue. But we are not able to post our courses until a workaround to this problem becomes available. Captivate is very popular development software and I'm sure other customers too might have similar compatibility issues.


      Request help!

      Thanks in advance...





        • 1. Re: LMS compatibility issues with Captivate 5
          RodWard MVP

          A couple of questions:

          • The first screenshot you have is when the Captivate SCORM module tries to set up a connection to the LMS via the JavaScript API.
          • The greyish screen with the word "Loading" on it usually indicates that the Captivate SCORM module has successfully opened a dialog with the LMS and is now trying to download the Captivate SWF.


          So, at which point do your courses stall? At the first screenshot or the second?

          • 2. Re: LMS compatibility issues with Captivate 5
            Suresh Jayaraman Community Member

            Rod ,


            Hope you read the AS2 VS AS3 conflict which the user has mentioned ..

            • 3. Re: LMS compatibility issues with Captivate 5
              RodWard MVP

              Yeah I noticed that, but I'm not convinced as yet that the fact Captivate is using AS3 is the real reason for the movies not loading.


              Has it been established somewhere that Cornerstone OnDemand's LMS won't load any SWF with AS3?  I may have missed that post.


              I might be wrong but....If the LMS supports SWFs at all (and Cornerstone OnDemand does) then it shouldn't theoretically care what version of ActionScript it contains.  It's normally the version of Flash Player plugin in the browser (i.e. versions prior to FP9) that determines compatibility with AS3.


              The screenshots in Saurabh_Flex's post make me think the Cp SCORM is unable to establish a link via the SCORM API, or else something is causing the SWF to load so slowly that it looks like it'll never get there.


              If it DOES turn out to be AS3 that's the problem with Cornerstone, then poor Saurabh is in for a big disappointment with Cp5.  If it turns out to be something else entirely then maybe things can be salvaged.

              • 4. Re: LMS compatibility issues with Captivate 5
                Maria Guarriello

                Hello, this is my first post in the forums.  I am also having problems publishing Captivate 5 (in our Plateau LMS), in both SCORM and AICC.  With SCORM, I get the gray loading screen as shown in the post above.  With AICC, I can't even import the published files to the LMS.  Tech Support at Plateau says, "...the "title" information is missing from the .des file".  I've never had a problem publishing with versions 3 or 4, and I've downloaded all the patches put out for 5.

                • 5. Re: LMS compatibility issues with Captivate 5
                  FrogSlug Community Member

                  I am having the same problem publishing using Captivate 5. We are using the Plateau LMS, like Maria. We are publishing to AICC, but I had the same issue when I tried SCORM.


                  Like the original poster described, when published to AS3, the course will not get past the loading page when viewed from within the LMS. I was able to replicate the problem using Captivate 4, by publishing to AS3, rather than AS2 (the default). The exact same course recorded results correctly in the LMS when published to AS2, but would not get past the loading page when published to AS3.


                  Unfortunately, Captivate 5 will not allow one to publish to AS3.


                  I'm pursuing the issue with IT, but am not that hopeful.


                  Any suggestions are welcome. Who else is having this problem?

                  • 6. Re: LMS compatibility issues with Captivate 5
                    RodWard MVP

                    Interesting.  And you can confirm that your Flash Player version is definitely higher than version 9?

                    • 7. Re: LMS compatibility issues with Captivate 5
                      FrogSlug Community Member

                      Yep. I have version 10.

                      • 8. Re: LMS compatibility issues with Captivate 5
                        RodWard MVP

                        Were these courses created first in Captivate 4 and then migrated to Captivate 5 or created from scratch in Captivate 5?


                        Just to be sure the issue is with Cp5, try creating a brand new blank project in Captivate 5, adding a single scorable question (e.g. a True/False) to it and then publishing as a SCORM to upload into the LMS. Make this lesson as simple as possible. Not even a preloader.  Does it work at all in your LMS?

                        • 9. Re: LMS compatibility issues with Captivate 5
                          Saurabh_Flex Community Member



                          Thanks for your suggestion. The SCORM test was successful, but we need to figure out a solution for AICC compliance usage since this is what we use with Cornerstone Ondemand LMS. It doesn't seem to be cost-effective to use SCORM with their LMS.


                          Regarding the original example that I mentioned in the beginning of this thread, we checked with Cornerstone, and they reverted saying that the LMS refers to a file named MMTracking.swf while trying to launch the course. Please refer to the below image, showing the launch sequence along with the files referenced on the server:




                          We did not get this file in our test output from CP5. Please see another image below, showing a list of all files that CP5 generated on publishing:


                          Are we missing any step, or doing something wrong while publishing?






                          • 10. Re: LMS compatibility issues with Captivate 5
                            RodWard MVP

                            You should be able to change your LMS quiz settings inside Captivate to be compatible with AICC systems instead of SCORM.  Just select AICC on the Preferences dialog under Quiz Reporting.



                            You don't actually need the mmtracking.swf file for your course to work in an LMS.  Cornerstone is picking up the request and thinking this is a showstopper but it's not.  mmtracking.swf is just a debugging file that is sometimes used by Adobe engineers to test for compliance with LMSs.  It doesn't normally get published to the output.  So you can forget about it.


                            There's an article here by Andrew Chemey, Adobe's foremost LMS expert (and I think he may have been the guy that created mmtracking.swf):


                            Notice one of the final comments at the bottom of the article relates to someone else getting an error message back from the LMS similar to the one you're getting.  Andrew comments that you don't need this file for your content to work.


                            Someone actually asked this very same question on the Adobe Captivate forum back in 2008:


                            Note that Andrew chimed in to clarify the issue here too.

                            • 11. Re: LMS compatibility issues with Captivate 5
                              Maria Guarriello Community Member

                              Just thought I'd let you know that my SCORM test was not successful, I still get the gray loading screen.  Our LMS team is working with Plateau, so hopefully I'll get it resolved.  I'll post back if I get information that others could use.


                              • 12. Re: LMS compatibility issues with Captivate 5
                                FrogSlug Community Member

                                The SCORM test was not successful for me either. I am also trying to work with our LMS team to resolve the issue. If I learn more, I'll post it.

                                • 13. Re: LMS compatibility issues with Captivate 5
                                  Saurabh_Flex Community Member



                                  We are already selecting the AICC option for quiz settings.


                                  We just took a look again and uploaded the same course once again, but this time on Cornerstone's server. We essentially just changed the URL to point to their server. In this case it launched and marked complete without issue. But the concern is that we need to publish courses on OUR server and call them from Cornerstone's LMS on THEIR server.


                                  Let me tell you that we have about 300+ courses, most of them created in different versions of Captivate, currently residing on our server and accessed from Cornerstone's LMS without any problem. On uploading the Captivate 5 course along with existing courses on our server, the communication between two servers (for Captivate 5 course alone) doesn't seem to happen properly.


                                  We are not sure where the issue lies but one possibility is that it is Flash related.


                                  Do you know of any difference with regard to server communication when creating courses through Captivate 5?




                                  • 14. Re: LMS compatibility issues with Captivate 5
                                    RodWard MVP

                                    No I'm not aware of any differences other than the fact that Captivate 5 only works in AS3.


                                    But I think this should be a question that the Adobe techs answer.

                                    • 15. Re: LMS compatibility issues with Captivate 5
                                      Saurabh_Flex Community Member

                                      Thanks for all your help Rod.

                                      Can you guide us on how to get further help with Adobe tech?


                                      Do they pitch-in through this forum automatically while monitoring the posts, or do we need to contact them specifically?


                                      Awaiting your reply!!!

                                      • 16. Re: LMS compatibility issues with Captivate 5
                                        Suresh Jayaraman Community Member

                                        Hi Saurabh


                                        Adobe engineering team looks into the forum and steps in when required. You can get our attention through Feature request / Bug report form as well




                                        For your current issue , I would appreciate if you send me quick summary with relevant details to sjayaram@adobe.com, either me or my team member would touch base with you at the earliest




                                        Suresh J


                                        Sr, Quality Engineering Manager - Captivate || ELS || Presenter

                                        • 17. Re: LMS compatibility issues with Captivate 5
                                          vishhere Community Member

                                          Hello Saurabh,


                                          Did you send the details asked by Suresh? If not, can you send it and copy me too so that I can also have a look? my id is viswanat@adobe.com




                                          • 18. Re: LMS compatibility issues with Captivate 5

                                            there's a new Hot Fix (see this blog post: http://blogs.adobe.com/captivate/2011/03/captivate-5-0-hotfix-for-the-issue-with-launching -aicc-enabled-projects-from-lms.html) that solves the hang at the "Loading..." page.


                                            But I still can't get it to mark completion in the LMS (Plateau) when finished.  All settings are the same as when published in CP4, which makes me think maybe AS3 is the culprit...


                                            if anyone has any ideas about that, I'd appreciate it.



                                            • 19. Re: LMS compatibility issues with Captivate 5
                                              megbertapelleid Community Member

                                              ok - one more HotFix & it all worked for me, hopefully you too:



                                              This is with reference to the issue you are facing with AICC courses on LMS.


                                              Please follow the steps mentioned below and let me know if this solves the issue for you.




                                              1.       Close Captivate if already launched.


                                              2.       Navigate to Captivate installed folder ( For Ex : C:\Program Files\Adobe\Adobe Captivate 5)


                                              3.       Navigate to folder “Templates


                                              4.       Open folder “Publish


                                              5.       Open folder “AICC


                                              6.       Rename the HTM file “default.htm” to “default_old.htm”.


                                              7.       Download the zip the file from https://acrobat.com/#d=rZv8-z9C0z4PPMpqjbkZIQ , Unzip the contents and copy the HTM file “default.htm”


                                              8.       Paste it inside “AICC” folder.


                                              9.       Launch Captivate and open the project.


                                              10.   Re-publish the project and upload the content to LMS.




                                              Let me know if this solves the issue.





                                              Ashwin Bharghav B

                                              Adobe Captivate Team



                                              good luck!

                                              • 20. Re: LMS compatibility issues with Captivate 5
                                                avary.s Community Member

                                                Screen shot 2011-06-03 at 2.14.28 PM.png

                                                Hi Ashwin,


                                                I am having Captivate/AICC issues similar to this blog post however the method you suggested did not resolve my issue. I am using Captivate 5, publishing to AICC and attempting to view my course on moodle. After I upload the course and try to view it, I keep getting the same error message:


                                                "Sorry, the requested file could not be found

                                                More information about this error

                                                Stack trace:
                                                • line 5772 of lib/weblib.php: call to debugging()
                                                • line 191 of file.php: call to print_error()
                                                • line 103 of file.php: call to not_found()"


                                                When I click on 'more info about this error' I see this:



                                                In the case of a change of server, check if you have copied the content of moodledata, especially uploaded files.

                                                Also make sure the file name contains no special characters like '#'

                                                You may also get this error if you have moved files after linking to them from the course page."



                                                This course when published as SCORM works without any error message, it is only when published as AICC that the course WILL NOT load in moodle. Another developer suggested that I modify the .des files within the published zip file; however, I am not sure how to do this within Captivate.



                                                Do you have any other suggestions?



                                                • 21. Re: LMS compatibility issues with Captivate 5

                                                  I also had this issue with Captivate 5 but thankfully I was given some files to use in replacement of the ones Cap5 creates and this worked for us. The only issue is we are migrating to Plateau and when we launch (only the Captivate 5 modules), they do not show completion once they are done. I have tried changing the settings several times but was unsuccessful in getting my modules to show complete. Any suggestions??


                                                  thank you,


                                                  • 22. Re: LMS compatibility issues with Captivate 5
                                                    megbertapelleid Community Member

                                                    Hi Andrea,

                                                    did you follow the directions for the HotFix (s) in the thread above?  We use Plateau with Captivate 5 currently, and that worked for us.  Here are the publish settings we use if that's helpful for you.


                                                    Cap_publish_LMS.png or try "Complete/Incomplete" insetaed of "Pass/Fail"



                                                    Good luck!


                                                    • 23. Re: LMS compatibility issues with Captivate 5
                                                      Andrea_1415 Community Member

                                                      Thank you for your help!! There are a couple of things I see you have checked that we normally don't. I am going to go back and try republishing a course with these settings to see how that works. I will let you know! I appreciate the response!!

                                                      • 24. Re: LMS compatibility issues with Captivate 5
                                                        Saurabh_Flex Community Member



                                                        I started this thread couple of months back, and our team has done extensive experiments in resolving CP5 concerns. Fortunately, Adobe has released an update patch of Captivate 5 in the form of an "update". This resolves all of the major concerns that are discussed in this post.


                                                        To update Captivate 5 to ver., launch Captivate 5, go to Help --> Updates. Make sure you are connected to the Internet.


                                                        Not sure about Captivate 5.5 since we didn't find the upgrade worth the money, hence didn't purchase upgrade licenses yet.


                                                        Any inputs will be greatly appreciated.




                                                        • 25. Re: LMS compatibility issues with Captivate 5
                                                          Janatwork Community Member

                                                          Saurabh and others, including the Adobe people who patched Captivate 5 --


                                                          Thank you for this most helpful information! We also were having problems getting scores for AICC courses (generated with Captivate 5) to be reported in the Cornerstone OnDemand LMS. Upgrading to Captivate 5.0.2 and re-generating the courses in the updated version of Captivate fixed the problem. THANK YOU!


                                                          Note: You may want to mark your original posting as "Answered" now.