1 Reply Latest reply on Jan 19, 2011 11:56 AM by jgf1

    Logging target issues

    Danilomr12

      Hi,
      I'm having the some problems with changing the Logging Target at the
      services-config.xml.
      I'm using Grails with flex (using the flex plugin 0.2 for grails) and I need to
      log write the logs to file, since grails uses Log4j I tried to use the default
      Logging target from BlazeDS, ServletLoggingTarget but the logs went to
      some place I don't know. With the ConsoleLoggintTarget it works well.
      So I tried to do it with the org.springframework.flex.core.CommonsLoggingTarget
      I get the following error, even if the logging target class is the CommonsLoggingTarget
      or any implementation that I made extending the AbstractLoggingTarget Class:
      **** MessageBrokerServlet failed to initialize due to runtime exception: flex.messaging.MessageException: Cannot create class of type 'org.springframework.flex.core.CommonsLoggingTarget'. Type 'org.springframework.flex.core.CommonsLoggingTarget' not found.
      at flex.messaging.util.ClassUtil.createClass(ClassUtil.java:65)
      Does anyone knows what could it be?