8 Replies Latest reply on Jun 10, 2011 7:58 AM by Alan.Diggler

    Enable Protected Mode at startup

    wayne_O

      I am deploying Adobe Reader X by Microsoft System Centre Configuration Manager.  I have created a package using the Customisation Wizard.  I have 3 Registry changes included.  1, Change unts from inches to centimeters. 2. Change spelling dictionary from US to UK.  and 3. uncheck the "Enable Protected Mode at startup" option.  Our workstations are Windows XP SP3.  The problem is that although the units and spelling options are passed through on installation the "Enable Protected Mode at startup" does not.  I can see it creates the registry key successfully in the S-1-5-18 registry location but when I launch Adobe Reader for the first time the Privileged key is created but fails to pass the REG_DWORD called bProtectedMode from the S-1-5-18 registry location to the HKCU registry hive.  Does anyone have any idea why this happens and how to fix it?  I need this option unchecked as PDF documents on some network drives fail to open citing "Access Denied" if it is checked.  Any help appreciated.  Wayne

        • 1. Re: Enable Protected Mode at startup
          vdobhal Adobe Employee

          Hi Wayne,

           

          HKEY_USERS \ S-1-5-18 is the loaded profile for SYSTEM account. You can instead create an entry in HKCU using the Customization Wizard and this works.

           

          I created the following key using CW:

          [HKEY_CURRENT_USER\Software\Adobe\Acrobat Reader\10.0\Privileged]
          "bProtectedMode"=dword:00000000

           

          When I deployed the modified Reader, the Protected Mode is disabled by default.

           

          Thanks,

          Vinod

          • 2. Re: Enable Protected Mode at startup
            vdobhal Adobe Employee

            Moreover the reason can be found at the following link:

             

            http://www.sepago.de/helge/2009/08/12/registry-fun-working-with-hive-files/

             

            "...although the local SYSTEM account does have a profile (located in %systemroot%\system32\config\systemprofile), its registry hive is not mounted. Instead, HKU\S-1-5-18 is a link to HKU\.Default"

            • 3. Re: Enable Protected Mode at startup
              wayne_O Level 1

              Thanks Vinod,  I already have the setting for the Destination Computer in the Customization Wizard as shown in the image.  I then deploy using System Centre Configuration Manager and the setting does not come over. The others do.  SCCM uses the SYSTEM account to deploy.

               

              CustWiz.JPG

              • 4. Re: Enable Protected Mode at startup
                jaitprof Level 1

                Hi Vinod,

                 

                Tried doing that through Customization Wizard... If we are installing it locally on machine through the Run in windows XP it did create the objects in the registry.. however we are deploying via Microsoft SMS 2003 and when i have deployed it using that the reg keys did not appear unless you open adobe reader and navigate through the Preferences menu then upon doing it the keys have been created.. any ideas??? We need the protected mode disabled upopn deployment as it affects workstations with HP Plotters... being unable to print when the Protected mode is enabled.

                 

                Thanks,

                • 5. Re: Enable Protected Mode at startup
                  vdobhal Adobe Employee

                  Hi Wayne,

                   

                  I tried the same thing.

                   

                  1. Created the following customization using Adobe Customization Wizard X:

                   

                  [HKEY_CURRENT_USER\Software\Adobe\Acrobat Reader\10.0\Privileged]
                  "bProtectedMode"=dword:00000000

                   

                  2. Deployed the modified build of Reader X using Software Distribution feature through SCCM.

                  snapshot1.png

                  It created the following migrate keys in the registry:

                  snapshot.PNG

                  When I run Reader, the protected mode is turned off by default.

                   

                  Is this what you are doing? or can you list the exact steps with snapshots.

                  • 6. Re: Enable Protected Mode at startup
                    ACM-HLM Level 1

                    Hi Wayne

                     

                    Did you have any luck with this? I am getting exactly the same problem. I have used Customization Wizard to create an MSI/transform with a bunch of settings such as automatically accepting the licence agreement, and also added in the registry setting as described above. When I deploy it using Windows Server 2003 Group Policy, pointing it at the transform mst file, all the settings take on the clients except the registry setting - protected mode is not disabled by default. This is a major problem for us as Reader X will not print to our HP DesignJet plotters with Protected Mode switched on (see this thread: http://forums.adobe.com/message/3689213#3689213)

                     

                    Thanks

                    • 7. Re: Enable Protected Mode at startup
                      wayne_O Level 1

                      I was contacted by an Adobe engineer who sent me a beta version to try but it only did half the job.  With Protected Mode enabled I could not open PDF documents on a DFS or a mount point.  The beta corrected the DFS but not the Mount point.  I told them this but never heard back.  As for the deployment I never got a fix for that.  I have been meaning to put an official support call in about it but haven't done so yet.

                      • 8. Re: Enable Protected Mode at startup
                        Alan.Diggler

                        I Use

                        HKLM\Software\Policies\Adobe\Acrobat Reader\10.0\FeatureLockDown\bProtectedMode with a value of 0

                        & this seems to work fine. Could you let me know what you use for your other two keys as I cant find them anywhere

                        1. Change unts from inches to centimeters. 2. Change spelling dictionary from US to UK