0 Replies Latest reply on Jan 20, 2011 6:51 AM by Xenus989898

    Error #16824 : Version mismatch while trying to auto update...

    Xenus989898 Level 1

      Hi all,

       

      OBJECTIVE :

      So here is my problem, I am trying to auto-update an old version software X v1.0.7 AIR Runtime SDK 2.0 to a new version X v1.0.8 AIR Runtime SDK 2.5.

       

      CONFIGURATION =

      Old Software X is version 1.0.7 using runtime SDK 2.0. App.xml as follow :

      <application xmlns="http://ns.adobe.com/air/application/2.0">

      <version>1.0.7</version>

       

      This software X is so, suppose to update to version 1.0.8 which suppose to use the AIR runtime 2.5.

       

      Im using an update.xml file with tags :

      <update xmlns="http://ns.adobe.com/air/framework/update/description/1.0">
             <version>1.0.8</version>

       

      The computer is MacOS X v10.6.6. running the latest AIR RUNTIME 2.5

       

      The new version of the old software X, version 1.0.8, is using an app.xml as follow :

       

      <application xmlns="http://ns.adobe.com/air/application/2.5">
          <versionNumber>1.0.8</versionNumber>
         <publisherID>#my hidden publisherID#</publisherID>

       

      The software X v1.0.8 is using the tag publisherID so the software would be recognized as the same software.

       

      WHAT HAPPEN ?

       

      When I launch the old software X v1.0.7, it is trying to update and raise the error 16824. This error is suppose to mean that my version of the new software does not match the version defined in the update.xml file but to me, its not true... so what is wrong ? Anyone can help ?