6 Replies Latest reply on Jul 16, 2007 6:07 AM by BGarr

    Flex Builder 3 Fouls Flash 9 plugin?

    BGarr
      I installed Flex Builder 3 and the Flash 9 debug player, but the player install seems to have failed (silently), and now I can't seem to get any flavor of Flash player to install on my Intel Mac. Anybody else have similar problems?
        • 1. Re: Flex Builder 3 Fouls Flash 9 plugin?
          sharonma
          Hi BGarr,

          Did you close all the browsers (and applications which use Flash Player) when you install Flex Builder 3? If you still don't see the Flash Player 9,0,60,120, you can try manually installing it from <FB install location>/player/mac directory. Here're some installation/unintallation instructions of Flash Player:
          http://labs.adobe.com/wiki/index.php/Flex_3:Release_Notes#Installing_Flex_SDK_3_beta_1

          thanks,
          Sharon
          • 2. Re: Flex Builder 3 Fouls Flash 9 plugin?
            BGarr Level 1
            Hi Sharon,
            Thank you for the reply. Yes, all browsers were closed. I also ran the mac osx uninstaller after I initially ran into a problem, but it didn't help. I'm still stuck -- can't get any Flash player to work. I've uninstalled Flex Builder 3 (& Flex Builder 2, which had been installed as well & might've caused the problem). I guess now I'll uninstall Flash 9 & will try reinstalling from the media. I'm not too hopeful about that idea, though. Any suggestions would be greatly appreciated.
            One other note: I have Parallels installed (though not running). I wouldn't expect this to affect anything, but just thought I'd make mention of it.
            Cheers,
            Bill Garr
            • 3. Re: Flex Builder 3 Fouls Flash 9 plugin?
              sharonma Level 1
              Hi Bill,

              After uninstall Flash Player 9, you could try rebooting your machine before reinstalling. Also, you may want to make sure that when you reinstall Flash Player, no other applications which may use Flash Player are running. FYI, I also have Parallels installed (not running) on my Mactel and so far I don't have any problem installing/uninstalling FB or Flash Player.

              thanks,
              Sharon
              • 4. Re: Flex Builder 3 Fouls Flash 9 plugin?
                enfluid
                I had the exact same problem. After I installed FlexBuilder 3 (on Intel Mac) I couldn't get any version of flash to install. I tried uninstalling, rebooting, etc., but nothing worked. Finally, I fixed it like this:

                The files that flash player uses are located in user/Library/Internet Plug-ins. It "should" contain two files: Flash Player.plugin and flashplayer.xpt. But after installing FlexBuilder 3, neither file is there.

                What I did was I switched over to my wife's account (on the same computer) and installed flash player there (yes, it successfully installed), then I manually copied those files from her directory over to mine. And now it works!

                Unfortunately, I later realized that the Java Browser plugin also no longer works (although it does work on my wife's account). I suspect it's related to the same issue. I'd like like to know what the cause of this is and find out how to fix it for real.
                • 5. Re: Flex Builder 3 Fouls Flash 9 plugin?
                  pejaham
                  I think there is an ongoing file permissioning problem with the FlashPlayer installer since day one of OS-X. When you install the FlashPlayer as admin (for all users), it will be installed in "/Library/Internet Plug-Ins" but the file permissions are wrong so you can not use it as non-admin (it silently fails). If you install the FlashPlayer as non-admin, it will be installed in "~/Library/Internet-Plug-Ins". I usually install as admin (for all users) and use DiskUtil to fix permissions. Usually it works then.

                  Peter
                  • 6. Re: Flex Builder 3 Fouls Flash 9 plugin?
                    BGarr Level 1
                    I've taken the flash player.plugin file from [CS3]/configuration/plug-ins, and now I can at least play flash movies again. I'd like to be able to play around with Flex 3, though, and use the debug player. Is it possible to post the .plugin file, so folks like me can do a manual install?