9 Replies Latest reply on Sep 27, 2016 11:59 PM by avpromedia

    Missing one audio channel from MXF video

    Cameron O'Rourke Level 1

      Greetings,

       

      I have a bunch of footage shot with a Canon XF300 camera. Two wireless lav mics were feeding into the camera. On the day, I was monitoring audio and am 100% certain that it was recorded correctly. I found a couple of unerased CF cards from the shoot and was able to verify that the audio is good when I pop the CF card into the camera.

       

      However, when I transfer the footage to hard disk and attempt to play it out using either Premier Pro CS5, or VLC, I'm losing channel one of the audio. I've been attempting to troubleshoot, and have found a couple of references on the Web regarding missing audio channel 1 from MXF video files -- but nothing that is relevant to this situation.

       

      I'm on Mac OS X 10.6.6 and am running Premiere Pro CS5 5.0.3. No video cards.

       

      I've tried bringing the files in using: Finder, XF Utility and ShotPutPro. I'm copying the complete directory structure in all cases.

       

      Has anyone seen this problem before? Any troubleshooting thoughts?

       

      Thanks,

      Cameron

        • 1. Re: Missing one audio channel from MXF video
          the_wine_snob Level 9

          IIRC, that camera shoots straight PCM 2-channel at 48KHz 16-bit, so should not be an issue there.

           

          Wonder what MediaInfo has to say about the Audio stream?

           

          With 2-channel Audio, I would not think that much could go wrong, but apparently something is.

           

          Good luck, and hope that folk, who know that camera, will have something better to offer.

           

          Hunt

          • 2. Re: Missing one audio channel from MXF video
            Colin Brougham Level 6

            Cameron,

             

            I don't have one of these cameras--just a couple test clips from an XF305--so my experience with this is not broad. However, I am able to successfully import the clips, and get both audio channels.

             

            When you bring the clips into Premiere, what do you visually see? Are the clips imported with two mono tracks (like a P2 MXF clip would be), or is it stereo? Interestingly, MediaInfo indicates that the audio in the MXFs is two separate mono streams, not a stereo stream, but upon importing the clips into Premiere, the master clip says the audio is stereo. I have the default source channel mapping set to "Use File" in Preferences, so it's a bit of a mystery as to why these are interpreted as stereo. In either case, are you able to see the waveforms of one or both of the audio channels in the Source Monitor "Audio Waveform" view or in the sequence?

             

            Have you tried trashing all of the CFA and PEK files that were generated when the clips were imported? Do this with Premiere closed, and then reopen your project. Let the conforming process finish before attempting anything.

             

            Also, I see that the Canon XF Utility installs its own MPEG2 decoder. This shouldn't affect Premiere, but it might be worth uninstalling that to see if nothing above shows progress. It's conceivable that the XF Utility installs its own MXF splitter, as well, and that might be interfering with Premiere's built-in splitters.

             

            Anyway, no solid ideas, but there are a few things to look into.

            1 person found this helpful
            • 3. Re: Missing one audio channel from MXF video
              Cameron O'Rourke Level 1

              Colin,

               

              Thanks, some great troubleshooting ideas.

               

              So, originally the clips would not play both audio tracks both in premiere, and other video apps like VLC. I've installed the Calibrated MXF importer which adds components to QuickTime -- and I believe this may have modified things...

               

              So in Premiere, I don't know how the clips were importing, but when put on the timeline, only one audio track was present.

               

              The Canon XF utility is not present on this machine. I tried a couple of transcoding utilities, and the resulting QuickTimes were missing the audio channel.

               

              Then I installed the Calibrated MXF importer, and I was able to open the clips in QuickTime and both channels of audio were present. I suspect this might also be somehow altering the way premiere sees the clips as it is now showing 2 channels of audio per clip.

               

              So I'm left with a slight mystery, but it seems that the Calibrated MXF importer does the trick. It is also able to create QuickTime reference movies pointing back to the MFX files which is helpful.

               

              There is another MXF QuickTime component, MXF4Mac, but it is a lot more expensive.

               

              I also see that I can now use PluralEyes with the MXF footage as well -- so lots of advantages to installing an MXF QuickTime component.

               

              Cheers,

              Cameron

              • 4. Re: Missing one audio channel from MXF video
                the_wine_snob Level 9

                Cameron,

                 

                The important thing is that you now have both Audio streams in PrPro. Sometimes, one just needs to run things through a "black box," where some alchemy is performed, away from our prying eyes. Maybe there's a little dude wearing a pointy hat, who waves a magic wand over the MXF files?

                 

                You have found the "black box," and the dang thing works. Thank you for reporting the success, as it will likely help others in the future.

                 

                Good luck,

                 

                Hunt

                • 5. Re: Missing one audio channel from MXF video
                  Colin Brougham Level 6

                  Cameron,

                   

                  Thanks for the report. Glad it's working with the Calibrated importer, but... you shouldn't need that In fact, I think you should submit a bug report because these clips work properly on a PC with no additional components installed; there should be parity between the platforms as far as these clips are concerned. When you installed the Calibrated importer, it took precedence over the built-in importer and splitter in Premiere, but that also will use QuickTime for playback instead of the Premiere decoders, which are 64-bit. You may potentially see a performance hit.

                   

                  It is possible that there is something "else" installed on your machine that is competing with Premiere and VLC as well. I'm able to open these clips in VLC (Windows version), and I get both audio channels. VLC is about as far removed from Premiere as you can get, so it's interesting that it's also (without the Calibrated components) not playing the second audio channel. That's what makes me think that perhaps there is something else on your Mac that is interfering with importing and playback.

                   

                  In any event, you'd obviously need the Calibrated components to enable other workflows, such as with PluralEyes, but for Premiere itself, they shouldn't be necessary. I'd encourage you to submit a bug report (Adobe - Feature Request/Bug Report Form) regarding that issue. In the meantime, is there anything else installed on your Mac that might be a potential candidate for interference?

                  • 6. Re: Missing one audio channel from MXF video
                    Cameron O'Rourke Level 1

                    Further follow up on this issue -- It turns out that the MXF files are coming in with 2 mono audio tracks, and for some reason, in the clip viewer, one of the audio tracks doesn't play, but if you move the clip to the timeline, both audio channels can be heard. Ran into the same issue with Cineform encoded material coming in with two mono audio tracks. So I'm going to file a bug report.

                     

                    Also, I uninstalled the Calibrated MXF Importer, but this had no effect on MXF playback nor Cineform playback.

                     

                    I found that none of this is happening in Final Cut Pro, basically, if QuickTime plays it, then Final Cut plays it.

                     

                    Thanks,
                    Cameron

                    • 7. Re: Missing one audio channel from MXF video
                      Colin Brougham-u9E3Ff Level 1
                      It turns out that the MXF files are coming in with 2 mono audio tracks, and for some reason, in the clip viewer, one of the audio tracks doesn't play, but if you move the clip to the timeline, both audio channels can be heard. Ran into the same issue with Cineform encoded material coming in with two mono audio tracks. So I'm going to file a bug report.

                       

                      Ah, OK... now I understand. No need to file a bug report; maybe a feature request, but a bug report isn't necessary. Here's why:

                       

                      When you bring in clips with mono channels, by default, you only hear the first mono channel when playing back in the Source Monitor. If you toggle over to Audio Waveform view (click the Output button), you can select which of the channels (called "Tracks" which is a little silly, frankly) you want to monitor. Here's what this looks like:

                       

                      audio-waveform.png

                       

                      This applies to any format that has mono channels. If you interpret the footage to stereo (you must do this before you use it in a sequence), you can listen to both channels at once. Of course, then you have to deal with the audio as stereo, which is not always what you want. That's why I do a lot of my editing with MXF material (primarily P2) that has multiple mic sources in a sequence, where I can monitor more than one source channel.

                       

                      In any event, that's why this isn't really a bug; it might be a poor design decision, but it's otherwise working correctly. I'd definitely suggest making a feature request for a "Mixed" or "Plus" audio source option in the Source Monitor. I'm going to do the same.

                       

                      Anyway, I hope that helps explain the issue. Good luck!

                      1 person found this helpful
                      • 8. Re: Missing one audio channel from MXF video
                        Cameron O'Rourke Level 1

                        Colin,

                         

                        Thanks again. So to further clarify, it appears that VNC does the same thing. Which added to my confusion. It turns out that QuickTime does not do this -- all the audio tracks are played concurrently and therefore, all audio tracks play in Final Cut Pro.

                         

                        I just got word from Cineform that there is a specific audio bug they are aware of with Premiere Pro and Cineform. Basically the CF_MOV_Importer (needed to properly bring in Cineform encoded material into Premiere Pro to avoid performance issues) crashes with certain types of files. So for the time being, it looks like my only option is to do this job in Final Cut.

                         

                        I'm guessing at this point that Premier Pro does not use QuickTime for rendering video -- and that is how it can be cross-platform. Hopefully Cineform will get this sorted out because there are some really dynamite reasons to use Cineform I'm discovering.

                         

                        Thanks,
                        Cameron

                        • 9. Re: Missing one audio channel from MXF video
                          avpromedia Level 1

                          Replying a bit late, but I just ran into a similar issue using canon XF305. Basically, when I put the MXF file into VLC player, I hear only one audio channel.

                          Eventually, I found that apparently the MXF file contains two audio streams, each with one channel. For some reason VLC player plays only one of the streams.

                          My solution is to use ffmpeg (which is free) to take the two mono streams and save each into a wav file, like this:

                          ffmpeg -i video.mxf left.wav -map 0:2 right.wav

                           

                          If you prefer, you can also put the two streams into one stereo wav file:

                          ffmpeg -i video.mxf -filter_complex "[0:1] [0:2] amerge" stereo.wav