4 Replies Latest reply on Jan 24, 2011 7:50 AM by docadler

    ??can't install PremiumElements 9

    docadler

      Installed photoshop elements 9 on my Mac 10.6.6 dual core Intel without trouble. trying to install premiere elements 9 however, gets me the warning " payload cannot be installed due to dependent operation failure". Following the suggested help steps gets nowhere. what gives? And what to do?