1 Reply Latest reply on Jan 24, 2011 9:23 AM by Mylenium

    color space AE CS5 Versus AE CS4 = !#%%$

    fredou_79 Level 1

      Hello,

       

      I'm trying to export HD uncompressed 10-bit with color space HDTV (rec.709) clips of VFXs footage that were done on AE CS5.

      My main project file to which I want to integrate them in on AE CS4 which I am using (the AE CS5 render are made by someone else that has it).

       

      My project file settings is in HDTV (rec.709) 16bit with mostly cineform clips, but with a few other VFXs shot that were renderer in HD uncompressed without problems (using CS4). I plan to them export my main project into HD uncompressed

       

      We tried to batch of export:

       

      First one was done in CS5 with HDTV (rec.709) in export settings but the project settings wasn't set to HDTV (rec.709) by the VFXs guy.

      When I imported those clips in my CS4 main project there was difference in color (more golden) and blacks (more crushed).

      You can it with the blacks's difference on the girl's hair and the side planel of the plane and the golden is less ovious on the picture quality but you see it a bit on the woman's face.

       

      AECS5 - render problem color space AVANT.jpg

       

       

      AECS5 - render problem color space APRÈS.jpg

       

      I then proceeded to check color space, and it was imported by default by AE in sRGB IEC611966-2.1.

      I then changed it to HDTV rec.709 using interpret footage; it was a closer match, but not quite.

      I then noticed that all my project's clips, including the HD uncompressed one that I rendered (under CS4) from work done by another VFX artist, were all in HDTV rec.709 YCrCb, but the the imported clips I was trying to match were in HDTV rec.709 only with no YCrCb mention afte them.

       

      I talked with film's colorist and VFXs artist that worked with those projct file from which all the problematic shots comes (because problem is isolated to project file this person worked on), because we both over our head in color space territory.

      We came up the the possible solution that the project setting might have been altered for quicker workflow and not set rigth again.

      We checked and color space wasn't set in setting; colorsit suggested that if it's not set in settings no mather if you set it in your export settings, AE won't allow it and that's why it might have forced RGB, hence the sRGB IEC611966-2.1. It was in 32bit float instead of 16 bit, so that's ok, we initialy suggestedthat it might have been reduced to 8bit for quicker workflow.

       

       

      After this, we proceded to re-render in CS5, bu we found a weird thing that we both don't realy grasp.

       

      After he did the 2nd render (in CS5 still), he tried importing clips with old ones, to compare them to my unafected originals clips, in my CS4 project that he converted in CS5.  It was worst. He then switched off the "blend color using 1.0 gamma"; which my project file didn't have on in CS4. The files are in 32bit float and color space was HDTV (rec.709), but since it's not embed in HD uncompressed files he set them manualy after importing them.

       

      The OLD render batch was matching, but not the NEW ones.

       

      Then he tried importing both render batch in the original project file he exported them from, and it was the NEW batch that now matched.

       

      _______________________________________________

       

      He's now doing test in my main project file in CS4 which is were I'd ultimately like it to work in,

      but if anyone could gives us pointer as to why this is happening and how to make it match with no hassly tat would be great help.

       

      Thank you for your time and interest.

       

      Frédéric

        • 1. Re: color space AE CS5 Versus AE CS4 = !#%%$
          Mylenium Most Valuable Participant

          You've lost me, honestly, but obviously you seem to be close to the solution. Your colorist is mistaken, though, about how AE handles color profiles. It doesn't discard or enforce profiles, it really seems you just forgot to carry them somewhere. Also, since these are different machines, maybe a specific profile was not available. eitehr it was never installed or it is blocked due to permission issues...

           

          Mylenium