4 Replies Latest reply on Feb 11, 2011 3:26 PM by JGaf

    Need help troubleshooting Index creation..

    JGaf Level 1

      Hi,

       

      I'm using RH8, Webhelp, working locally.

       

      I've tried several times to create an index, but each time it crashes.

       

      The first few times, I manually accepted the index keywords.....I'd spend about 25 minutes or so working on it, then RH would freeze on random files (different each time), causing me to reboot RH.  I've lost the entire index because it never completed.

       

      Now, I thought I would test it by just automatically adding the index keywords.......and after about 3-4 minutes of it working through the files, it froze. I can't even minimize the RH window, I have to reboot again.

       

      I've created an index for a previous project with no errors......but this is not the case with this project.

       

      Does anyone have any advice on what could be wrong?  Anything errors I can eliminate? files to test? review? anything?  I don't even know where to begin to troubleshoot this problem.......

       

       

      Thanks!

        • 1. Re: Need help troubleshooting Index creation..
          RoboColum(n) Level 5

          Personally I'd never used the automatic index wizard as it is woefully inadequate. Try deleting the project's CPD file. If that doesn't work, see if anyone else with RoboHelp has the same issue with this project? If they do, or you can't check, are there any special characters in the index keywords?

           


            The RoboColum(n)   @robocolumn   Colum McAndrew
          • 2. Re: Need help troubleshooting Index creation..
            JGaf Level 1

            Yes, I agree.. the create index words automatically is terrible.  I was just trying ANYTHING to get an index created. 

             

            I've removed the .cpd file...and also set my Options to automatically delete and create.  Unfortunately, this didn't work and my index creation continues to fail.  I can't even create an index on ONE folder.  After I select a word to add to the index and hit "Next" it just hangs.........even when there's no other file to be index.

             

            No problems on adding an individual word to the index by selecting the "key" icon from the index toolbar.

             

             

            I'm the lone writer, there's no one else who can try to create the index.  So far, I haven't seen any special characters in the index keywords. In fact, the one folder I tested (above) contained nothing but alpha characters....

            • 3. Re: Need help troubleshooting Index creation..
              VikramGaur Adobe Employee

              Hello JGaf,

               

              Did you tried to create Index on a different project (new project)

               

              Please let me know on which Operating System you are working (Windows or MAC)

               

              Need to know the configuration (RAM or is it a 64bit or 32 bit)

               

              Thanks

              Vikram

              • 4. Re: Need help troubleshooting Index creation..
                JGaf Level 1

                HI,

                 

                Just following up....

                 

                1 - Yes, I have successfully created an index on a completely different project.

                 

                2 - Windows xp, 32.

                 

                 

                I need to revisit this issue in a couple of months, I have other things to tend to.  I'll post back my "next attempts" on creating an index.

                 

                but, if there's someone out there with an answer, by all means.........please share!

                 

                Thanks!